aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2014-07-03 05:52:11 +0800
committermarino <marino@FreeBSD.org>2014-07-03 05:52:11 +0800
commit64d9b1d1c09e709f31165f32f2e82f70d56a6972 (patch)
tree02b26ca5812e14395c1b1542ad27228537363cf1 /mail
parent185d9af108ac13bd7fd67250894ac72439207c6c (diff)
downloadfreebsd-ports-gnome-64d9b1d1c09e709f31165f32f2e82f70d56a6972.tar.gz
freebsd-ports-gnome-64d9b1d1c09e709f31165f32f2e82f70d56a6972.tar.zst
freebsd-ports-gnome-64d9b1d1c09e709f31165f32f2e82f70d56a6972.zip
mail/courier: Unbreak F10+, add stage support and remove interactivity
PR: 190209 Submitted by: maintainer (Milan Obuch) Verified by: Redports 8x pass
Diffstat (limited to 'mail')
-rw-r--r--mail/courier/Makefile103
-rw-r--r--mail/courier/Makefile.man73
-rw-r--r--mail/courier/files/pkg-install.in51
-rw-r--r--mail/courier/files/pkg-message.in118
-rw-r--r--mail/courier/pkg-plist238
5 files changed, 285 insertions, 298 deletions
diff --git a/mail/courier/Makefile b/mail/courier/Makefile
index f3fc0e5e8e03..95b05c62601c 100644
--- a/mail/courier/Makefile
+++ b/mail/courier/Makefile
@@ -26,10 +26,6 @@ CONFLICTS= courier-imap-2.* couriermlm-0.* \
smail-3.* sqwebmail-3.* \
zmailer-2.*
-.if !defined(BATCH) && !defined(PACKAGE_BUILDING)
-IS_INTERACTIVE= yes
-.endif
-
#
# User-serviceable variables
#
@@ -40,10 +36,13 @@ IS_INTERACTIVE= yes
# set MAILDROPDEFAULT to what you'd like the $DEFAULT in maildrop to be
# recomended values are: /var/mail, ./Mailbox or ./Maildir
#
+
IMAGEURL?= /webmail
CACHEOWN?= pop
MAILDROPDEFAULT?=./Maildir
+
# End of user-serviceable variables
+
MAILOWN= courier
MAILGRP= courier
MAILUID= 465
@@ -57,13 +56,12 @@ CALENDIR= /var/spool/calendar
MIMETYPES= ${LOCALBASE}/etc/mime.types
WITH_TRANSPORT= local esmtp dsn
-USE_AUTOTOOLS= libtool aclocal automake
AUTOMAKE_ARGS= --add-missing
+USE_AUTOTOOLS= libtool aclocal automake
USE_BZIP2= yes
-USE_GCC= any
-USES= fam gettext gmake perl5 pkgconfig
USE_OPENSSL= yes
USE_SUBMAKE= yes
+USES= fam gettext gmake perl5 pkgconfig
USE_RC_SUBR= courier
@@ -106,16 +104,17 @@ PLIST_SUB+= BINOWN="${BINOWN}" BINGRP="${BINGRP}" \
CACHEOWN="${CACHEOWN}" CACHEDIR="${CACHEDIR}" \
CALENDIR="${CALENDIR}" LOCALSTATEDIR="${LOCALSTATEDIR}"
SUB_LIST:= ${PLIST_SUB}
-SUB_FILES+= pkg-install pkg-message crontab sharedindexupdate
-
-OPTIONS_DEFINE= LDAP GNUPG PROCMAIL SENDFAX UUCP IPV6 MAILDROPFLAGS \
- WEBMAILFLAGS WEBMAILRSENT
-OPTIONS_GROUP= EXPERIMENTAL
-OPTIONS_GROUP_EXPERIMENTAL= WEBMAILXFACE
+SUB_FILES+= pkg-message crontab sharedindexupdate
+#SUB_FILES+= pkg-install pkg-message crontab sharedindexupdate
+
+OPTIONS_DEFINE= LDAP PROCMAIL SENDFAX UUCP IPV6 MAILDROPFLAGS
+OPTIONS_GROUP= WEBMAIL
+#OPTIONS_GROUP= SYSTEM WEBMAIL
+#OPTIONS_GROUP_SYSTEM= RCCONF MAILCONF PERIODIC
+OPTIONS_GROUP_WEBMAIL= GNUPG WEBMAILRSENT WEBMAILFLAGS WEBMAILXFACE
OPTIONS_RADIO= ALIASES SPELL
OPTIONS_RADIO_ALIASES= SYSTEMALIASES EMPTYALIASES
OPTIONS_RADIO_SPELL= ASPELL ISPELL
-
OPTIONS_DEFAULT=WEBMAILRSENT SYSTEMALIASES
LDAP_DESC= LDAP-based mail aliasing support
@@ -126,18 +125,24 @@ PROCMAIL_DESC= Procmail local delivery support
SENDFAX_DESC= mgetty+sendfax support
UUCP_DESC= UUCP support
MAILDROPFLAGS_DESC= maildrop set flags patch
+WEBMAILRSENT_DESC= enable Autorename Sent folder
WEBMAILFLAGS_DESC= webmail show flags patch
WEBMAILXFACE_DESC= experimental webmail X-Face patch
-WEBMAILRSENT_DESC= enable Autorename Sent folder
SYSTEMALIASES_DESC= symlink system /etc/aliases
EMPTYALIASES_DESC= create empty aliases file
+RCCONF_DESC= modify rc.conf to enable courier/disable sendmail
+MAILCONF_DESC= modify mailer.conf to use courier instead of sendmail
+PERIODIC_DESC= modify/create periodic.conf
-NO_STAGE= yes
.include <bsd.port.options.mk>
+
.include "${.CURDIR}/Makefile.doc"
-.include "${.CURDIR}/Makefile.man"
.include "${.CURDIR}/Makefile.own"
+.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1000000
+USE_GCC= 4.6
+.endif
+
.if ${PORT_OPTIONS:MLDAP}
USE_OPENLDAP= yes
WITH_AUTH_LDAP= yes
@@ -243,6 +248,24 @@ CONFIGURE_ARGS+=--enable-autorenamesent
CONFIGURE_ARGS+=--disable-autorenamesent
.endif
+.if ${PORT_OPTIONS:MMAILCONF}
+SUB_LIST+= MAILCONF="y"
+.else
+SUB_LIST+= MAILCONF="n"
+.endif
+
+.if ${PORT_OPTIONS:MRCCONF}
+SUB_LIST+= RCCONF="y"
+.else
+SUB_LIST+= RCCONF="n"
+.endif
+
+.if ${PORT_OPTIONS:MPERIODIC}
+SUB_LIST+= PERIODIC="y"
+.else
+SUB_LIST+= PERIODIC="n"
+.endif
+
pre-everything::
@${ECHO_MSG} "===> --------------------------------------------------------"
@${ECHO_MSG} "===> Run 'make config' to (re)configure ${PKGNAME}"
@@ -306,44 +329,28 @@ post-build:
@${LN} -f ${WRKSRC}/webmail/SECURITY.html ${WRKSRC}/webmail/SECURITY.webmail.html
post-install:
- @${LN} -f ${SYSCONFDIR}/maildrop ${SYSCONFDIR}/maildropfilter
- @${INSTALL_DATA} /dev/null ${SYSCONFDIR}/locallowercase
- @${INSTALL_DATA} ${WRKDIR}/crontab ${SYSCONFDIR}/
- @${INSTALL_SCRIPT} ${WRKDIR}/sharedindexupdate ${DATADIR}/
+ @${LN} -f ${STAGEDIR}${SYSCONFDIR}/maildrop ${STAGEDIR}${SYSCONFDIR}/maildropfilter
+ @${INSTALL_DATA} /dev/null ${STAGEDIR}${SYSCONFDIR}/locallowercase
+ @${INSTALL_DATA} ${WRKDIR}/crontab ${STAGEDIR}${SYSCONFDIR}/
+ @${INSTALL_SCRIPT} ${WRKDIR}/sharedindexupdate ${STAGEDIR}${DATADIR}/
.for file in ${OWNER0}
- @-${CHOWN} -Rh ${BINOWN}:${BINGRP} ${PREFIX}/${file}
+ @-${CHOWN} -Rh ${BINOWN}:${BINGRP} ${STAGEDIR}${PREFIX}/${file}
.endfor
- @${GREP} '^@exec ' ${TMPPLIST} \
- | ${SED} -e 's:^@exec ::' -e 's:%D:${PREFIX}:g' \
- > ${WRKDIR}/.PLIST.exec \
- && ${SH} ${WRKDIR}/.PLIST.exec
.if ${PORT_OPTIONS:MDOCS}
- @${INSTALL} ${_DOCOWNGRP} -d ${DOCSDIR}/html
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ @${INSTALL} ${_DOCOWNGRP} -d ${STAGEDIR}${DOCSDIR}/html
.for f in ${DOCS}
- @${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
.endfor
.for f in ${HTMLDOCS}
- @${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}/html
+ @${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}/html
.endfor
- @${INSTALL_DATA} ${DATADIR}/htmldoc/* ${DOCSDIR}/html
-.endif
- @${RM} -rf ${DATADIR}/htmldoc
- @-${CHOWN} -Rh ${SHAREOWN}:${SHAREGRP} ${DATADIR}
- @${CHMOD} -R a+r ${DATADIR}/courierwebadmin
- @${CHMOD} -R a-w ${DATADIR} ${LIBEXECDIR}/courier
- @${CHMOD} 550 ${LIBEXECDIR}/courier/modules/esmtp/courieresmtp*
- @${ECHO_MSG}
- @${CAT} ${PKGMESSAGE}
- @${ECHO_MSG}
-.if defined(BATCH) || defined(PACKAGE_BUILDING)
- @${ECHO_MSG} " To activate Courier in /etc/mail/mailer.conf or to"
- @${ECHO_MSG} " replace {sendmail,mailq,newaliases} with Courier"
- @${ECHO_MSG} " versions execute the following as root user:"
- @${ECHO_MSG}
- @${ECHO_MSG} "PKG_PREFIX=\"${PREFIX}\" ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL"
- @${ECHO_MSG}
-.else
- @PKG_PREFIX="${PREFIX}" ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+ @${INSTALL_DATA} ${STAGEDIR}${DATADIR}/htmldoc/* ${STAGEDIR}${DOCSDIR}/html
.endif
+ @${RM} -rf ${STAGEDIR}${DATADIR}/htmldoc
+ @-${CHOWN} -Rh ${SHAREOWN}:${SHAREGRP} ${STAGEDIR}${DATADIR}
+ @${CHMOD} -R a+r ${STAGEDIR}${DATADIR}/courierwebadmin
+ @${CHMOD} -R a-w ${STAGEDIR}${DATADIR} ${STAGEDIR}${LIBEXECDIR}/courier
+ @${CHMOD} 550 ${STAGEDIR}${LIBEXECDIR}/courier/modules/esmtp/courieresmtp*
.include <bsd.port.mk>
diff --git a/mail/courier/Makefile.man b/mail/courier/Makefile.man
deleted file mode 100644
index dd6def1c6ef7..000000000000
--- a/mail/courier/Makefile.man
+++ /dev/null
@@ -1,73 +0,0 @@
-MAN1= \
- cancelmsg.1 \
- couriermlm.1 \
- couriertcpd.1 \
- couriertls.1 \
- dot-forward.1 \
- lockmail.1 \
- mailbot.1 \
- maildiracl.1 \
- maildirkw.1 \
- maildirmake.1 \
- maildrop.1 \
- mailq.1 \
- makedat.1 \
- makemime.1 \
- mimegpg.1 \
- preline.1 \
- reformail.1 \
- reformime.1 \
- sendmail.1 \
- testmxlookup.1 \
- webmlmd.1
-MAN5= \
- dot-courier.5 \
- maildir.5
-MAN7= \
- localmailfilter.7 \
- maildirquota.7 \
- maildropex.7 \
- maildropfilter.7 \
- maildropgdbm.7
-MAN8= \
- aliaslookup.8 \
- courier.8 \
- courierfilter.8 \
- courierldapaliasd.8 \
- courierperlfilter.8 \
- courierpop3d.8 \
- deliverquota.8 \
- dupfilter.8 \
- esmtpd.8 \
- imapd.8 \
- makeacceptmailfor.8 \
- makealiases.8 \
- makehosteddomains.8 \
- makepercentrelay.8 \
- makesmtpaccess.8 \
- mkesmtpdcert.8 \
- mkimapdcert.8 \
- mkpop3dcert.8 \
- pop3d.8 \
- pop3d-ssl.8 \
- submit.8
-
-MLINKS= dot-forward.1 dotforward.1 \
- sendmail.1 rmail.1 \
- courierfilter.8 filterctl.8 \
- courierpop3d.8 courierpop3login.8 \
- esmtpd.8 esmtpd-msa.8 \
- makesmtpaccess.8 makesmtpaccess-msa.8
-
-.if defined(WITH_LDAP) && !defined(WITHOUT_LDAP)
-#MAN8+= courierldapaliasd.8
-.endif
-
-.if defined(WITH_SENDFAX) && !defined(WITHOUT_SENDFAX)
-MAN8+= courierfax.8
-.endif
-
-.if defined(WITH_UUCP) && !defined(WITHOUT_UUCP)
-MAN8+= courieruucp.8
-MLINKS+=courieruucp.8 makeuucpneighbors.8
-.endif
diff --git a/mail/courier/files/pkg-install.in b/mail/courier/files/pkg-install.in
index 3c3cf76b9886..4bef2bc5f73a 100644
--- a/mail/courier/files/pkg-install.in
+++ b/mail/courier/files/pkg-install.in
@@ -8,53 +8,10 @@ PKG_PREFIX=${PKG_PREFIX:=/usr/local}
USER=%%MAILOWN%%; UID=%%MAILUID%%
GROUP=%%MAILGRP%%; GID=%%MAILGID%%
-ask() {
- local question default answer
-
- question=$1
- default=$2
- if [ -z "${PACKAGE_BUILDING}" ]; then
- read -p "${question} [${default}]? " answer
- fi
- if [ -z "${answer}" ]; then
- answer=${default}
- fi
- echo ${answer}
-}
-
-yesno() {
- local question default answer
-
- question=$1
- default=$2
- while :; do
- answer=$(ask "${question}" "${default}")
- case "${answer}" in
- [Yy]*) return 0;;
- [Nn]*) return 1;;
- esac
- echo "Please answer yes or no."
- done
-}
-
-replace() {
- local orig repl
-
- orig=$1
- repl=$2
- if [ -e ${orig} ]; then
- mv -f ${orig} ${orig}.OFF
- chmod 0 ${orig}.OFF
- fi
- if [ -e ${repl} ]; then
- ln -s ${repl} ${orig}
- fi
-}
-
if [ ":$2" = ":POST-INSTALL" ]; then
- if yesno "Would you like to activate Courier in /etc/mail/mailer.conf" n; then
+ if [ "%%MAILCONF%%" = "y" ]; then
mv -f /etc/mail/mailer.conf /etc/mail/mailer.conf.old
- echo "#" > /etc/mail/mailer.conf
+ echo "# created by courier's pkg-install" > /etc/mail/mailer.conf
echo -n "# Execute the Courier sendmail program" >> /etc/mail/mailer.conf
echo ", named ${PKG_PREFIX}/bin/sendmail" >> /etc/mail/mailer.conf
echo "#" >> /etc/mail/mailer.conf
@@ -64,4 +21,8 @@ if [ ":$2" = ":POST-INSTALL" ]; then
echo "newaliases ${PKG_PREFIX}/sbin/makealiases" >> /etc/mail/mailer.conf
echo "Done."
fi
+ if [ "%%RCCONF%%" = "y" ]; then
+ fi
+ if [ "%%PERIODIC%%" = "y" ]; then
+ fi
fi
diff --git a/mail/courier/files/pkg-message.in b/mail/courier/files/pkg-message.in
index ec6cc1fdf387..181923cb2de8 100644
--- a/mail/courier/files/pkg-message.in
+++ b/mail/courier/files/pkg-message.in
@@ -1,58 +1,60 @@
- RTFM before configuring and running Courier!!!
-
- Check and/or modify the following configuration files to
- suit your needs:
-
- %%PREFIX%%/etc/courier/courierd
- %%PREFIX%%/etc/courier/esmtpd
- %%PREFIX%%/etc/courier/esmtpd-msa
- %%PREFIX%%/etc/courier/esmtpd-ssl
-%%WITHFAX%% %%PREFIX%%/etc/courier/faxcoverpage.tr
-%%WITHFAX%% %%PREFIX%%/etc/courier/faxnotifyrc
-%%WITHFAX%% %%PREFIX%%/etc/courier/faxrc
- %%PREFIX%%/etc/courier/imapd
- %%PREFIX%%/etc/courier/imapd-ssl
- %%PREFIX%%/etc/courier/ldapaddressbook
-%%WITHLDAP%% %%PREFIX%%/etc/courier/ldapaliasrc
- %%PREFIX%%/etc/courier/pop3d
- %%PREFIX%%/etc/courier/pop3d-ssl
-
- Do not forget to update /etc/pam.d/ or /etc/pam.conf with
- the contents of %%PREFIX%%/etc/courier/*.authpam.
-
- To enable Courier-MTA to start at boot time,
- set these variables in your /etc/rc.conf file:
-
- courier_enable="YES"
- sendmail_enable="NONE"
-
- Note: in newer OS versions you should change variables
- used in /etc/rc.conf file, as NONE for sendmail_enable
- is deprecated and will be not supported in future:
-
- courier_enable="YES"
- sendmail_enable="NO"
- sendmail_submit_enable="NO"
- sendmail_outbound_enable="NO"
- sendmail_msp_queue_enable="NO"
-
- Also, you will want to disable some Sendmail
- specific daily maintenance routines in your
- /etc/periodic.conf file:
-
- daily_clean_hoststat_enable="NO"
- daily_status_mail_rejects_enable="NO"
- daily_status_include_submit_mailq="NO"
- daily_submit_queuerun="NO"
-
- Documentation (if installed locally) is located in
- %%DOCSDIR%%/ otherwise see
- http://www.Courier-MTA.org/
-
- If you are planning to serve shared maildirs, then
- you should create a cron job that runs at regular
- intervals (once every few hours is fine) that
- executes the following script to update the
- shared folder index:
-
- %%PREFIX%%/share/courier/sharedindexupdate
+ RTFM before configuring and running Courier!!!
+
+Check and/or modify the following configuration files to suit your needs:
+
+ %%PREFIX%%/etc/courier/courierd
+ %%PREFIX%%/etc/courier/esmtpd
+ %%PREFIX%%/etc/courier/esmtpd-msa
+ %%PREFIX%%/etc/courier/esmtpd-ssl
+%%WITHFAX%% %%PREFIX%%/etc/courier/faxcoverpage.tr
+%%WITHFAX%% %%PREFIX%%/etc/courier/faxnotifyrc
+%%WITHFAX%% %%PREFIX%%/etc/courier/faxrc
+ %%PREFIX%%/etc/courier/imapd
+ %%PREFIX%%/etc/courier/imapd-ssl
+ %%PREFIX%%/etc/courier/ldapaddressbook
+%%WITHLDAP%% %%PREFIX%%/etc/courier/ldapaliasrc
+ %%PREFIX%%/etc/courier/pop3d
+ %%PREFIX%%/etc/courier/pop3d-ssl
+
+Do not forget to update /etc/pam.d/ or /etc/pam.conf with the contents of
+%%PREFIX%%/etc/courier/*.authpam.
+
+To enable Courier-MTA to start at boot time, set these variables in your
+/etc/rc.conf file:
+
+ courier_enable="YES"
+ sendmail_enable="NONE"
+
+Note: as in newer OS versions NONE for sendmail_enable is deprecated and
+will be not supported in future, use following instead:
+
+ courier_enable="YES"
+ sendmail_enable="NO"
+ sendmail_submit_enable="NO"
+ sendmail_outbound_enable="NO"
+ sendmail_msp_queue_enable="NO"
+
+Usually editing /etc/mail/mailer.conf is necessary, too, so it contains
+following lines:
+
+ sendmail %%PREFIX%%/bin/sendmail
+ send-mail %%PREFIX%%/bin/sendmail
+ mailq %%PREFIX%%/bin/mailq
+ newaliases %%PREFIX%%/sbin/makealiases
+
+Also, you will want to disable some Sendmail specific daily maintenance
+routines in your /etc/periodic.conf file:
+
+ daily_clean_hoststat_enable="NO"
+ daily_status_mail_rejects_enable="NO"
+ daily_status_include_submit_mailq="NO"
+ daily_submit_queuerun="NO"
+
+Documentation (if installed locally) is located in %%DOCSDIR%%,
+otherwise see http://www.Courier-MTA.org/
+
+If you are planning to serve shared maildirs, then you should create a cron
+job that runs at regular intervals (once every few hours is fine) that
+executes the following script to update the shared folder index:
+
+ %%PREFIX%%/share/courier/sharedindexupdate
diff --git a/mail/courier/pkg-plist b/mail/courier/pkg-plist
index a886094989f4..6025045504b9 100644
--- a/mail/courier/pkg-plist
+++ b/mail/courier/pkg-plist
@@ -22,23 +22,12 @@
@exec install -o %%MAILOWN%% -g %%MAILGRP%% -m 0700 -d %D/etc/courier/webadmin/added
@exec install -o %%MAILOWN%% -g %%MAILGRP%% -m 0700 -d %D/etc/courier/webadmin/removed
@unexec rm -f %D/etc/courier/*.dat 2>/dev/null || true
-@unexec cmp -s %D/etc/courier/courierd %D/etc/courier/courierd.dist && rm -f %D/etc/courier/courierd 2>/dev/null || true
-@unexec cmp -s %D/etc/courier/esmtpd-msa %D/etc/courier/esmtpd-msa.dist && rm -f %D/etc/courier/esmtpd-msa 2>/dev/null || true
-@unexec cmp -s %D/etc/courier/esmtpd-ssl %D/etc/courier/esmtpd-ssl.dist && rm -f %D/etc/courier/esmtpd-ssl 2>/dev/null || true
-@unexec cmp -s %D/etc/courier/esmtpd %D/etc/courier/esmtpd.dist && rm -f %D/etc/courier/esmtpd 2>/dev/null || true
-%%WITHFAX%%@unexec cmp -s %D/etc/courier/faxcoverpage.tr %D/etc/courier/faxcoverpage.tr.dist && rm -f %D/etc/courier/faxcoverpage.tr 2>/dev/null || true
-%%WITHFAX%%@unexec cmp -s %D/etc/courier/faxnotifyrc %D/etc/courier/faxnotifyrc.dist && rm -f %D/etc/courier/faxnotifyrc 2>/dev/null || true
-%%WITHFAX%%@unexec cmp -s %D/etc/courier/faxrc %D/etc/courier/faxrc.dist && rm -f %D/etc/courier/faxrc 2>/dev/null || true
-@unexec cmp -s %D/etc/courier/imapd-ssl %D/etc/courier/imapd-ssl.dist && rm -f %D/etc/courier/imapd-ssl 2>/dev/null || true
-@unexec cmp -s %D/etc/courier/imapd %D/etc/courier/imapd.dist && rm -f %D/etc/courier/imapd 2>/dev/null || true
-@unexec cmp -s %D/etc/courier/ldapaddressbook %D/etc/courier/ldapaddressbook.dist && rm -f %D/etc/courier/ldapaddressbook 2>/dev/null || true
-%%WITHLDAP%%@unexec cmp -s %D/etc/courier/ldapaliasrc %D/etc/courier/ldapaliasrc.dist && rm -f %D/etc/courier/ldapaliasrc 2>/dev/null || true
-@unexec cmp -s %D/etc/courier/pop3d-ssl %D/etc/courier/pop3d-ssl.dist && rm -f %D/etc/courier/pop3d-ssl 2>/dev/null || true
-@unexec cmp -s %D/etc/courier/pop3d %D/etc/courier/pop3d.dist && rm -f %D/etc/courier/pop3d 2>/dev/null || true
-@unexec cmp -s %D/etc/courier/sqwebmaild %D/etc/courier/sqwebmaild.dist && rm -f %D/etc/courier/sqwebmaild 2>/dev/null || true
-@unexec cmp -s %D/etc/courier/webmlmrc %D/etc/courier/webmlmrc.dist && rm -f %D/etc/courier/webmlmrc 2>/dev/null || true
bin/addcr
+@owner %%MAILOWN%%
+@group %%MAILGRP%%
bin/cancelmsg
+@owner
+@group
bin/courier-config
bin/couriermlm
bin/couriertls
@@ -63,7 +52,13 @@ bin/sendmail
bin/testmxlookup
bin/webmlmd
bin/webmlmd.rc
+etc/courier/aliases/system
+%%WITHSYSTEMALIASES%%@exec [ -e /etc/aliases ] && ln -sf /etc/aliases %D/etc/courier/aliases/system
+%%WITHEMPTYALIASES%%@exec true > %D/etc/courier/aliases/system
+@unexec cmp -s %D/etc/courier/courierd %D/etc/courier/courierd.dist && rm -f %D/etc/courier/courierd 2>/dev/null || true
etc/courier/courierd.dist
+@exec [ -f %D/etc/courier/courierd.dist ] && %%LOCALBASE%%/share/sysconftool/sysconftool %D/etc/courier/courierd.dist
+@comment etc/courier/courierd
etc/courier/crontab
etc/courier/dsndelayed.txt
etc/courier/dsndelivered.txt
@@ -76,19 +71,49 @@ etc/courier/dsnsubjectwarn.txt
etc/courier/enablefiltering
etc/courier/esmtp.authpam
etc/courier/esmtpauthclient
+@unexec cmp -s %D/etc/courier/esmtpd-msa %D/etc/courier/esmtpd-msa.dist && rm -f %D/etc/courier/esmtpd-msa 2>/dev/null || true
etc/courier/esmtpd-msa.dist
+@exec [ -f %D/etc/courier/esmtpd-msa.dist ] && %%LOCALBASE%%/share/sysconftool/sysconftool %D/etc/courier/esmtpd-msa.dist
+@comment etc/courier/esmtpd-msa
+@unexec cmp -s %D/etc/courier/esmtpd-ssl %D/etc/courier/esmtpd-ssl.dist && rm -f %D/etc/courier/esmtpd-ssl 2>/dev/null || true
etc/courier/esmtpd-ssl.dist
+@exec [ -f %D/etc/courier/esmtpd-ssl.dist ] && %%LOCALBASE%%/share/sysconftool/sysconftool %D/etc/courier/esmtpd-ssl.dist
+@comment etc/courier/esmtpd-ssl
etc/courier/esmtpd.cnf
+@unexec cmp -s %D/etc/courier/esmtpd %D/etc/courier/esmtpd.dist && rm -f %D/etc/courier/esmtpd 2>/dev/null || true
etc/courier/esmtpd.dist
+@exec [ -f %D/etc/courier/esmtpd.dist ] && %%LOCALBASE%%/share/sysconftool/sysconftool %D/etc/courier/esmtpd.dist
+@comment etc/courier/esmtpd
+%%WITHFAX%%@unexec cmp -s %D/etc/courier/faxcoverpage.tr %D/etc/courier/faxcoverpage.tr.dist && rm -f %D/etc/courier/faxcoverpage.tr 2>/dev/null || true
%%WITHFAX%%etc/courier/faxcoverpage.tr.dist
+%%WITHFAX%%@exec [ -f %D/etc/courier/faxcoverpage.tr.dist ] && %%LOCALBASE%%/share/sysconftool/sysconftool %D/etc/courier/faxcoverpage.tr.dist
+%%WITHFAX%%@comment etc/courier/faxcoverpage.tr
+%%WITHFAX%%@unexec cmp -s %D/etc/courier/faxnotifyrc %D/etc/courier/faxnotifyrc.dist && rm -f %D/etc/courier/faxnotifyrc 2>/dev/null || true
%%WITHFAX%%etc/courier/faxnotifyrc.dist
+%%WITHFAX%%@exec [ -f %D/etc/courier/faxnotifyrc.dist ] && %%LOCALBASE%%/share/sysconftool/sysconftool %D/etc/courier/faxnotifyrc.dist
+%%WITHFAX%%@comment etc/courier/faxnotifyrc
+%%WITHFAX%%@unexec cmp -s %D/etc/courier/faxrc %D/etc/courier/faxrc.dist && rm -f %D/etc/courier/faxrc 2>/dev/null || true
%%WITHFAX%%etc/courier/faxrc.dist
+%%WITHFAX%%@exec [ -f %D/etc/courier/faxrc.dist ] && %%LOCALBASE%%/share/sysconftool/sysconftool %D/etc/courier/faxrc.dist
+%%WITHFAX%%@comment etc/courier/faxrc
+@unexec cmp -s %D/etc/courier/imapd-ssl %D/etc/courier/imapd-ssl.dist && rm -f %D/etc/courier/imapd-ssl 2>/dev/null || true
etc/courier/imapd-ssl.dist
+@exec [ -f %D/etc/courier/imapd-ssl.dist ] && %%LOCALBASE%%/share/sysconftool/sysconftool %D/etc/courier/imapd-ssl.dist
+@comment etc/courier/imapd-ssl
etc/courier/imapd.authpam
etc/courier/imapd.cnf
+@unexec cmp -s %D/etc/courier/imapd %D/etc/courier/imapd.dist && rm -f %D/etc/courier/imapd 2>/dev/null || true
etc/courier/imapd.dist
+@exec [ -f %D/etc/courier/imapd.dist ] && %%LOCALBASE%%/share/sysconftool/sysconftool %D/etc/courier/imapd.dist
+@comment etc/courier/imapd
+@unexec cmp -s %D/etc/courier/ldapaddressbook %D/etc/courier/ldapaddressbook.dist && rm -f %D/etc/courier/ldapaddressbook 2>/dev/null || true
etc/courier/ldapaddressbook.dist
+@exec [ -f %D/etc/courier/ldapaddressbook.dist ] && %%LOCALBASE%%/share/sysconftool/sysconftool %D/etc/courier/ldapaddressbook.dist
+@comment etc/courier/ldapaddressbook
+%%WITHLDAP%%@unexec cmp -s %D/etc/courier/ldapaliasrc %D/etc/courier/ldapaliasrc.dist && rm -f %D/etc/courier/ldapaliasrc 2>/dev/null || true
%%WITHLDAP%%etc/courier/ldapaliasrc.dist
+%%WITHLDAP%%@exec [ -f %D/etc/courier/ldapaliasrc.dist ] && %%LOCALBASE%%/share/sysconftool/sysconftool %D/etc/courier/ldapaliasrc.dist
+%%WITHLDAP%%@comment etc/courier/ldapaliasrc
etc/courier/locallowercase
etc/courier/maildrop
etc/courier/maildropfilter
@@ -97,37 +122,31 @@ etc/courier/module.esmtp
%%WITHFAX%%etc/courier/module.fax
etc/courier/module.local
%%WITHUUCP%%etc/courier/module.uucp
+@unexec cmp -s %D/etc/courier/pop3d-ssl %D/etc/courier/pop3d-ssl.dist && rm -f %D/etc/courier/pop3d-ssl 2>/dev/null || true
etc/courier/pop3d-ssl.dist
+@exec [ -f %D/etc/courier/pop3d-ssl.dist ] && %%LOCALBASE%%/share/sysconftool/sysconftool %D/etc/courier/pop3d-ssl.dist
+@comment etc/courier/pop3d-ssl
etc/courier/pop3d.authpam
etc/courier/pop3d.cnf
+@unexec cmp -s %D/etc/courier/pop3d %D/etc/courier/pop3d.dist && rm -f %D/etc/courier/pop3d 2>/dev/null || true
etc/courier/pop3d.dist
+@exec [ -f %D/etc/courier/pop3d.dist ] && %%LOCALBASE%%/share/sysconftool/sysconftool %D/etc/courier/pop3d.dist
+@comment etc/courier/pop3d
etc/courier/quotawarnmsg.example
etc/courier/rfcerr2045.txt
etc/courier/rfcerr2046.txt
etc/courier/rfcerr2047.txt
etc/courier/rfcerrheader.txt
etc/courier/smtpaccess/default
+@unexec cmp -s %D/etc/courier/sqwebmaild %D/etc/courier/sqwebmaild.dist && rm -f %D/etc/courier/sqwebmaild 2>/dev/null || true
etc/courier/sqwebmaild.dist
+@exec [ -f %D/etc/courier/sqwebmaild.dist ] && %%LOCALBASE%%/share/sysconftool/sysconftool %D/etc/courier/sqwebmaild.dist
+@comment etc/courier/sqwebmaild
etc/courier/webmail.authpam
+@unexec cmp -s %D/etc/courier/webmlmrc %D/etc/courier/webmlmrc.dist && rm -f %D/etc/courier/webmlmrc 2>/dev/null || true
etc/courier/webmlmrc.dist
-%%WITHSYSTEMALIASES%%@exec [ -e /etc/aliases ] && ln -sf /etc/aliases %D/etc/courier/aliases/system
-%%WITHEMPTYALIASES%%@exec true > %D/etc/courier/aliases/system
-@unexec rm -f %D/etc/courier/aliases/system
-@exec [ -f %D/etc/courier/courierd.dist ] && %%LOCALBASE%%/share/sysconftool/sysconftool %D/etc/courier/courierd.dist
-@exec [ -f %D/etc/courier/esmtpd-msa.dist ] && %%LOCALBASE%%/share/sysconftool/sysconftool %D/etc/courier/esmtpd-msa.dist
-@exec [ -f %D/etc/courier/esmtpd-ssl.dist ] && %%LOCALBASE%%/share/sysconftool/sysconftool %D/etc/courier/esmtpd-ssl.dist
-@exec [ -f %D/etc/courier/esmtpd.dist ] && %%LOCALBASE%%/share/sysconftool/sysconftool %D/etc/courier/esmtpd.dist
-%%WITHFAX%%@exec [ -f %D/etc/courier/faxcoverpage.tr.dist ] && %%LOCALBASE%%/share/sysconftool/sysconftool %D/etc/courier/faxcoverpage.tr.dist
-%%WITHFAX%%@exec [ -f %D/etc/courier/faxnotifyrc.dist ] && %%LOCALBASE%%/share/sysconftool/sysconftool %D/etc/courier/faxnotifyrc.dist
-%%WITHFAX%%@exec [ -f %D/etc/courier/faxrc.dist ] && %%LOCALBASE%%/share/sysconftool/sysconftool %D/etc/courier/faxrc.dist
-@exec [ -f %D/etc/courier/imapd-ssl.dist ] && %%LOCALBASE%%/share/sysconftool/sysconftool %D/etc/courier/imapd-ssl.dist
-@exec [ -f %D/etc/courier/imapd.dist ] && %%LOCALBASE%%/share/sysconftool/sysconftool %D/etc/courier/imapd.dist
-@exec [ -f %D/etc/courier/ldapaddressbook.dist ] && %%LOCALBASE%%/share/sysconftool/sysconftool %D/etc/courier/ldapaddressbook.dist
-%%WITHLDAP%%@exec [ -f %D/etc/courier/ldapaliasrc.dist ] && %%LOCALBASE%%/share/sysconftool/sysconftool %D/etc/courier/ldapaliasrc.dist
-@exec [ -f %D/etc/courier/pop3d-ssl.dist ] && %%LOCALBASE%%/share/sysconftool/sysconftool %D/etc/courier/pop3d-ssl.dist
-@exec [ -f %D/etc/courier/pop3d.dist ] && %%LOCALBASE%%/share/sysconftool/sysconftool %D/etc/courier/pop3d.dist
-@exec [ -f %D/etc/courier/sqwebmaild.dist ] && %%LOCALBASE%%/share/sysconftool/sysconftool %D/etc/courier/sqwebmaild.dist
@exec [ -f %D/etc/courier/webmlmrc.dist ] && %%LOCALBASE%%/share/sysconftool/sysconftool %D/etc/courier/webmlmrc.dist
+@comment etc/courier/webmlmrc
@dirrmtry etc/courier/aliasdir
@dirrmtry etc/courier/aliases
@dirrmtry etc/courier/esmtpacceptmailfor.dir
@@ -149,14 +168,24 @@ libexec/courier/courierpop3d
libexec/courier/courierpop3login
libexec/courier/imaplogin
libexec/courier/makedatprog
+@owner %%MAILOWN%%
+@group %%MAILGRP%%
libexec/courier/modules/dsn/courierdsn
+@dirrm libexec/courier/modules/dsn
libexec/courier/modules/esmtp/addcr
libexec/courier/modules/esmtp/courieresmtp
libexec/courier/modules/esmtp/courieresmtpd
+@dirrm libexec/courier/modules/esmtp
%%WITHFAX%%libexec/courier/modules/fax/courierfax
+%%WITHFAX%%@dirrm libexec/courier/modules/fax
libexec/courier/modules/local/courierdeliver
libexec/courier/modules/local/courierlocal
+@dirrm libexec/courier/modules/local
%%WITHUUCP%%libexec/courier/modules/uucp/courieruucp
+%%WITHUUCP%%@dirrm libexec/courier/modules/uucp
+@dirrm libexec/courier/modules
+@owner
+@group
libexec/courier/pcpd
libexec/courier/sqwebmaild
libexec/courier/sqwebpasswd
@@ -165,17 +194,66 @@ libexec/courier/submitmkdir
libexec/courier/webmail/webadmin
libexec/courier/webmail/webmail
libexec/courier/webmail/webmlm
-libexec/filters/dupfilter
-libexec/filters/perlfilter
-%%WITHUUCP%%@dirrm libexec/courier/modules/uucp
-@dirrm libexec/courier/modules/local
-%%WITHFAX%%@dirrm libexec/courier/modules/fax
-@dirrm libexec/courier/modules/esmtp
-@dirrm libexec/courier/modules/dsn
-@dirrm libexec/courier/modules
@dirrm libexec/courier/webmail
@dirrm libexec/courier
+libexec/filters/dupfilter
+libexec/filters/perlfilter
@dirrmtry libexec/filters
+man/man1/cancelmsg.1.gz
+man/man1/couriermlm.1.gz
+man/man1/couriertcpd.1.gz
+man/man1/couriertls.1.gz
+man/man1/dot-forward.1.gz
+man/man1/dotforward.1.gz
+man/man1/lockmail.1.gz
+man/man1/mailbot.1.gz
+man/man1/maildiracl.1.gz
+man/man1/maildirkw.1.gz
+man/man1/maildirmake.1.gz
+man/man1/maildrop.1.gz
+man/man1/mailq.1.gz
+man/man1/makedat.1.gz
+man/man1/makemime.1.gz
+man/man1/mimegpg.1.gz
+man/man1/preline.1.gz
+man/man1/reformail.1.gz
+man/man1/reformime.1.gz
+man/man1/rmail.1.gz
+man/man1/sendmail.1.gz
+man/man1/testmxlookup.1.gz
+man/man1/webmlmd.1.gz
+man/man5/dot-courier.5.gz
+man/man5/maildir.5.gz
+man/man7/localmailfilter.7.gz
+man/man7/maildirquota.7.gz
+man/man7/maildropex.7.gz
+man/man7/maildropfilter.7.gz
+man/man7/maildropgdbm.7.gz
+man/man8/aliaslookup.8.gz
+man/man8/courier.8.gz
+man/man8/courierfilter.8.gz
+man/man8/courierldapaliasd.8.gz
+man/man8/courierperlfilter.8.gz
+man/man8/courierpop3d.8.gz
+man/man8/courierpop3login.8.gz
+man/man8/deliverquota.8.gz
+man/man8/dupfilter.8.gz
+man/man8/esmtpd-msa.8.gz
+man/man8/esmtpd.8.gz
+man/man8/filterctl.8.gz
+man/man8/imapd.8.gz
+man/man8/makeacceptmailfor.8.gz
+man/man8/makealiases.8.gz
+man/man8/makehosteddomains.8.gz
+man/man8/makepercentrelay.8.gz
+man/man8/makesmtpaccess-msa.8.gz
+man/man8/makesmtpaccess.8.gz
+man/man8/mkesmtpdcert.8.gz
+man/man8/mkimapdcert.8.gz
+man/man8/mkpop3dcert.8.gz
+man/man8/pop3d-ssl.8.gz
+man/man8/pop3d.8.gz
+man/man8/submit.8.gz
sbin/aliaslookup
sbin/courier
sbin/courieresmtpd
@@ -560,39 +638,51 @@ share/courier/sqwebmail/webgpg
%%PORTDOCS%%%%DOCSDIR%%/html/webmlmd.html
%%PORTDOCS%%@dirrm %%DOCSDIR%%/html
%%PORTDOCS%%@dirrm %%DOCSDIR%%
-@exec chown %%MAILOWN%%:%%MAILGRP%% %D/bin/cancelmsg
-@exec chown %%BINOWN%%:mail %D/bin/maildrop
-@exec chown %%BINOWN%%:%%MAILGRP%% %D/bin/mailq
-@exec chown %%MAILOWN%%:%%MAILGRP%% %D/etc/courier
-@exec chown -Rh %%MAILOWN%%:%%MAILGRP%% %D/etc/courier/aliases
-@exec chown %%BINOWN%%:%%BINGRP%% %D/etc/courier/courierd.dist
-@exec chown %%MAILOWN%%:%%MAILGRP%% %D/etc/courier/*.txt
-@exec chown %%MAILOWN%%:%%MAILGRP%% %D/etc/courier/esmtpauthclient
-@exec chown %%MAILOWN%%:%%MAILGRP%% %D/etc/courier/module.*
-@exec chown %%MAILOWN%%:%%MAILGRP%% %D/libexec/courier/aliascombine
-@exec chown %%MAILOWN%%:%%MAILGRP%% %D/libexec/courier/aliascreate
-@exec chown %%MAILOWN%%:%%MAILGRP%% %D/libexec/courier/aliasexp
-@exec chown %%MAILOWN%%:%%MAILGRP%% %D/libexec/courier/courierd
-@exec chown -Rh %%MAILOWN%%:%%MAILGRP%% %D/libexec/courier/modules/*
-@exec chown %%MAILOWN%%:%%MAILGRP%% %D/libexec/courier/submit
-@exec chown %%MAILOWN%%:%%MAILGRP%% %D/libexec/courier/submitmkdir
-@exec chown %%MAILOWN%%:%%MAILGRP%% %D/sbin/showmodules
-@exec chmod 0555 %D/libexec/courier
-@exec chmod 0555 %D/libexec/courier/modules
-@exec chmod 0555 %D/libexec/courier/modules/dsn
-@exec chmod 0555 %D/libexec/courier/modules/esmtp
-%%WITHFAX%%@exec chmod 0555 %D/libexec/courier/modules/fax
-@exec chmod 0555 %D/libexec/courier/modules/local
-%%WITHUUCP%%@exec chmod 0555 %D/libexec/courier/modules/uucp
-@exec chmod 0555 %D/libexec/courier/webmail
-@exec chmod 0555 %D/libexec/filters
-@exec chmod 0555 %D/share/courier
-@exec chmod 0555 %D/share/courier/couriermlm
-@exec chmod 0555 %D/share/courier/courierwebadmin
-%%WITHFAX%%@exec chmod 0555 %D/share/courier/faxmail
-@exec chmod 0555 %D/share/courier/sqwebmail
-@exec chmod 0555 %D/share/courier/sqwebmail/html
-@exec chmod 0555 %D/share/courier/sqwebmail/html/en-us
-@exec chmod 0555 %D/share/courier/sqwebmail/images
+@comment @exec chown %%MAILOWN%%:%%MAILGRP%% %D/bin/cancelmsg
+@comment @exec chown %%BINOWN%%:mail %D/bin/maildrop
+@comment @exec chown %%BINOWN%%:%%MAILGRP%% %D/bin/mailq
+@comment @exec chown %%MAILOWN%%:%%MAILGRP%% %D/etc/courier
+@comment @exec chown -Rh %%MAILOWN%%:%%MAILGRP%% %D/etc/courier/aliases
+@comment @exec chown %%BINOWN%%:%%BINGRP%% %D/etc/courier/courierd.dist
+@comment @exec chown %%MAILOWN%%:%%MAILGRP%% %D/etc/courier/*.txt
+@comment @exec chown %%MAILOWN%%:%%MAILGRP%% %D/etc/courier/esmtpauthclient
+@comment @exec chown %%MAILOWN%%:%%MAILGRP%% %D/etc/courier/module.*
+@comment @exec chown %%MAILOWN%%:%%MAILGRP%% %D/libexec/courier/aliascombine
+@comment @exec chown %%MAILOWN%%:%%MAILGRP%% %D/libexec/courier/aliascreate
+@comment @exec chown %%MAILOWN%%:%%MAILGRP%% %D/libexec/courier/aliasexp
+@comment @exec chown %%MAILOWN%%:%%MAILGRP%% %D/libexec/courier/courierd
+@comment @exec chown -Rh %%MAILOWN%%:%%MAILGRP%% %D/libexec/courier/modules/*
+@comment @exec chown %%MAILOWN%%:%%MAILGRP%% %D/libexec/courier/submit
+@comment @exec chown %%MAILOWN%%:%%MAILGRP%% %D/libexec/courier/submitmkdir
+@comment @exec chown %%MAILOWN%%:%%MAILGRP%% %D/sbin/showmodules
+@comment @exec chmod 0555 %D/libexec/courier
+@comment @exec chmod 0555 %D/libexec/courier/modules
+@comment @exec chmod 0555 %D/libexec/courier/modules/dsn
+@comment @exec chmod 0555 %D/libexec/courier/modules/esmtp
+@comment %%WITHFAX%%@exec chmod 0555 %D/libexec/courier/modules/fax
+@comment @exec chmod 0555 %D/libexec/courier/modules/local
+@comment %%WITHUUCP%%@exec chmod 0555 %D/libexec/courier/modules/uucp
+@comment @exec chmod 0555 %D/libexec/courier/webmail
+@comment @exec chmod 0555 %D/libexec/filters
+@comment @exec chmod 0555 %D/share/courier
+@comment @exec chmod 0555 %D/share/courier/couriermlm
+@comment @exec chmod 0555 %D/share/courier/courierwebadmin
+@comment %%WITHFAX%%@exec chmod 0555 %D/share/courier/faxmail
+@comment @exec chmod 0555 %D/share/courier/sqwebmail
+@comment @exec chmod 0555 %D/share/courier/sqwebmail/html
+@comment @exec chmod 0555 %D/share/courier/sqwebmail/html/en-us
+@comment @exec chmod 0555 %D/share/courier/sqwebmail/images
@unexec echo y | crontab -u %%CACHEOWN%% -r 2>/dev/null || true
@unexec rm -rf %%CALENDIR%% %%CACHEDIR%% 2>/dev/null || true
+@dirrmtry %%CALENDIR%%/localcache
+@dirrmtry %%CALENDIR%%/private
+@dirrmtry %%CALENDIR%%/public
+@dirrmtry %%CALENDIR%%
+@dirrmtry %%LOCALSTATEDIR%%/allfilters
+@dirrmtry %%LOCALSTATEDIR%%/filters
+@dirrmtry %%LOCALSTATEDIR%%/msgq
+@dirrmtry %%LOCALSTATEDIR%%/msgs
+@dirrmtry %%LOCALSTATEDIR%%/tmp
+@dirrmtry %%LOCALSTATEDIR%%/track
+@dirrmtry %%LOCALSTATEDIR%%
+@dirrmtry %%CACHEDIR%%