aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorbdrewery <bdrewery@FreeBSD.org>2015-03-20 01:04:07 +0800
committerbdrewery <bdrewery@FreeBSD.org>2015-03-20 01:04:07 +0800
commit65addcc2124c59bce3c0a338c8eb0dd9110f0014 (patch)
treea1e774283773c06adc503b61d8f1099226e2ec50 /mail
parentf244314b70417e9719ad6da092979fb8f67e6418 (diff)
downloadfreebsd-ports-gnome-65addcc2124c59bce3c0a338c8eb0dd9110f0014.tar.gz
freebsd-ports-gnome-65addcc2124c59bce3c0a338c8eb0dd9110f0014.tar.zst
freebsd-ports-gnome-65addcc2124c59bce3c0a338c8eb0dd9110f0014.zip
Disable SSLv2 and SSLv3.
PR: 197027 Submitted by: Kai Gallasch <k@free.de> MFH: 2015Q1
Diffstat (limited to 'mail')
-rw-r--r--mail/dovecot/Makefile2
-rw-r--r--mail/dovecot/files/patch-src__login-common__ssl-proxy-openssl.c11
2 files changed, 12 insertions, 1 deletions
diff --git a/mail/dovecot/Makefile b/mail/dovecot/Makefile
index c0adcba95e55..f942ced0b669 100644
--- a/mail/dovecot/Makefile
+++ b/mail/dovecot/Makefile
@@ -3,7 +3,7 @@
PORTNAME= dovecot
PORTVERSION= 1.2.17
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= mail ipv6
MASTER_SITES= http://www.dovecot.org/releases/${PORTVERSION:R}/ \
http://www.rename-it.nl/dovecot/${PORTVERSION:R}/
diff --git a/mail/dovecot/files/patch-src__login-common__ssl-proxy-openssl.c b/mail/dovecot/files/patch-src__login-common__ssl-proxy-openssl.c
new file mode 100644
index 000000000000..b2a7adcdbb15
--- /dev/null
+++ b/mail/dovecot/files/patch-src__login-common__ssl-proxy-openssl.c
@@ -0,0 +1,11 @@
+--- src/login-common/ssl-proxy-openssl.c.orig 2015-03-19 11:57:04.578367000 -0500
++++ src/login-common/ssl-proxy-openssl.c 2015-03-19 11:57:21.859436000 -0500
+@@ -818,7 +818,7 @@ static void ssl_proxy_ctx_init(SSL_CTX *
+ {
+ const char *cafile;
+
+- SSL_CTX_set_options(ssl_ctx, SSL_OP_ALL);
++ SSL_CTX_set_options(ssl_ctx, SSL_OP_ALL | SSL_OP_NO_SSLv2 | SSL_OP_NO_SSLv3);
+
+ cafile = getenv("SSL_CA_FILE");
+ if (cafile != NULL) {