aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authoraz <az@FreeBSD.org>2013-07-26 15:33:41 +0800
committeraz <az@FreeBSD.org>2013-07-26 15:33:41 +0800
commit665183f53eb74ec3fb00d82d5e4d998804f85ad2 (patch)
treee2c71147def7c03ff268350288657b4e7692d180 /mail
parente80ef1fc474e04a3b1999f45fd39114572d34f44 (diff)
downloadfreebsd-ports-gnome-665183f53eb74ec3fb00d82d5e4d998804f85ad2.tar.gz
freebsd-ports-gnome-665183f53eb74ec3fb00d82d5e4d998804f85ad2.tar.zst
freebsd-ports-gnome-665183f53eb74ec3fb00d82d5e4d998804f85ad2.zip
- switch simple inline replacement from perl to sed
and remove where is no need in this anymore. - trim Makefile header Approved by: bapt@ (portmrg@)
Diffstat (limited to 'mail')
-rw-r--r--mail/mailagent/Makefile3
-rw-r--r--mail/mb2md/Makefile5
-rw-r--r--mail/spamstats/Makefile5
-rw-r--r--mail/tlb/Makefile13
4 files changed, 13 insertions, 13 deletions
diff --git a/mail/mailagent/Makefile b/mail/mailagent/Makefile
index 5a162998d838..f8b86612ec94 100644
--- a/mail/mailagent/Makefile
+++ b/mail/mailagent/Makefile
@@ -47,8 +47,7 @@ pre-extract:
post-patch:
@(cd ${WRKSRC}; \
- ${PERL} -pi.bak \
- -e 's|exec perl -S|exec ${PERL} -S|' \
+ ${REINPLACE_CMD} -i '' -e 's|exec perl -S|exec ${PERL} -S|' \
agent/edusers.SH agent/magent.sh agent/maildist.SH \
agent/mailhelp.SH agent/maillist.SH agent/mailpatch.SH \
agent/package.SH agent/test/TEST agent/test/atail \
diff --git a/mail/mb2md/Makefile b/mail/mb2md/Makefile
index eb0b309ee8e9..718b7a917875 100644
--- a/mail/mb2md/Makefile
+++ b/mail/mb2md/Makefile
@@ -21,12 +21,11 @@ EXTRACT_AFTER_ARGS= > ${WRKDIR}/${PORTNAME}
NO_WRKSUBDIR= yes
NO_BUILD= yes
USE_PERL5= yes
+USES= shebangfix
+SHEBANG_FILES= mb2md
PLIST_FILES= bin/mb2md
-post-patch:
- @${PERL} -pi -e 's|/usr/bin/perl|${PERL}|g' ${WRKSRC}/${PORTNAME}
-
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
diff --git a/mail/spamstats/Makefile b/mail/spamstats/Makefile
index 8a0546119ee5..fa4bfab53b54 100644
--- a/mail/spamstats/Makefile
+++ b/mail/spamstats/Makefile
@@ -19,9 +19,12 @@ USE_PERL5= yes
NO_BUILD= yes
PORTDOCS= QUICK README copyright
PLIST_FILES= bin/spamstats.pl
+USES= shebangfix
+SHEBANG_FILES= ${PORTNAME}${PORTVERSION}.pl
post-patch:
- @${PERL} -pi.bak -e 's,/mail.log,/maillog,g' ${WRKSRC}/${PORTNAME}${PORTVERSION}.pl
+ @${REINPLACE_CMD} -i '' -e 's|mail.log|maillog|g' \
+ ${WRKSRC}/${PORTNAME}${PORTVERSION}.pl
.include <bsd.port.options.mk>
diff --git a/mail/tlb/Makefile b/mail/tlb/Makefile
index db5fd4417451..29b34feb2f4b 100644
--- a/mail/tlb/Makefile
+++ b/mail/tlb/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: tlb
-# Date created: 01 July 2001
-# Whom: Anders Nordby <anders@fix.no>
-#
+# Created by: Anders Nordby <anders@fix.no>
# $FreeBSD$
-#
PORTNAME= tlb
PORTVERSION= 0.11a
@@ -27,10 +23,13 @@ DOCS= FAQ INSTALL README README.loglevels README.mungelist TIPS TODO \
complete.tlb mj.tlb simple.tlb
FIXPREFIX= tlb mungelist complete.tlb mj.tlb simple.tlb
+USES= shebangfix
+SHEBANG_FILES= ${FIXPREFIX}
+perl_OLD_CMD= /usr/local/bin/perl5
+
pre-patch:
.for f in ${FIXPREFIX}
- ${PERL} -pi -e "s@^#!/usr/local/bin/perl5@#!${PERL}@g;\
- s@/usr/lib/sendmail@/usr/sbin/sendmail@g" ${WRKSRC}/${f}
+ @${PERL} -pi -e "s@/usr/lib/sendmail@/usr/sbin/sendmail@g" ${WRKSRC}/${f}
.endfor
do-install: