aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorsada <sada@FreeBSD.org>2002-11-17 13:03:54 +0800
committersada <sada@FreeBSD.org>2002-11-17 13:03:54 +0800
commit678796d68f78e59552202a6dc781c058e84ccab5 (patch)
treec41d2d272c020fad9decc7fd52ba2c4d6b181908 /mail
parent3df22975f641e9f39851b20ebf2ac710cf17257a (diff)
downloadfreebsd-ports-gnome-678796d68f78e59552202a6dc781c058e84ccab5.tar.gz
freebsd-ports-gnome-678796d68f78e59552202a6dc781c058e84ccab5.tar.zst
freebsd-ports-gnome-678796d68f78e59552202a6dc781c058e84ccab5.zip
Resurrection of port devel/pear
PR: ports/44473 Submitted by: Thierry Thomas <thierry@pompo.net>
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/pear-Mail_Mime/Makefile39
-rw-r--r--mail/pear-Mail_Mime/distinfo1
-rw-r--r--mail/pear-Mail_Mime/pkg-comment1
-rw-r--r--mail/pear-Mail_Mime/pkg-descr3
-rw-r--r--mail/pear-Mail_Mime/pkg-plist5
6 files changed, 50 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index 5c72ca80e312..85dfe8b9897e 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -175,6 +175,7 @@
SUBDIR += pantomime
SUBDIR += pantomime-ssl
SUBDIR += pathalias
+ SUBDIR += pear-Mail_Mime
SUBDIR += perdition
SUBDIR += pflogsumm
SUBDIR += pgen
diff --git a/mail/pear-Mail_Mime/Makefile b/mail/pear-Mail_Mime/Makefile
new file mode 100644
index 000000000000..49f247ca087a
--- /dev/null
+++ b/mail/pear-Mail_Mime/Makefile
@@ -0,0 +1,39 @@
+# Ports collection makefile for: pear-Mail_Mime
+# Date created: 24 October 2002
+# Whom: Thierry Thomas (<thierry@pompo.net>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= Mail_Mime
+PORTVERSION= 1.2.1
+CATEGORIES= mail www
+MASTER_SITES= http://pear.php.net/get/
+PKGNAMEPREFIX= pear-
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= PEAR
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= ${PEARDIR}.DIST_PHP:${PORTSDIR}/devel/pear-install
+RUN_DEPENDS= ${PEARDIR}.DIST_PHP:${PORTSDIR}/devel/pear-install
+
+NO_BUILD= yes
+
+.include <bsd.port.pre.mk>
+
+.if exists(${LOCALBASE}/bin/php-config)
+PHP_BASE!= ${LOCALBASE}/bin/php-config --prefix
+.endif
+LPHP_LIB= lib/php
+PEARDIR= ${PHP_BASE}/${LPHP_LIB}
+PLIST_SUB= PEARDIR=${LPHP_LIB}
+
+do-install:
+ @${CP} -Rp ${WRKSRC}/* ${PEARDIR}/Mail
+ @${CHOWN} -R root:wheel ${PEARDIR}/Mail/*
+.for BUGMODE in mimeDecode.php mimePart.php xmail.dtd xmail.xsl
+ @${CHMOD} a-x ${PEARDIR}/Mail/${BUGMODE}
+.endfor
+
+.include <bsd.port.post.mk>
diff --git a/mail/pear-Mail_Mime/distinfo b/mail/pear-Mail_Mime/distinfo
new file mode 100644
index 000000000000..cd74af7ac488
--- /dev/null
+++ b/mail/pear-Mail_Mime/distinfo
@@ -0,0 +1 @@
+MD5 (PEAR/Mail_Mime-1.2.1.tgz) = 667f631d9b128ef559bf97b9cd182c48
diff --git a/mail/pear-Mail_Mime/pkg-comment b/mail/pear-Mail_Mime/pkg-comment
new file mode 100644
index 000000000000..a94306bcfd13
--- /dev/null
+++ b/mail/pear-Mail_Mime/pkg-comment
@@ -0,0 +1 @@
+PEAR classes to create and decode MIME messages
diff --git a/mail/pear-Mail_Mime/pkg-descr b/mail/pear-Mail_Mime/pkg-descr
new file mode 100644
index 000000000000..e3dc657c9ddf
--- /dev/null
+++ b/mail/pear-Mail_Mime/pkg-descr
@@ -0,0 +1,3 @@
+PEAR classes to deal with creation and manipulation of MIME messages.
+
+WWW: http://pear.php.net/manual/en/core.mail.mime.php
diff --git a/mail/pear-Mail_Mime/pkg-plist b/mail/pear-Mail_Mime/pkg-plist
new file mode 100644
index 000000000000..9ece498454c6
--- /dev/null
+++ b/mail/pear-Mail_Mime/pkg-plist
@@ -0,0 +1,5 @@
+%%PEARDIR%%/Mail/mime.php
+%%PEARDIR%%/Mail/mimeDecode.php
+%%PEARDIR%%/Mail/mimePart.php
+%%PEARDIR%%/Mail/xmail.dtd
+%%PEARDIR%%/Mail/xmail.xsl