aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorsat <sat@FreeBSD.org>2006-05-08 00:48:52 +0800
committersat <sat@FreeBSD.org>2006-05-08 00:48:52 +0800
commit683f5d5fe45bb85ec7d8f7578ac2ac326311fad4 (patch)
treee847384aa2ef479a0c84ab9531ae607e4771a04a /mail
parent078b59a68b9f95fc1841541915e11628c92b214f (diff)
downloadfreebsd-ports-gnome-683f5d5fe45bb85ec7d8f7578ac2ac326311fad4.tar.gz
freebsd-ports-gnome-683f5d5fe45bb85ec7d8f7578ac2ac326311fad4.tar.zst
freebsd-ports-gnome-683f5d5fe45bb85ec7d8f7578ac2ac326311fad4.zip
- Move common code code and files from mozilla linux binary
ports to www/linux-seamonkey - Add translations to desktop entries by snatching them from native apps [1] - Update www/linux-flock to 0.5.15.0 Inspired by: Masashi CHIBA <chiba.masashi@gmail.com> [1] PR: 96784 Approved by: krion (mentor)
Diffstat (limited to 'mail')
-rw-r--r--mail/linux-thunderbird/Makefile48
-rw-r--r--mail/linux-thunderbird/files/linux-thunderbird.desktop.in6
-rw-r--r--mail/linux-thunderbird/files/run1
3 files changed, 6 insertions, 49 deletions
diff --git a/mail/linux-thunderbird/Makefile b/mail/linux-thunderbird/Makefile
index 5bd93f7b9018..dc706fc3e067 100644
--- a/mail/linux-thunderbird/Makefile
+++ b/mail/linux-thunderbird/Makefile
@@ -7,53 +7,11 @@
PORTNAME= thunderbird
PORTVERSION= 1.5.0.2
-CATEGORIES= mail linux
-MASTER_SITES= ${MASTER_SITE_MOZILLA}
+CATEGORIES= mail
MASTER_SITE_SUBDIR?= ${PORTNAME}/releases/${PORTVERSION}/linux-i686/en-US
-PKGNAMEPREFIX= linux-
MAINTAINER= infofarmer@gmail.com
COMMENT= Mozilla Thunderbird is standalone mail and news that stands above
-RUN_DEPENDS?= ${LINUXBASE}/usr/lib/libgtk-x11-2.0.so.0:${PORTSDIR}/x11-toolkits/linux-gtk2 \
- ${LINUXBASE}/usr/lib/libatk-1.0.so.0:${PORTSDIR}/accessibility/linux-atk \
- ${LINUXBASE}/usr/lib/libpangoxft-1.0.so.0:${PORTSDIR}/x11-toolkits/linux-pango\
- ${LINUXBASE}/usr/lib/libgobject-2.0.so.0:${PORTSDIR}/devel/linux-glib2 \
- ${LINUXBASE}/usr/lib/libfontconfig.so.1:${PORTSDIR}/x11-fonts/linux-fontconfig \
- ${LINUXBASE}/usr/share/icons/hicolor/index.theme:${PORTSDIR}/x11-themes/linux-hicolor-icon-theme
-
-NO_BUILD= yes
-ONLY_FOR_ARCHS= i386 amd64
-APP_NAME= ${UNIQUENAME}
-USE_LINUX= yes
-USE_X_PREFIX= yes
-WRKSRC= ${WRKDIR}/${PORTNAME}
-FDIR= ${PREFIX}/lib/${APP_NAME}
-
-PLIST_SUB+= APP_NAME=${APP_NAME}
-SUB_LIST+= APP_NAME=${APP_NAME}
-SUB_FILES= ${APP_NAME}.desktop
-PKGMESSAGE= ${WRKDIR}/pkg-message
-PREFS_FILE= ${WRKSRC}/defaults/pref/${PORTNAME}.js
-
-.include <bsd.port.pre.mk>
-
-do-install:
- ${INSTALL} -d ${FDIR}
- ${MKDIR} ${PREFIX}/share/applications
- ${INSTALL_DATA} ${WRKDIR}/${APP_NAME}.desktop ${PREFIX}/share/applications
- ${CP} -pR ${WRKSRC}/ ${FDIR}/
- ${INSTALL_SCRIPT} ${FILESDIR}/run ${PREFIX}/bin/${APP_NAME}
- ${ECHO} 'cd ${PREFIX} && exec ${FDIR}/${PORTNAME}' >> ${PREFIX}/bin/${APP_NAME}
-
-# Maintainer section
-create-plist:
- ${ECHO_CMD} bin/%%APP_NAME%% > ${PLIST}
- ${ECHO_CMD} share/applications/%%APP_NAME%%.desktop >> ${PLIST}
- cd ${WRKDIR} && ${FIND} ${PORTNAME} -type f -or -type l | \
- ${SED} -e "s#^${PORTNAME}#lib/%%APP_NAME%%#" | ${SORT} >> ${PLIST}
- cd ${WRKDIR} && ${FIND} -d ${PORTNAME} -type d | \
- ${SED} -e "s#^${PORTNAME}#@dirrm lib/%%APP_NAME%%#" >> ${PLIST}
- ${ECHO_CMD} @dirrmtry share/applications >> ${PLIST}
-
-.include <bsd.port.post.mk>
+.include "${.CURDIR}/../../www/linux-seamonkey/Makefile.common"
+.include <bsd.port.mk>
diff --git a/mail/linux-thunderbird/files/linux-thunderbird.desktop.in b/mail/linux-thunderbird/files/linux-thunderbird.desktop.in
index fe9128bc0d85..2e972538f63c 100644
--- a/mail/linux-thunderbird/files/linux-thunderbird.desktop.in
+++ b/mail/linux-thunderbird/files/linux-thunderbird.desktop.in
@@ -1,10 +1,10 @@
[Desktop Entry]
Encoding=UTF-8
-Name=Thunderbird (Linux binary)
-GenericName=Mail Client
+Name=Thunderbird (Linux)
+GenericName=Mail Client (Linux)
Comment=Mail client and News Reader
Exec=linux-thunderbird %U
-Icon=thunderbird
+Icon=%%PREFIX%%/lib/%%APP_NAME%%/chrome/icons/default/default.xpm
StartupNotify=false
Terminal=false
Type=Application
diff --git a/mail/linux-thunderbird/files/run b/mail/linux-thunderbird/files/run
deleted file mode 100644
index 1a2485251c33..000000000000
--- a/mail/linux-thunderbird/files/run
+++ /dev/null
@@ -1 +0,0 @@
-#!/bin/sh