aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authordd <dd@FreeBSD.org>2001-07-29 01:46:33 +0800
committerdd <dd@FreeBSD.org>2001-07-29 01:46:33 +0800
commit6b0ddebcbdcb0f5980f9883e91ee764ae22326cd (patch)
tree1aca400b21f644b4005332ce3c50501caffefd9c /mail
parentd35c28b6f2a25e2cbc5eaf022f882ae3f6d78a45 (diff)
downloadfreebsd-ports-gnome-6b0ddebcbdcb0f5980f9883e91ee764ae22326cd.tar.gz
freebsd-ports-gnome-6b0ddebcbdcb0f5980f9883e91ee764ae22326cd.tar.zst
freebsd-ports-gnome-6b0ddebcbdcb0f5980f9883e91ee764ae22326cd.zip
Add rmime: decode MIME messages inside Emacs (works with RMAIL, VM,
and mh-e).
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/rmime/Makefile34
-rw-r--r--mail/rmime/distinfo1
-rw-r--r--mail/rmime/pkg-comment1
-rw-r--r--mail/rmime/pkg-descr6
-rw-r--r--mail/rmime/pkg-plist2
6 files changed, 45 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index 026339fd06f0..e50e7d84e7fe 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -161,6 +161,7 @@
SUBDIR += rftp
SUBDIR += ripmime
SUBDIR += rlytest
+ SUBDIR += rmime
SUBDIR += rmoldmail
SUBDIR += ruby-tmail
SUBDIR += sendmail
diff --git a/mail/rmime/Makefile b/mail/rmime/Makefile
new file mode 100644
index 000000000000..f8629b5d076d
--- /dev/null
+++ b/mail/rmime/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: rmime
+# Date created: 28 July 2001
+# Whom: dd
+#
+# $FreeBSD$
+#
+
+PORTNAME= rmime
+PORTVERSION= 1.2
+CATEGORIES= mail
+MASTER_SITES= http://www.cinti.net/~rmoody/rmime/ \
+ ${MASTER_SITE_LOCAL} \
+ http://www.unixfreak.org/~dima/distfiles/
+MASTER_SITE_SUBDIR= dd
+DISTNAME= rmime.el
+EXTRACT_SUFX= # empty
+EXTRACT_ONLY= # empty
+
+MAINTAINER= dd@FreeBSD.org
+
+BUILD_DEPENDS= emacs:${PORTSDIR}/editors/emacs20
+
+NO_WRKSUBDIR= yes
+STRIP= # empty
+
+do-build:
+ ${CP} ${DISTDIR}/rmime.el ${WRKDIR}
+ emacs -batch -f batch-byte-compile ${WRKDIR}/rmime.el
+
+do-install:
+ ${INSTALL_DATA} ${WRKDIR}/rmime.el ${WRKDIR}/rmime.elc\
+ ${PREFIX}/share/emacs/site-lisp
+
+.include <bsd.port.mk>
diff --git a/mail/rmime/distinfo b/mail/rmime/distinfo
new file mode 100644
index 000000000000..d38604c516dc
--- /dev/null
+++ b/mail/rmime/distinfo
@@ -0,0 +1 @@
+MD5 (rmime.el) = 6b18b7855077ce9373d94474b801747d
diff --git a/mail/rmime/pkg-comment b/mail/rmime/pkg-comment
new file mode 100644
index 000000000000..dd0e38d579a1
--- /dev/null
+++ b/mail/rmime/pkg-comment
@@ -0,0 +1 @@
+Decode MIME messages inside Emacs (works with RMAIL, VM, and mh-e)
diff --git a/mail/rmime/pkg-descr b/mail/rmime/pkg-descr
new file mode 100644
index 000000000000..f5cce11118c0
--- /dev/null
+++ b/mail/rmime/pkg-descr
@@ -0,0 +1,6 @@
+RMIME provides MIME support for several Emacs message reading
+packages. RMIME has been designed with RMAIL in mind, but it has also
+been tested with mh-e and VM. It should work with most other major
+modes as well.
+
+WWW: http://www.cinti.net/~rmoody/rmime/
diff --git a/mail/rmime/pkg-plist b/mail/rmime/pkg-plist
new file mode 100644
index 000000000000..5b745a743d86
--- /dev/null
+++ b/mail/rmime/pkg-plist
@@ -0,0 +1,2 @@
+share/emacs/site-lisp/rmime.el
+share/emacs/site-lisp/rmime.elc