aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2014-08-27 01:22:12 +0800
committersunpoet <sunpoet@FreeBSD.org>2014-08-27 01:22:12 +0800
commit6d223e09f8a726a31d061664105dc908d8555e37 (patch)
tree4a629898ee4c2afd11aa37ff3980f201eb871873 /mail
parent6723f019ad4e15bd03e5dacb2d274cc83e25a926 (diff)
downloadfreebsd-ports-gnome-6d223e09f8a726a31d061664105dc908d8555e37.tar.gz
freebsd-ports-gnome-6d223e09f8a726a31d061664105dc908d8555e37.tar.zst
freebsd-ports-gnome-6d223e09f8a726a31d061664105dc908d8555e37.zip
- Convert to new options helper
- Cleanup Makefile - Sort PLIST - Take maintainership
Diffstat (limited to 'mail')
-rw-r--r--mail/libpst/Makefile49
-rw-r--r--mail/libpst/pkg-plist2
2 files changed, 20 insertions, 31 deletions
diff --git a/mail/libpst/Makefile b/mail/libpst/Makefile
index a6ab6f7358b6..ac6546e97dd0 100644
--- a/mail/libpst/Makefile
+++ b/mail/libpst/Makefile
@@ -8,49 +8,38 @@ CATEGORIES= mail converters
MASTER_SITES= http://www.five-ten-sg.com/libpst/packages/ \
http://fossies.org/unix/privat/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Tool for converting Outlook .pst files to mbox and other formats
LICENSE= GPLv2
LIB_DEPENDS= libgsf-1.so:${PORTSDIR}/devel/libgsf
-GNU_CONFIGURE= yes
-USES= iconv libtool pathfix gmake pkgconfig
+OPTIONS_DEFINE= DOCS PST2DII
+OPTIONS_SUB= yes
+PST2DII_DESC= Allow Summation Document Image Information output
+
+CONFIGURE_ARGS= --disable-python --enable-libpst-shared
CPPFLAGS+= -I${LOCALBASE}/include
+GNU_CONFIGURE= yes
LDFLAGS+= -L${LOCALBASE}/lib ${ICONV_LIB}
-CONFIGURE_ARGS+= --disable-python --enable-libpst-shared
USE_LDCONFIG= yes
+USES= gmake iconv libtool pathfix pkgconfig
PORTDOCS= *
-OPTIONS_DEFINE= DOCS PST2DII
-PST2DII_DESC= Allow Summation Document Image Information output
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MPST2DII}
-CONFIGURE_ARGS+= --enable-dii=yes
-BUILD_DEPENDS+= ${LOCALBASE}/bin/convert:${PORTSDIR}/graphics/ImageMagick
-RUN_DEPENDS+= ${LOCALBASE}/bin/convert:${PORTSDIR}/graphics/ImageMagick
-LIB_DEPENDS+= libgd.so:${PORTSDIR}/graphics/gd
-PLIST_SUB+= PST2DII=""
-.else
-CONFIGURE_ARGS+= --enable-dii=no
-PLIST_SUB+= PST2DII="@comment "
-.endif
+PST2DII_BUILD_DEPENDS= ${LOCALBASE}/bin/convert:${PORTSDIR}/graphics/ImageMagick
+PST2DII_CONFIGURE_OFF= --enable-dii=no
+PST2DII_CONFIGURE_ON= --enable-dii=yes
+PST2DII_LIB_DEPENDS= libgd.so:${PORTSDIR}/graphics/gd
+PST2DII_RUN_DEPENDS= ${LOCALBASE}/bin/convert:${PORTSDIR}/graphics/ImageMagick
post-patch:
- ${FIND} -X ${WRKSRC} -type f | ${XARGS} ${REINPLACE_CMD} \
- -e 's/malloc.h/stdlib.h/g'
- ${REINPLACE_CMD} -e 's;doc\/@PACKAGE@-@VERSION@;doc\/@PACKAGE@;g' \
- ${WRKSRC}/Makefile.in ${WRKSRC}/html/Makefile.in
-.if ${PORT_OPTIONS:MDOCS}
- ${REINPLACE_CMD} -e '/html_DATA =/s/COPYING //' \
- ${WRKSRC}/Makefile.in
-.else
- ${REINPLACE_CMD} -e '/SUBDIRS =/s/=.*/= src man/' -e '/html_DATA =/d' \
- ${WRKSRC}/Makefile.in
-.endif
+ @${GREP} -lr malloc.h ${WRKSRC}/ | ${XARGS} ${REINPLACE_CMD} -e 's|malloc.h|stdlib.h|g'
+ @${REINPLACE_CMD} -e 's|doc\/@PACKAGE@-@VERSION@|doc\/@PACKAGE@|g' ${WRKSRC}/Makefile.in ${WRKSRC}/html/Makefile.in
+ @${REINPLACE_CMD} -e '/html_DATA =/ s|COPYING ||' ${WRKSRC}/Makefile.in
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libpst.so.4.1.10
.include <bsd.port.mk>
diff --git a/mail/libpst/pkg-plist b/mail/libpst/pkg-plist
index 1cd374c771a6..1048107c96da 100644
--- a/mail/libpst/pkg-plist
+++ b/mail/libpst/pkg-plist
@@ -1,8 +1,8 @@
bin/lspst
bin/nick2ldif
+%%PST2DII%%bin/pst2dii
bin/pst2ldif
bin/readpst
-%%PST2DII%%bin/pst2dii
include/libpst-4/libpst/common.h
include/libpst-4/libpst/libpst.h
include/libpst-4/libpst/libstrfunc.h