aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2003-05-18 17:55:25 +0800
committerkris <kris@FreeBSD.org>2003-05-18 17:55:25 +0800
commit6f07558a470ffa1d87d80af0b4007d14060e7808 (patch)
tree0a6c4132fdb6c80f82e2405cebd8936484804de4 /mail
parenta06e65bebb2b10d4b6f5dfcff23f08e8d38c918a (diff)
downloadfreebsd-ports-gnome-6f07558a470ffa1d87d80af0b4007d14060e7808.tar.gz
freebsd-ports-gnome-6f07558a470ffa1d87d80af0b4007d14060e7808.tar.zst
freebsd-ports-gnome-6f07558a470ffa1d87d80af0b4007d14060e7808.zip
BROKEN on 5.1: bad C++
Diffstat (limited to 'mail')
-rw-r--r--mail/dkimap4/Makefile8
-rw-r--r--mail/filtermail/Makefile8
-rw-r--r--mail/ftrack/Makefile8
3 files changed, 21 insertions, 3 deletions
diff --git a/mail/dkimap4/Makefile b/mail/dkimap4/Makefile
index b6625735a9e1..b74b1e0e69ba 100644
--- a/mail/dkimap4/Makefile
+++ b/mail/dkimap4/Makefile
@@ -16,6 +16,12 @@ EXTRACT_SUFX= .tgz
MAINTAINER= d.marks@student.umist.ac.uk
COMMENT= IMAP4rev1 and POP3 server from the DBOX BBS package
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
USE_GMAKE= yes
GNU_CONFIGURE= yes
@@ -47,4 +53,4 @@ post-install:
.endif
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/mail/filtermail/Makefile b/mail/filtermail/Makefile
index ce2bd0454df6..88297476b272 100644
--- a/mail/filtermail/Makefile
+++ b/mail/filtermail/Makefile
@@ -23,6 +23,12 @@ LIB_DEPENDS= intl:${PORTSDIR}/devel/gettext \
iconv:${PORTSDIR}/converters/libiconv \
gnugetopt:${PORTSDIR}/devel/libgnugetopt
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -lgnugetopt"
@@ -39,4 +45,4 @@ MAN5= filtermailrc.5 filtermailex.5
EXTRACT_AFTER_ARGS= | ${SED} 's/[mM][aA][iI][lL][fF][iI][lL][tT][eE][rR]/filtermail/g' | ${TAR} -xf -
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/mail/ftrack/Makefile b/mail/ftrack/Makefile
index 34828e283b98..9fd1e0ec3550 100644
--- a/mail/ftrack/Makefile
+++ b/mail/ftrack/Makefile
@@ -16,6 +16,12 @@ COMMENT= FTN Messages tracker
BUILD_DEPENDS= ${LOCALBASE}/lib/libsmapi.a:${PORTSDIR}/mail/smapi
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
USE_ZIP= yes
USE_REINPLACE= yes
USE_GMAKE= yes
@@ -48,4 +54,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/samples/${FILE} ${PREFIX}/etc/ftrack
.endfor
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>