aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2016-01-11 00:44:24 +0800
committerBaptiste Daroussin <bapt@FreeBSD.org>2016-01-11 00:44:24 +0800
commit72a6ab79881652e1f89338a8884439b3054997c7 (patch)
tree4282c6f5d647c3c53fc4a55086aa5581631c9073 /mail
parent05cf3794df65552ba3729dc0cd6d58735c40641f (diff)
downloadfreebsd-ports-gnome-72a6ab79881652e1f89338a8884439b3054997c7.tar.gz
freebsd-ports-gnome-72a6ab79881652e1f89338a8884439b3054997c7.tar.zst
freebsd-ports-gnome-72a6ab79881652e1f89338a8884439b3054997c7.zip
Convert categories m* and m* to USES=sqlite and USES=firebird
Diffstat (limited to 'mail')
-rw-r--r--mail/bogofilter-sqlite/Makefile3
-rw-r--r--mail/cyrus-imapd25/Makefile2
-rw-r--r--mail/evolution-ews/Makefile3
-rw-r--r--mail/ezmlm-idx/Makefile2
-rw-r--r--mail/greylite/Makefile3
-rw-r--r--mail/libmapi/Makefile4
-rw-r--r--mail/qsf/Makefile2
-rw-r--r--mail/rspamd-devel/Makefile3
-rw-r--r--mail/rspamd/Makefile3
9 files changed, 10 insertions, 15 deletions
diff --git a/mail/bogofilter-sqlite/Makefile b/mail/bogofilter-sqlite/Makefile
index 003bee84790d..f57d2fd75342 100644
--- a/mail/bogofilter-sqlite/Makefile
+++ b/mail/bogofilter-sqlite/Makefile
@@ -8,8 +8,7 @@ PKGNAMESUFFIX= -sqlite
MAINTAINER= mandree@FreeBSD.org
-USE_SQLITE= 3
-
+USES= sqlite
CONFLICTS_INSTALL= bogofilter-[0-9]* bogofilter-qdbm-[0-9]* bogofilter-tc-[0-9]* [a-z][a-z]-bogofilter-[0-9]*
CONFIGURE_ARGS= --with-database=sqlite
diff --git a/mail/cyrus-imapd25/Makefile b/mail/cyrus-imapd25/Makefile
index aa3bec0c4c81..455ae861ea23 100644
--- a/mail/cyrus-imapd25/Makefile
+++ b/mail/cyrus-imapd25/Makefile
@@ -162,7 +162,7 @@ IGNORE= DRAC is not available
.endif
.if ${PORT_OPTIONS:MHTTP} || ${PORT_OPTIONS:MSQLITE}
-USE_SQLITE=yes
+USES+= sqlite
.endif
.if !${PORT_OPTIONS:MGSSAPI_BASE} && !${PORT_OPTIONS:MGSSAPI_HEIMDAL} && \
diff --git a/mail/evolution-ews/Makefile b/mail/evolution-ews/Makefile
index f82641d7152f..aaff214092de 100644
--- a/mail/evolution-ews/Makefile
+++ b/mail/evolution-ews/Makefile
@@ -18,10 +18,9 @@ RUN_DEPENDS= evolution>=3.0.0:${PORTSDIR}/mail/evolution
PORTSCOUT= limitw:1,even
-USES= gettext gmake libtool pathfix pkgconfig tar:xz
+USES= gettext gmake libtool pathfix pkgconfig sqlite tar:xz
USE_GNOME= intltool
GNU_CONFIGURE= yes
-USE_SQLITE= 3
USE_BDB= 5
USE_OPENLDAP= yes
USE_LDCONFIG= yes
diff --git a/mail/ezmlm-idx/Makefile b/mail/ezmlm-idx/Makefile
index c4402bcaddf3..c287daeb0022 100644
--- a/mail/ezmlm-idx/Makefile
+++ b/mail/ezmlm-idx/Makefile
@@ -52,7 +52,7 @@ PLIST_SUB+= MYSQL="@comment " PGSQL="" SQLITE="@comment "
.endif
.if ${PORT_OPTIONS:MSQLITE}
-USE_SQLITE= yes
+USES+= sqlite
EXTRACT_INCLUDE+= -I${LOCALBASE}/include
EXTRACT_LIB+= -L${LOCALBASE}/lib -lsqlite3
ALL_TARGET+= sqlite3
diff --git a/mail/greylite/Makefile b/mail/greylite/Makefile
index f998b93e107e..bc5e5bf259ac 100644
--- a/mail/greylite/Makefile
+++ b/mail/greylite/Makefile
@@ -14,8 +14,7 @@ LICENSE= BSD3CLAUSE
RUN_DEPENDS= tcpserver:${PORTSDIR}/sysutils/ucspi-tcp
-USES= tar:bzip2
-USE_SQLITE= 3
+USES= sqlite tar:bzip2
PLIST_FILES= bin/greylite \
%%DNSBLENV%%bin/dnsblenv \
%%UCSPI2SOCKET%%bin/ucspi2socket \
diff --git a/mail/libmapi/Makefile b/mail/libmapi/Makefile
index f43c01cfaf1a..8430472126c7 100644
--- a/mail/libmapi/Makefile
+++ b/mail/libmapi/Makefile
@@ -22,8 +22,8 @@ RUN_DEPENDS= ${SAMBA_DEP}
CODENAME= QUADRANT
DOWNLOADCODE= 244
-USE_SQLITE= 3
-USES= compiler:c++11-lib gmake pathfix pkgconfig python shebangfix
+USES= compiler:c++11-lib gmake pathfix pkgconfig python shebangfix \
+ sqlite
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/mail/qsf/Makefile b/mail/qsf/Makefile
index 6bf18d47dd56..ae0146f20d16 100644
--- a/mail/qsf/Makefile
+++ b/mail/qsf/Makefile
@@ -37,7 +37,7 @@ CONFIGURE_ARGS+= --without-mysql
.endif
.if ${PORT_OPTIONS:MSQLITE2}
-USE_SQLITE= 2
+USES+= sqlite:2
.else
CONFIGURE_ARGS+= --without-sqlite
.endif
diff --git a/mail/rspamd-devel/Makefile b/mail/rspamd-devel/Makefile
index 798004ff553e..f65a29235282 100644
--- a/mail/rspamd-devel/Makefile
+++ b/mail/rspamd-devel/Makefile
@@ -45,13 +45,12 @@ CMAKE_ARGS+= -DCONFDIR=${PREFIX}/etc/rspamd \
-DDEBUG=ON
USES= cmake:outsource gettext iconv pkgconfig tar:xz perl5 \
- compiler:c11
+ compiler:c11 sqlite
USE_LDCONFIG= yes
USE_PERL5= build
USE_GNOME= glib20
USE_OPENSSL= yes
-USE_SQLITE= yes
DEBUG_FLAGS= -g -O0
WITH_DEBUG= yes
diff --git a/mail/rspamd/Makefile b/mail/rspamd/Makefile
index 6228593e63dc..9b4d80a02546 100644
--- a/mail/rspamd/Makefile
+++ b/mail/rspamd/Makefile
@@ -40,13 +40,12 @@ CMAKE_ARGS+= -DCONFDIR=${PREFIX}/etc/rspamd \
-DNO_SHARED=ON
USES= cmake:outsource gettext iconv pkgconfig tar:xz perl5 \
- compiler:c11
+ compiler:c11 sqlite
USE_LDCONFIG= yes
USE_PERL5= build
USE_GNOME= glib20
USE_OPENSSL= yes
-USE_SQLITE= yes
.include <bsd.port.options.mk>