aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2009-06-23 07:03:12 +0800
committerpgollucci <pgollucci@FreeBSD.org>2009-06-23 07:03:12 +0800
commit7589398ff9779dc9f33008da8aca1bf1a6299894 (patch)
tree6c677d35edfc400fa03b2eecdde40cd90c47ab7e /mail
parentbdce9acb7ac8ff410c9bec510628a7a3d6911e4d (diff)
downloadfreebsd-ports-gnome-7589398ff9779dc9f33008da8aca1bf1a6299894.tar.gz
freebsd-ports-gnome-7589398ff9779dc9f33008da8aca1bf1a6299894.tar.zst
freebsd-ports-gnome-7589398ff9779dc9f33008da8aca1bf1a6299894.zip
- Ressurrect correctly and update to 1.2.13
Diffstat (limited to 'mail')
-rw-r--r--mail/qmailadmin-devel/Makefile136
-rw-r--r--mail/qmailadmin-devel/distinfo3
-rw-r--r--mail/qmailadmin-devel/pkg-descr3
-rw-r--r--mail/qmailadmin-devel/pkg-plist85
4 files changed, 227 insertions, 0 deletions
diff --git a/mail/qmailadmin-devel/Makefile b/mail/qmailadmin-devel/Makefile
new file mode 100644
index 000000000000..fb0c90b7a014
--- /dev/null
+++ b/mail/qmailadmin-devel/Makefile
@@ -0,0 +1,136 @@
+# New ports collection makefile for: qmailadmin
+# Date created: 31 May 2009
+# Whom: Ismail YENIGUL
+#
+# $FreeBSD$
+#
+
+PORTNAME= qmailadmin
+PORTVERSION= 1.2.13
+PORTEPOCH= 1
+CATEGORIES= mail www
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ismail.yenigul@endersys.com.tr
+COMMENT= CGI program for administering Qmail with vchkpw/vpopmail
+
+# vpopmail installation directory
+#
+# NB: change this with extreme caution! For instance, if vpopmail is not
+# already installed in this directory, building the vpopmail port as
+# a dependency will NOT automatically cause it to be installed there!
+
+VPOPMAIL_DIR?= ${LOCALBASE}/vpopmail
+
+BUILD_DEPENDS= \
+ autorespond:${PORTSDIR}/mail/autorespond \
+ ${VPOPMAIL_DIR}/lib/libvpopmail.a:${PORTSDIR}/mail/vpopmail
+RUN_DEPENDS= \
+ autorespond:${PORTSDIR}/mail/autorespond \
+ ${VPOPMAIL_DIR}/lib/libvpopmail.a:${PORTSDIR}/mail/vpopmail
+
+.if defined(WITHOUT_IDX)
+BUILD_DEPENDS+= ezmlm-send:${PORTSDIR}/mail/ezmlm
+RUN_DEPENDS+= ezmlm-send:${PORTSDIR}/mail/ezmlm
+.else
+BUILD_DEPENDS+= ezmlm-idx:${PORTSDIR}/mail/ezmlm-idx
+RUN_DEPENDS+= ezmlm-idx:${PORTSDIR}/mail/ezmlm-idx
+.endif
+
+CONFLICTS= qmailadmin-1.*
+
+GNU_CONFIGURE= YES
+USE_GMAKE= YES
+WANT_QMAIL= yes
+
+#
+# User-configurable variables
+#
+# CGIBINDIR - location of your cgi directory
+# CGIBINSUBDIR - subdirectory to place cgi scripts in
+# CGIBINURL - location of your cgi directory in a URL
+# WEBDATADIR - location of your html files
+# WEBDATASUBDIR - subdirectory to place html files in
+# WEBDATAURL - location of your html files in a URL
+#
+# WITHOUT_IPAUTH - disable the IP address check after login
+# WITHOUT_USER_INDEX - disable the user index display, which might
+# confuse earlier versions of Internet Explorer
+# WITH_MODIFY_QUOTA - enable domain admin to modify user quotas
+# WITH_DOMAIN_AUTOFILL - autofill the domain on login page based on the
+# hostname
+# WITHOUT_IDX_SQL - disable the SQL support for mailing lists
+# WITH_HELP - display help links on login page
+#
+# WITH_SPAM_DETECTION - allow users to enable/disable spam checking
+# SPAM_COMMAND - the command to use to check for spam;
+# default is "|preline /usr/local/bin/maildrop /etc/mailfilter"
+# do not forget the "|" at the start
+# WITH_SPAM_NEEDS_EMAIL - append the user's e-mail address as the last
+# argument to the spam command
+#
+
+CGIBINDIR?= www/cgi-bin.default
+CGIBINSUBDIR?= qmailadmin
+CGIBINURL?= /cgi-bin
+WEBDATADIR?= www/data.default
+WEBDATASUBDIR?= qmailadmin
+WEBDATAURL?=
+
+PLIST_SUB+= CGIBINDIR="${CGIBINDIR}" CGIBINSUBDIR="${CGIBINSUBDIR}" \
+ WEBDATADIR="${WEBDATADIR}" WEBDATASUBDIR="${WEBDATASUBDIR}"
+
+.include <bsd.port.pre.mk>
+
+# End of user-configurable variables
+
+CONFIGURE_ARGS+= \
+ --enable-qmaildir=${QMAIL_PREFIX} \
+ --enable-htmldir=${PREFIX}/${WEBDATADIR}/${WEBDATASUBDIR} \
+ --enable-imagedir=${PREFIX}/${WEBDATADIR}/${WEBDATASUBDIR}/images \
+ --enable-imageurl=${WEBDATAURL}/${WEBDATASUBDIR}/images \
+ --enable-htmllibdir=${DATADIR} \
+ --enable-cgibindir=${PREFIX}/${CGIBINDIR}/${CGIBINSUBDIR} \
+ --enable-cgipath=${CGIBINURL}/${CGIBINSUBDIR}/qmailadmin \
+ --enable-vpopmaildir=${VPOPMAIL_DIR} \
+ --enable-autoresponder-path=${LOCALBASE}/bin \
+ --enable-ezmlmdir=${LOCALBASE}/bin
+
+.if defined(WITHOUT_IPAUTH)
+CONFIGURE_ARGS+= --disable-ipauth
+.endif
+
+.if defined(WITHOUT_USER_INDEX)
+CONFIGURE_ARGS+= --disable-user-index
+.endif
+
+.if defined(WITH_MODIFY_QUOTA)
+CONFIGURE_ARGS+= --enable-modify-quota
+.endif
+
+.if defined(WITH_DOMAIN_AUTOFILL)
+CONFIGURE_ARGS+= --enable-domain-autofill
+.endif
+
+.if defined(WITHOUT_IDX_SQL)
+CONFIGURE_ARGS+= --disable-ezmlm-mysql
+.endif
+
+.if defined(WITH_HELP)
+CONFIGURE_ARGS+= --enable-help
+.endif
+
+.if defined(WITH_SPAM_DETECTION)
+CONFIGURE_ARGS+= --enable-modify-spam=y
+.if defined(SPAM_COMMAND)
+CONFIGURE_ARGS+= --enable-spam-command="${SPAM_COMMAND}"
+.endif
+.if defined(WITH_SPAM_NEEDS_EMAIL)
+CONFIGURE_ARGS+= --enable-spamcmd-needs-email
+.else
+CONFIGURE_ARGS+= --disable-spamcmd-needs-email
+.endif
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/mail/qmailadmin-devel/distinfo b/mail/qmailadmin-devel/distinfo
new file mode 100644
index 000000000000..764f10ddebc9
--- /dev/null
+++ b/mail/qmailadmin-devel/distinfo
@@ -0,0 +1,3 @@
+MD5 (qmailadmin-1.2.13.tar.gz) = cce2865e5b6d735c79d3caa2b8201db6
+SHA256 (qmailadmin-1.2.13.tar.gz) = 5e363f6bc6f0bb2d7dbac57006e1247dd49065bf24dc7e7c60336ab712d5f68c
+SIZE (qmailadmin-1.2.13.tar.gz) = 405251
diff --git a/mail/qmailadmin-devel/pkg-descr b/mail/qmailadmin-devel/pkg-descr
new file mode 100644
index 000000000000..5ff40bf2cab5
--- /dev/null
+++ b/mail/qmailadmin-devel/pkg-descr
@@ -0,0 +1,3 @@
+QmailAdmin is a cgi program for administering Qmail with vchkpw.
+
+WWW: http://www.inter7.com/qmailadmin/
diff --git a/mail/qmailadmin-devel/pkg-plist b/mail/qmailadmin-devel/pkg-plist
new file mode 100644
index 000000000000..5b5808995d7e
--- /dev/null
+++ b/mail/qmailadmin-devel/pkg-plist
@@ -0,0 +1,85 @@
+%%DATADIR%%/html/add_autorespond.html
+%%DATADIR%%/html/add_forward.html
+%%DATADIR%%/html/add_listmod.html
+%%DATADIR%%/html/add_listdig.html
+%%DATADIR%%/html/add_listuser.html
+%%DATADIR%%/html/add_mailinglist-idx.html
+%%DATADIR%%/html/add_mailinglist-no-idx.html
+%%DATADIR%%/html/add_user.html
+%%DATADIR%%/html/change_password.html
+%%DATADIR%%/html/change_password_success.html
+%%DATADIR%%/html/colortable
+%%DATADIR%%/html/del_autorespond_confirm.html
+%%DATADIR%%/html/del_forward_confirm.html
+%%DATADIR%%/html/del_listdig.html
+%%DATADIR%%/html/del_listmod.html
+%%DATADIR%%/html/del_listuser.html
+%%DATADIR%%/html/del_mailinglist_confirm.html
+%%DATADIR%%/html/del_user_confirm.html
+%%DATADIR%%/html/footer.html
+%%DATADIR%%/html/header.html
+%%DATADIR%%/html/main_menu.html
+%%DATADIR%%/html/mod_autorespond.html
+%%DATADIR%%/html/mod_dotqmail.html
+%%DATADIR%%/html/mod_mailinglist-idx.html
+%%DATADIR%%/html/mod_user.html
+%%DATADIR%%/html/setremotecatchall.html
+%%DATADIR%%/html/show_autorespond.html
+%%DATADIR%%/html/show_digest_subscribers.html
+%%DATADIR%%/html/show_forwards.html
+%%DATADIR%%/html/show_login.html
+%%DATADIR%%/html/show_mailinglist.html
+%%DATADIR%%/html/show_moderators.html
+%%DATADIR%%/html/show_subscribers.html
+%%DATADIR%%/html/show_users.html
+%%DATADIR%%/lang/bg
+%%DATADIR%%/lang/cs
+%%DATADIR%%/lang/da
+%%DATADIR%%/lang/de
+%%DATADIR%%/lang/en
+%%DATADIR%%/lang/es
+%%DATADIR%%/lang/fi
+%%DATADIR%%/lang/fr
+%%DATADIR%%/lang/hu
+%%DATADIR%%/lang/it
+%%DATADIR%%/lang/ja
+%%DATADIR%%/lang/lt
+%%DATADIR%%/lang/nl
+%%DATADIR%%/lang/no
+%%DATADIR%%/lang/pl
+%%DATADIR%%/lang/pt-br
+%%DATADIR%%/lang/ru
+%%DATADIR%%/lang/sk
+%%DATADIR%%/lang/sv
+%%DATADIR%%/lang/tr
+%%DATADIR%%/lang/zh-cn
+%%CGIBINDIR%%/%%CGIBINSUBDIR%%/qmailadmin
+%%WEBDATADIR%%/%%WEBDATASUBDIR%%/images/delete.png
+%%WEBDATADIR%%/%%WEBDATASUBDIR%%/images/disabled.png
+%%WEBDATADIR%%/%%WEBDATASUBDIR%%/images/lowerleft.png
+%%WEBDATADIR%%/%%WEBDATASUBDIR%%/images/lowermiddle.png
+%%WEBDATADIR%%/%%WEBDATASUBDIR%%/images/lowerright.png
+%%WEBDATADIR%%/%%WEBDATASUBDIR%%/images/main.png
+%%WEBDATADIR%%/%%WEBDATASUBDIR%%/images/main1.png
+%%WEBDATADIR%%/%%WEBDATASUBDIR%%/images/main2.png
+%%WEBDATADIR%%/%%WEBDATASUBDIR%%/images/middleleft1.png
+%%WEBDATADIR%%/%%WEBDATASUBDIR%%/images/middleleft2.png
+%%WEBDATADIR%%/%%WEBDATASUBDIR%%/images/middlelogin.png
+%%WEBDATADIR%%/%%WEBDATASUBDIR%%/images/middleright1.png
+%%WEBDATADIR%%/%%WEBDATASUBDIR%%/images/modify.png
+%%WEBDATADIR%%/%%WEBDATASUBDIR%%/images/pixel.png
+%%WEBDATADIR%%/%%WEBDATASUBDIR%%/images/radio-on.png
+%%WEBDATADIR%%/%%WEBDATASUBDIR%%/images/radio-off.png
+%%WEBDATADIR%%/%%WEBDATASUBDIR%%/images/trash.png
+%%WEBDATADIR%%/%%WEBDATASUBDIR%%/images/upperleft.png
+%%WEBDATADIR%%/%%WEBDATASUBDIR%%/images/uppermiddle1.png
+%%WEBDATADIR%%/%%WEBDATASUBDIR%%/images/uppermiddle2.png
+%%WEBDATADIR%%/%%WEBDATASUBDIR%%/images/upperright.png
+@dirrm %%WEBDATADIR%%/%%WEBDATASUBDIR%%/images
+@unexec /bin/rmdir %D/%%WEBDATADIR%%/%%WEBDATASUBDIR%% 2> /dev/null || true
+@unexec /bin/rmdir %D/%%WEBDATADIR%% 2> /dev/null || true
+@unexec /bin/rmdir %D/%%CGIBINDIR%%/%%CGIBINSUBDIR%% 2> /dev/null || true
+@unexec /bin/rmdir %D/%%CGIBINDIR%% 2> /dev/null || true
+@dirrm %%DATADIR%%/html
+@dirrm %%DATADIR%%/lang
+@dirrm %%DATADIR%%