aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2014-09-14 10:06:58 +0800
committerswills <swills@FreeBSD.org>2014-09-14 10:06:58 +0800
commit7d5c7d52c15e838cdc0ce72b3f27825438e2c7c0 (patch)
tree80b3dcb025ec943583a478981072ebc0ef107aa8 /mail
parent757ceae806b4708dcfb75afe4a5429c1c13770b4 (diff)
downloadfreebsd-ports-gnome-7d5c7d52c15e838cdc0ce72b3f27825438e2c7c0.tar.gz
freebsd-ports-gnome-7d5c7d52c15e838cdc0ce72b3f27825438e2c7c0.tar.zst
freebsd-ports-gnome-7d5c7d52c15e838cdc0ce72b3f27825438e2c7c0.zip
www/rubygem-rails4: create port for rails4
This port required creating a number of new ports, old versions of existing ports and other adjustments, so do all that while here too. Rails is a web-application framework for the MVC pattern that includes both a template engine, controller framework, and object-relational mapping package. Everything needed to develop web-apps that can run on CGI, FastCGI, and mod_ruby Being a full-stack framework means that all layers are built to work seamlessly together. That way you Don't Repeat Yourself (DRY) and you can use a single language from top to bottom. Everything from templates to control flow to business logic is written in Ruby - The language of love for industry heavy-weights. WWW: http://www.rubyonrails.org Submitted by: xmj (based on)
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile2
-rw-r--r--mail/rubygem-actionmailer4/Makefile23
-rw-r--r--mail/rubygem-actionmailer4/distinfo2
-rw-r--r--mail/rubygem-actionmailer4/pkg-descr10
-rw-r--r--mail/rubygem-mail/Makefile5
-rw-r--r--mail/rubygem-mail/distinfo4
6 files changed, 41 insertions, 5 deletions
diff --git a/mail/Makefile b/mail/Makefile
index 3b1e21f9b845..c9705fb9dd0a 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -566,9 +566,11 @@
SUBDIR += ruby-rfilter
SUBDIR += ruby-rmail
SUBDIR += rubygem-actionmailer
+ SUBDIR += rubygem-actionmailer4
SUBDIR += rubygem-exception_notification
SUBDIR += rubygem-larch
SUBDIR += rubygem-mail
+ SUBDIR += rubygem-mail25
SUBDIR += rubygem-mailfactory
SUBDIR += rubygem-pony
SUBDIR += rubygem-qmail
diff --git a/mail/rubygem-actionmailer4/Makefile b/mail/rubygem-actionmailer4/Makefile
new file mode 100644
index 000000000000..f8c6b8a77a58
--- /dev/null
+++ b/mail/rubygem-actionmailer4/Makefile
@@ -0,0 +1,23 @@
+# Created by: Johannes Meixner <xmj@chaot.net>
+# $FreeBSD$
+
+PORTNAME= actionmailer
+PORTVERSION= 4.1.6
+CATEGORIES= mail rubygems
+MASTER_SITES= RG
+PKGNAMESUFFIX= 4
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= Easy email delivery and testing for Ruby
+
+LICENSE= MIT
+
+RUN_DEPENDS= rubygem-actionpack4>=${PORTVERSION}:${PORTSDIR}/www/rubygem-actionpack4 \
+ rubygem-actionview>=${PORTVERSION}:${PORTSDIR}/devel/rubygem-actionview \
+ rubygem-mail>=2.5.4:${PORTSDIR}/mail/rubygem-mail
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/mail/rubygem-actionmailer4/distinfo b/mail/rubygem-actionmailer4/distinfo
new file mode 100644
index 000000000000..93de627d7abd
--- /dev/null
+++ b/mail/rubygem-actionmailer4/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/actionmailer-4.1.6.gem) = 9b03de00a3c0e19034e98f35d29c298e858556f1033799ea6ffc9eca014c5cd3
+SIZE (rubygem/actionmailer-4.1.6.gem) = 24576
diff --git a/mail/rubygem-actionmailer4/pkg-descr b/mail/rubygem-actionmailer4/pkg-descr
new file mode 100644
index 000000000000..2af9adc06c58
--- /dev/null
+++ b/mail/rubygem-actionmailer4/pkg-descr
@@ -0,0 +1,10 @@
+Action Mailer is framework for designing email-service layers. These layers
+are used to consolidate code for sending out forgotten passwords, welcoming
+wishes on signup, invoices for billing, and any other use case that requires
+a written notification to either a person or another system.
+
+Additionally, an Action Mailer class can be used to process incoming email,
+such as allowing a weblog to accept new posts from an email (which could even
+have been sent from a phone)
+
+WWW: http://www.rubyonrails.org
diff --git a/mail/rubygem-mail/Makefile b/mail/rubygem-mail/Makefile
index 3aaba4881f53..7d4d92a4603d 100644
--- a/mail/rubygem-mail/Makefile
+++ b/mail/rubygem-mail/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= mail
-PORTVERSION= 2.5.4
+PORTVERSION= 2.6.1
PORTEPOCH= 2
CATEGORIES= mail rubygems
MASTER_SITES= RG
@@ -12,8 +12,7 @@ COMMENT= Ruby email handler
LICENSE= MIT
-RUN_DEPENDS= rubygem-mime-types1>=1.25.1:${PORTSDIR}/misc/rubygem-mime-types1 \
- rubygem-treetop>=1.4.8:${PORTSDIR}/devel/rubygem-treetop
+RUN_DEPENDS= rubygem-mime-types>=2.3:${PORTSDIR}/misc/rubygem-mime-types
USE_RUBY= yes
USE_RUBYGEMS= yes
diff --git a/mail/rubygem-mail/distinfo b/mail/rubygem-mail/distinfo
index 897f24fe816a..2b13db40541a 100644
--- a/mail/rubygem-mail/distinfo
+++ b/mail/rubygem-mail/distinfo
@@ -1,2 +1,2 @@
-SHA256 (rubygem/mail-2.5.4.gem) = 446585c38b062121252688dcc9cc70af1f470822e30db021bb97d185969e257c
-SIZE (rubygem/mail-2.5.4.gem) = 272384
+SHA256 (rubygem/mail-2.6.1.gem) = 1d56216c0a426f908e8726d44209dc3140b37f8b34e1653b99301e664fe1fa9d
+SIZE (rubygem/mail-2.6.1.gem) = 335872