aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorbarner <barner@FreeBSD.org>2008-04-09 04:23:18 +0800
committerbarner <barner@FreeBSD.org>2008-04-09 04:23:18 +0800
commit8094c6e2e6b70941c1b0e84504337b6534da92e1 (patch)
treebf82ce5738c7a7c570b4bff61b8ed73f47b4338d /mail
parent8883258a63b751c2484a7c7407637d7060e25da6 (diff)
downloadfreebsd-ports-gnome-8094c6e2e6b70941c1b0e84504337b6534da92e1.tar.gz
freebsd-ports-gnome-8094c6e2e6b70941c1b0e84504337b6534da92e1.tar.zst
freebsd-ports-gnome-8094c6e2e6b70941c1b0e84504337b6534da92e1.zip
- Fix SSL support
- Bump port revision PR: ports/122574 Submitted by: Sven Herschke
Diffstat (limited to 'mail')
-rw-r--r--mail/kbiff/Makefile14
-rw-r--r--mail/kbiff/files/patch-configure20
2 files changed, 32 insertions, 2 deletions
diff --git a/mail/kbiff/Makefile b/mail/kbiff/Makefile
index 2a789ba053b6..62b326947fd2 100644
--- a/mail/kbiff/Makefile
+++ b/mail/kbiff/Makefile
@@ -7,7 +7,7 @@
PORTNAME= kbiff
PORTVERSION= 3.8
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= mail kde
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -23,9 +23,19 @@ CONFIGURE_ARGS= --disable-fast-perl
CONFIGURE_ENV+= LDFLAGS="${LDFLAGS} ${PTHREAD_LIBS}"
MAN1= kbiff.1
+OPTIONS= SSL "SSL support" on
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_SSL)
+CONFIGURE_ARGS+=--enable-ssl
+.else
+CONFIGURE_ARGS+=--disable-ssl
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|-pthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|-D_THREAD_SAFE|${PTHREAD_CFLAGS}|g' ${WRKSRC}/configure
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/mail/kbiff/files/patch-configure b/mail/kbiff/files/patch-configure
new file mode 100644
index 000000000000..3b3f6db646aa
--- /dev/null
+++ b/mail/kbiff/files/patch-configure
@@ -0,0 +1,20 @@
+--- configure.orig 2008-04-08 21:45:31.000000000 +0200
++++ configure 2008-04-08 21:45:50.000000000 +0200
+@@ -25477,7 +25477,7 @@
+ use_ssl=yes
+ fi;
+
+-if test "$use_ssl" == "yes"; then
++if test "$use_ssl" = "yes"; then
+
+ cat >>confdefs.h <<\_ACEOF
+ #define USE_SSL
+@@ -25494,7 +25494,7 @@
+ use_ssl=yes
+ fi;
+
+-if test "$use_ssl" == "yes"; then
++if test "$use_ssl" = "yes"; then
+
+ cat >>confdefs.h <<\_ACEOF
+ #define USE_SSL