aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorerwin <erwin@FreeBSD.org>2005-07-13 20:40:43 +0800
committererwin <erwin@FreeBSD.org>2005-07-13 20:40:43 +0800
commit84ca7d184aeefac25ce307cdb88da22af20d6c06 (patch)
tree4541c7301f04a7eca35bcbabe2d61f4b682f5a6b /mail
parent15e5df08e88c2f526859dd841c7d12bca8c97b41 (diff)
downloadfreebsd-ports-gnome-84ca7d184aeefac25ce307cdb88da22af20d6c06.tar.gz
freebsd-ports-gnome-84ca7d184aeefac25ce307cdb88da22af20d6c06.tar.zst
freebsd-ports-gnome-84ca7d184aeefac25ce307cdb88da22af20d6c06.zip
Add p5-Sendmail-AccessDB 0.09, perl5 interface to the Sendmail access.db
list. PR: ports/82772 Submitted by: Emanuel Haupt <ehaupt@critical.ch>
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/p5-Sendmail-AccessDB/Makefile31
-rw-r--r--mail/p5-Sendmail-AccessDB/distinfo2
-rw-r--r--mail/p5-Sendmail-AccessDB/pkg-descr10
-rw-r--r--mail/p5-Sendmail-AccessDB/pkg-plist5
5 files changed, 49 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index 519888ab0203..6be3a2ac31fb 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -324,6 +324,7 @@
SUBDIR += p5-POE-Component-Client-SMTP
SUBDIR += p5-POE-Component-SMTP
SUBDIR += p5-Qmail-Envelope
+ SUBDIR += p5-Sendmail-AccessDB
SUBDIR += p5-Sendmail-Milter
SUBDIR += p5-URI-imap
SUBDIR += p5-URI-imaps
diff --git a/mail/p5-Sendmail-AccessDB/Makefile b/mail/p5-Sendmail-AccessDB/Makefile
new file mode 100644
index 000000000000..9c2235cfc66b
--- /dev/null
+++ b/mail/p5-Sendmail-AccessDB/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-Sendmail-AccessDB
+# Date created: 29 Jun 2005
+# Whom: Emanuel Haupt <ehaupt@critical.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Sendmail-AccessDB
+PORTVERSION= 0.09
+CATEGORIES= mail perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Sendmail
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ehaupt@critical.ch
+COMMENT= Perl5 interface to the Sendmail access.db list
+
+BUILD_DEPENDS= ${SITE_PERL}/mach/BerkeleyDB.pm:${PORTSDIR}/databases/p5-BerkeleyDB
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Sendmail::AccessDB.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500806
+IGNORE= needs Perl 5.8.6 or above (lang/perl5.8)
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/mail/p5-Sendmail-AccessDB/distinfo b/mail/p5-Sendmail-AccessDB/distinfo
new file mode 100644
index 000000000000..f4eb39a588b0
--- /dev/null
+++ b/mail/p5-Sendmail-AccessDB/distinfo
@@ -0,0 +1,2 @@
+MD5 (Sendmail-AccessDB-0.09.tar.gz) = 7a3fe220a14259a8d8f000aac8e53048
+SIZE (Sendmail-AccessDB-0.09.tar.gz) = 15129
diff --git a/mail/p5-Sendmail-AccessDB/pkg-descr b/mail/p5-Sendmail-AccessDB/pkg-descr
new file mode 100644
index 000000000000..9d7ea706c0f0
--- /dev/null
+++ b/mail/p5-Sendmail-AccessDB/pkg-descr
@@ -0,0 +1,10 @@
+This module is designed so that users of the Sendmail::Milter module (or other
+Sendmail programmers) can ascertain if a user has elected to whitelist
+themselves as a "spam friend" (where there should be no spam filtering on mail
+to them) or, where spam-filtering is not the default, but an option, where
+certain receipients have been labeled as "spam haters".
+
+WWW: http://search.cpan.org/dist/Sendmail-AccessDB/
+
+- ehaupt
+ehaupt@critical.ch
diff --git a/mail/p5-Sendmail-AccessDB/pkg-plist b/mail/p5-Sendmail-AccessDB/pkg-plist
new file mode 100644
index 000000000000..d36e8db1bf8c
--- /dev/null
+++ b/mail/p5-Sendmail-AccessDB/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Sendmail/AccessDB.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Sendmail/AccessDB/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Sendmail/AccessDB
+@unexec rmdir %D/%%SITE_PERL%%/Sendmail 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Sendmail 2>/dev/null || true