aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2003-06-12 10:17:45 +0800
committerlioux <lioux@FreeBSD.org>2003-06-12 10:17:45 +0800
commit883051c0a5600bc0519b425772c123d315cb95d8 (patch)
tree6af4de64d66703380dbb8a2ab81a4a269e2da468 /mail
parent0d2e91d7f831f506f49d64ff0cd34f1ee0c36e46 (diff)
downloadfreebsd-ports-gnome-883051c0a5600bc0519b425772c123d315cb95d8.tar.gz
freebsd-ports-gnome-883051c0a5600bc0519b425772c123d315cb95d8.tar.zst
freebsd-ports-gnome-883051c0a5600bc0519b425772c123d315cb95d8.zip
o Replace openldap20 dependency on openldap21
o Prefer openldap12 if it's already installed. Otherwise, depend on openldap21 PR: 53123 Submitted by: maintainer
Diffstat (limited to 'mail')
-rw-r--r--mail/horde-turba/Makefile16
-rw-r--r--mail/horde4-turba/Makefile16
-rw-r--r--mail/imp3/Makefile13
-rw-r--r--mail/turba/Makefile16
4 files changed, 23 insertions, 38 deletions
diff --git a/mail/horde-turba/Makefile b/mail/horde-turba/Makefile
index bd198fa9961f..81028a575cf1 100644
--- a/mail/horde-turba/Makefile
+++ b/mail/horde-turba/Makefile
@@ -7,6 +7,7 @@
PORTNAME= turba
PORTVERSION= 1.2
+PORTREVISION= 1
CATEGORIES= mail www
MASTER_SITES= ftp://ftp.horde.org/pub/turba/ \
ftp://ftp.au.horde.org/pub/horde/turba/ \
@@ -19,22 +20,17 @@ MAINTAINER= thierry@pompo.net
COMMENT= The Horde contact management application
#-----------------------------------------------------------------------
-# You may define these options:
+# You may define this option:
#
# - WITHOUT_LDAP : if you do not need OpenLDAP;
-# - WITH_LDAP1 : if you prefer OpenLDAP1.
-#
-# - WITHOUT_SUPPORTED_DB: if you run a database not in the ports tree;
#
#-----------------------------------------------------------------------
.if !defined(WITHOUT_LDAP)
-.if defined(WITH_LDAP1)
-LIB_DEPENDS+= ldap.1:${PORTSDIR}/net/openldap12 \
- lber.1:${PORTSDIR}/net/openldap12
+.if exists(${LOCALBASE}/lib/libldap.so.1)
+LIB_DEPENDS+= ldap.1:${PORTSDIR}/net/openldap12
.else
-LIB_DEPENDS+= ldap.2:${PORTSDIR}/net/openldap20 \
- lber.2:${PORTSDIR}/net/openldap20
+LIB_DEPENDS+= ldap.2:${PORTSDIR}/net/openldap21
.endif
.endif
@@ -70,7 +66,7 @@ PHPSO= ${LOCALBASE}/libexec/apache/libphp4.so
pre-install:
.if !defined(WITHOUT_LDAP)
-.if defined(WITH_LDAP1)
+.if exists(${LOCALBASE}/lib/libldap.so.1)
@if ! ${LDD} ${PHPSO} | ${GREP} -q -e "libldap.so.1"; then \
${ECHO_MSG} "" ; \
${ECHO_MSG} "Please configure PHP with OpenLDAP support." ; \
diff --git a/mail/horde4-turba/Makefile b/mail/horde4-turba/Makefile
index bd198fa9961f..81028a575cf1 100644
--- a/mail/horde4-turba/Makefile
+++ b/mail/horde4-turba/Makefile
@@ -7,6 +7,7 @@
PORTNAME= turba
PORTVERSION= 1.2
+PORTREVISION= 1
CATEGORIES= mail www
MASTER_SITES= ftp://ftp.horde.org/pub/turba/ \
ftp://ftp.au.horde.org/pub/horde/turba/ \
@@ -19,22 +20,17 @@ MAINTAINER= thierry@pompo.net
COMMENT= The Horde contact management application
#-----------------------------------------------------------------------
-# You may define these options:
+# You may define this option:
#
# - WITHOUT_LDAP : if you do not need OpenLDAP;
-# - WITH_LDAP1 : if you prefer OpenLDAP1.
-#
-# - WITHOUT_SUPPORTED_DB: if you run a database not in the ports tree;
#
#-----------------------------------------------------------------------
.if !defined(WITHOUT_LDAP)
-.if defined(WITH_LDAP1)
-LIB_DEPENDS+= ldap.1:${PORTSDIR}/net/openldap12 \
- lber.1:${PORTSDIR}/net/openldap12
+.if exists(${LOCALBASE}/lib/libldap.so.1)
+LIB_DEPENDS+= ldap.1:${PORTSDIR}/net/openldap12
.else
-LIB_DEPENDS+= ldap.2:${PORTSDIR}/net/openldap20 \
- lber.2:${PORTSDIR}/net/openldap20
+LIB_DEPENDS+= ldap.2:${PORTSDIR}/net/openldap21
.endif
.endif
@@ -70,7 +66,7 @@ PHPSO= ${LOCALBASE}/libexec/apache/libphp4.so
pre-install:
.if !defined(WITHOUT_LDAP)
-.if defined(WITH_LDAP1)
+.if exists(${LOCALBASE}/lib/libldap.so.1)
@if ! ${LDD} ${PHPSO} | ${GREP} -q -e "libldap.so.1"; then \
${ECHO_MSG} "" ; \
${ECHO_MSG} "Please configure PHP with OpenLDAP support." ; \
diff --git a/mail/imp3/Makefile b/mail/imp3/Makefile
index 497fe4f56210..4eb0de71aa50 100644
--- a/mail/imp3/Makefile
+++ b/mail/imp3/Makefile
@@ -7,7 +7,7 @@
PORTNAME= imp
PORTVERSION= 3.2.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= mail www
MASTER_SITES= ftp://ftp.horde.org/pub/imp/ \
ftp://ftp.au.horde.org/pub/horde/imp/ \
@@ -23,7 +23,6 @@ COMMENT= A webmail system which accesses mail over IMAP
# You may define these options:
#
# - WITHOUT_LDAP : if you do not need OpenLDAP;
-# - WITH_LDAP1 : if you prefer OpenLDAP1.
#
# - WITHOUT_SUPPORTED_DB: if you run a database not in the ports tree;
#
@@ -66,12 +65,10 @@ LIB_DEPENDS= c-client4.8:${PORTSDIR}/mail/cclient
.if defined(WITHOUT_TURBA)
.if !defined(WITHOUT_LDAP)
-.if defined(WITH_LDAP1)
-LIB_DEPENDS+= ldap.1:${PORTSDIR}/net/openldap12 \
- lber.1:${PORTSDIR}/net/openldap12
+.if exists(${LOCALBASE}/lib/libldap.so.1)
+LIB_DEPENDS+= ldap.1:${PORTSDIR}/net/openldap12
.else
-LIB_DEPENDS+= ldap.2:${PORTSDIR}/net/openldap20 \
- lber.2:${PORTSDIR}/net/openldap20
+LIB_DEPENDS+= ldap.2:${PORTSDIR}/net/openldap21
.endif
.endif
RUN_DEPENDS+= ${LOCALBASE}/www/horde/index.php:${PORTSDIR}/www/horde2
@@ -197,7 +194,7 @@ pre-install:
.endif
.endif
.if !defined(WITHOUT_LDAP)
-.if defined(WITH_LDAP1)
+.if exists(${LOCALBASE}/lib/libldap.so.1)
@if ! ${LDD} ${PHPSO} | ${GREP} -q -e "libldap.so.1"; then \
${ECHO_MSG} "" ; \
${ECHO_MSG} "Please configure PHP with OpenLDAP support." ; \
diff --git a/mail/turba/Makefile b/mail/turba/Makefile
index bd198fa9961f..81028a575cf1 100644
--- a/mail/turba/Makefile
+++ b/mail/turba/Makefile
@@ -7,6 +7,7 @@
PORTNAME= turba
PORTVERSION= 1.2
+PORTREVISION= 1
CATEGORIES= mail www
MASTER_SITES= ftp://ftp.horde.org/pub/turba/ \
ftp://ftp.au.horde.org/pub/horde/turba/ \
@@ -19,22 +20,17 @@ MAINTAINER= thierry@pompo.net
COMMENT= The Horde contact management application
#-----------------------------------------------------------------------
-# You may define these options:
+# You may define this option:
#
# - WITHOUT_LDAP : if you do not need OpenLDAP;
-# - WITH_LDAP1 : if you prefer OpenLDAP1.
-#
-# - WITHOUT_SUPPORTED_DB: if you run a database not in the ports tree;
#
#-----------------------------------------------------------------------
.if !defined(WITHOUT_LDAP)
-.if defined(WITH_LDAP1)
-LIB_DEPENDS+= ldap.1:${PORTSDIR}/net/openldap12 \
- lber.1:${PORTSDIR}/net/openldap12
+.if exists(${LOCALBASE}/lib/libldap.so.1)
+LIB_DEPENDS+= ldap.1:${PORTSDIR}/net/openldap12
.else
-LIB_DEPENDS+= ldap.2:${PORTSDIR}/net/openldap20 \
- lber.2:${PORTSDIR}/net/openldap20
+LIB_DEPENDS+= ldap.2:${PORTSDIR}/net/openldap21
.endif
.endif
@@ -70,7 +66,7 @@ PHPSO= ${LOCALBASE}/libexec/apache/libphp4.so
pre-install:
.if !defined(WITHOUT_LDAP)
-.if defined(WITH_LDAP1)
+.if exists(${LOCALBASE}/lib/libldap.so.1)
@if ! ${LDD} ${PHPSO} | ${GREP} -q -e "libldap.so.1"; then \
${ECHO_MSG} "" ; \
${ECHO_MSG} "Please configure PHP with OpenLDAP support." ; \