aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2001-03-20 17:40:16 +0800
committersobomax <sobomax@FreeBSD.org>2001-03-20 17:40:16 +0800
commit8ccd850bd0e11b962b51161f860a898cb1944cb7 (patch)
tree53ecf656ba78a3819a44c1d7b7a889485ba2da82 /mail
parent2168b0a2ae19ce82be10f6ce53864d7bbd6fffa6 (diff)
downloadfreebsd-ports-gnome-8ccd850bd0e11b962b51161f860a898cb1944cb7.tar.gz
freebsd-ports-gnome-8ccd850bd0e11b962b51161f860a898cb1944cb7.tar.zst
freebsd-ports-gnome-8ccd850bd0e11b962b51161f860a898cb1944cb7.zip
Fix two breakages:
- Prevent Makefile from trying to run 644 missing script when no autocrap is installed; - add missed by the configure -lintl into LDFLAGS. Replace perl with ${PERL} while I'm here. Submitted by: bento
Diffstat (limited to 'mail')
-rw-r--r--mail/fetchmail/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/mail/fetchmail/Makefile b/mail/fetchmail/Makefile
index d2d0b4f7eef7..65b80505e426 100644
--- a/mail/fetchmail/Makefile
+++ b/mail/fetchmail/Makefile
@@ -27,7 +27,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-opie --enable-RPA --enable-POP2 --enable-SDPS \
--enable-nls --with-hesiod=no
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib" \
+ LDFLAGS="-L${LOCALBASE}/lib -lintl" \
CFLAGS="-I${LOCALBASE}/include ${CFLAGS}"
MAKE_ENV+= ${CONFIGURE_ENV}
MAN1= fetchmail.1
@@ -60,8 +60,9 @@ FDOC= ${PREFIX}/share/doc/fetchmail
pre-patch:
@${CP} -f /usr/include/md5.h ${WRKSRC}
- @perl -pi.bak -e 's|^#!/.*/python|#!${PREFIX}/bin/python|;' ${WRKSRC}/fetchmailconf
+ @${PERL} -pi.bak -e 's|^#!/.*/python|#!${PREFIX}/bin/python|;' ${WRKSRC}/fetchmailconf
@${SED} -e "s|@PREFIX@|${PREFIX}|" ${FILESDIR}/fetchmailconf > ${WRKDIR}/fetchmailconf
+ @${PERL} -pi.bak -e 's|\$$missing_dir/missing|${TRUE}|g' ${WRKSRC}/configure
post-install:
.if !defined(NOPORTDOCS)