aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2019-05-23 15:35:12 +0800
committerbapt <bapt@FreeBSD.org>2019-05-23 15:35:12 +0800
commit90a0950ba07bffb7d198e126cb23c3b81bbd216d (patch)
tree163254fc5a70fd393a948ec94f65c80ea099956f /mail
parenta248f6e233cf34a328703bf598a5a460e8a9dfeb (diff)
downloadfreebsd-ports-gnome-90a0950ba07bffb7d198e126cb23c3b81bbd216d.tar.gz
freebsd-ports-gnome-90a0950ba07bffb7d198e126cb23c3b81bbd216d.tar.zst
freebsd-ports-gnome-90a0950ba07bffb7d198e126cb23c3b81bbd216d.zip
Fix a warning in perl 5.28 which would become fatal in 5.30:
Unescaped left brace in regex is deprecated here (and will be fatal in Perl 5.30), passed through in regex; marked by <-- HERE in m/^{ <-- HERE (\d+)\+?}\r?$/ at /usr/local/bin/sieve-connect line 930.
Diffstat (limited to 'mail')
-rw-r--r--mail/sieve-connect/Makefile1
-rw-r--r--mail/sieve-connect/files/patch-sieve-connect.pl29
2 files changed, 30 insertions, 0 deletions
diff --git a/mail/sieve-connect/Makefile b/mail/sieve-connect/Makefile
index 6b39d8000f8b..cf7474668d9c 100644
--- a/mail/sieve-connect/Makefile
+++ b/mail/sieve-connect/Makefile
@@ -3,6 +3,7 @@
PORTNAME= sieve-connect
DISTVERSION= 0.89
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= http://people.spodhuis.org/phil.pennock/software/
diff --git a/mail/sieve-connect/files/patch-sieve-connect.pl b/mail/sieve-connect/files/patch-sieve-connect.pl
new file mode 100644
index 000000000000..26c66da83ed9
--- /dev/null
+++ b/mail/sieve-connect/files/patch-sieve-connect.pl
@@ -0,0 +1,29 @@
+--- sieve-connect.pl.orig 2019-05-23 07:31:11 UTC
++++ sieve-connect.pl
+@@ -927,7 +927,7 @@ if (defined $realm) {
+ if (/^"(.*)"\r?\n?$/) {
+ $challenge = $1;
+ } else {
+- unless (/^{(\d+)\+?}\r?$/m) {
++ unless (/^\{(\d+)\+?}\r?$/m) {
+ sfinish $sock, "*";
+ closedie($sock, "Failure to parse server SASL response.\n");
+ }
+@@ -1510,7 +1510,7 @@ sub sieve_download
+ warn qq{Empty script "$remotefn"? Not saved.\n};
+ return;
+ }
+- unless (/^{(\d+)\+?}\r?$/m) {
++ unless (/^\{(\d+)\+?}\r?$/m) {
+ die "QUIT:Failed to parse server response to GETSCRIPT";
+ }
+ my $contentdata = $_;
+@@ -1526,7 +1526,7 @@ sub sieve_download
+ or die "write-open($localfn) failed: $!\n";
+ $oldouthandle = select $fh;
+ }
+- $contentdata =~ s/^{\d+\+?}\r?\n?//m;
++ $contentdata =~ s/^\{\d+\+?}\r?\n?//m;
+ print $contentdata;
+ select $oldouthandle if defined $oldouthandle;
+ if (defined $fh) {