aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2013-08-30 12:45:28 +0800
committerdanfe <danfe@FreeBSD.org>2013-08-30 12:45:28 +0800
commit90d65c435948ac524637b9d468c363a7d1694fe9 (patch)
tree0766924b62b07d6bc4e50d459df1d1172a6c6216 /mail
parent64fd3a5a58d5173a2fb6802172c9b91aaf5282cf (diff)
downloadfreebsd-ports-gnome-90d65c435948ac524637b9d468c363a7d1694fe9.tar.gz
freebsd-ports-gnome-90d65c435948ac524637b9d468c363a7d1694fe9.tar.zst
freebsd-ports-gnome-90d65c435948ac524637b9d468c363a7d1694fe9.zip
- Try to fix parallel builds (-jX): daemon also depends on their library;
drop MAKE_JOBS_UNSAFE and fix extra whitespace at CONFIGURE_ARGS/MANx - Convert NOPORTDOCS, get rid of .for loop when installing documentation - Properly terminate WWW: line in port description with a slash Reported by: marino Approved by: miwi, bapt (portmgr, implicit)
Diffstat (limited to 'mail')
-rw-r--r--mail/whoson/Makefile22
-rw-r--r--mail/whoson/files/patch-Makefile.in11
-rw-r--r--mail/whoson/pkg-descr2
3 files changed, 22 insertions, 13 deletions
diff --git a/mail/whoson/Makefile b/mail/whoson/Makefile
index a76b2e51ef64..1993073b1622 100644
--- a/mail/whoson/Makefile
+++ b/mail/whoson/Makefile
@@ -11,25 +11,25 @@ COMMENT= Implementation of `WHO iS ONline' protocol
USE_AUTOTOOLS= libtool
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-config=${PREFIX}/etc/whoson.conf
+CONFIGURE_ARGS= --with-config=${PREFIX}/etc/whoson.conf
USE_LDCONFIG= yes
-MAKE_JOBS_UNSAFE=yes
-
USE_RC_SUBR= whoson
-MAN3= whoson.3 wso_login.3 wso_logout.3 wso_query.3 wso_version.3
-MAN5= whoson.conf.5
-MAN8= whoson.8 whosond.8
+MAN3= whoson.3 wso_login.3 wso_logout.3 wso_query.3 wso_version.3
+MAN5= whoson.conf.5
+MAN8= whoson.8 whosond.8
PORTDOCS= README ChangeLog
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.options.mk>
+
post-install:
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
-.for f in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
-.endfor
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}
.endif
.include <bsd.port.mk>
diff --git a/mail/whoson/files/patch-Makefile.in b/mail/whoson/files/patch-Makefile.in
index ddacced05f5b..b163ee19c3e4 100644
--- a/mail/whoson/files/patch-Makefile.in
+++ b/mail/whoson/files/patch-Makefile.in
@@ -1,6 +1,15 @@
--- Makefile.in.orig 2008-01-17 15:59:21.000000000 +0300
+++ Makefile.in 2008-07-02 19:37:47.000000000 +0400
-@@ -961,12 +961,7 @@
+@@ -336,7 +336,7 @@ whosond_SOURCES = whosond.c mainloop.c l
+ nodist_whosond_SOURCES = servlist.c
+ EXTRA_whosond_SOURCES = serv_tcp.c serv_unix.c serv_unixd.c serv_udp.c
+ whosond_LDADD = $(lib_LTLIBRARIES) @LIBOBJS@ @SERV_CONN_OBJ@
+-whosond_DEPENDENCIES = @SERV_CONN_OBJ@
++whosond_DEPENDENCIES = @SERV_CONN_OBJ@ $(lib_LTLIBRARIES)
+ libwhoson_la_SOURCES = clnt_common.c rtconfig.c checkperm.c
+ nodist_libwhoson_la_SOURCES = clntlist.c
+ EXTRA_libwhoson_la_SOURCES = clnt_tcp.c clnt_unix.c clnt_unixd.c clnt_udp.c
+@@ -982,12 +982,7 @@ uninstall-man: uninstall-man3 uninstall-
install-data-hook:
diff --git a/mail/whoson/pkg-descr b/mail/whoson/pkg-descr
index 94845425a118..8d2800e257b4 100644
--- a/mail/whoson/pkg-descr
+++ b/mail/whoson/pkg-descr
@@ -10,4 +10,4 @@ clients, and SMTP server using it to put the user identity into the
"Received" header along with the source IP address. The protocol itself
is defined in a separate document "whoson.txt".
-WWW: http://whoson.sourceforge.net
+WWW: http://whoson.sourceforge.net/