aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorosa <osa@FreeBSD.org>2003-07-20 20:09:18 +0800
committerosa <osa@FreeBSD.org>2003-07-20 20:09:18 +0800
commit9105b796754bb4f986dbe2192e0101481a9fa218 (patch)
tree5fd9f3c97e27bd29403ded06e52435dce65654d1 /mail
parent0485f2f133db330fa647e873e5471ba58c39bfdd (diff)
downloadfreebsd-ports-gnome-9105b796754bb4f986dbe2192e0101481a9fa218.tar.gz
freebsd-ports-gnome-9105b796754bb4f986dbe2192e0101481a9fa218.tar.zst
freebsd-ports-gnome-9105b796754bb4f986dbe2192e0101481a9fa218.zip
Fix APOP, mark SASL as broken
Submitted by: Bruce M Simpson <bms@spc.org> Approved by: Udo Schweigert <udo.schweigert@siemens.com> (maintainer) PR: 54592
Diffstat (limited to 'mail')
-rw-r--r--mail/mutt-devel/Makefile3
-rw-r--r--mail/mutt-devel/files/patch-pop_auth.c19
2 files changed, 21 insertions, 1 deletions
diff --git a/mail/mutt-devel/Makefile b/mail/mutt-devel/Makefile
index 1e9f979669e4..0de801b509bc 100644
--- a/mail/mutt-devel/Makefile
+++ b/mail/mutt-devel/Makefile
@@ -75,7 +75,7 @@
PORTNAME= mutt-devel
PORTVERSION= 1.5.4
-PORTREVISION?= 4
+PORTREVISION?= 5
CATEGORIES+= mail ipv6
.if defined(WITH_MUTT_NNTP)
CATEGORIES+= news
@@ -177,6 +177,7 @@ LIB_DEPENDS+= slang.1:${PORTSDIR}/devel/libslang
USE_OPENSSL= yes
.endif
.if defined(WITH_MUTT_CYRUS_SASL)
+BROKEN= "mutt-devel's SASL code appears to be broken"
LIB_DEPENDS+= sasl.8:${PORTSDIR}/security/cyrus-sasl
.endif
.if ! defined(WITHOUT_MUTT_SMIME_OUTLOOK_COMPAT)
diff --git a/mail/mutt-devel/files/patch-pop_auth.c b/mail/mutt-devel/files/patch-pop_auth.c
new file mode 100644
index 000000000000..1f7a37f269be
--- /dev/null
+++ b/mail/mutt-devel/files/patch-pop_auth.c
@@ -0,0 +1,19 @@
+--- pop_auth.c.orig Thu Jul 17 19:42:53 2003
++++ pop_auth.c Thu Jul 17 19:46:01 2003
+@@ -206,12 +206,12 @@
+ mutt_message _("Authenticating (APOP)...");
+
+ /* Compute the authentication hash to send to the server */
+- MD5Init (&mdContext);
+- MD5Update (&mdContext, (unsigned char *)pop_data->timestamp,
++ MD5_Init (&mdContext);
++ MD5_Update (&mdContext, (unsigned char *)pop_data->timestamp,
+ strlen (pop_data->timestamp));
+- MD5Update (&mdContext, (unsigned char *)pop_data->conn->account.pass,
++ MD5_Update (&mdContext, (unsigned char *)pop_data->conn->account.pass,
+ strlen (pop_data->conn->account.pass));
+- MD5Final (digest, &mdContext);
++ MD5_Final (digest, &mdContext);
+
+ for (i = 0; i < sizeof (digest); i++)
+ sprintf (hash + 2 * i, "%02x", digest[i]);