aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorvsevolod <vsevolod@FreeBSD.org>2017-03-09 00:46:06 +0800
committerKoop Mast <kwm@rainbow-runner.nl>2017-04-09 19:58:59 +0800
commit98535722bc0dee496184da1cf239e0e208c1a75d (patch)
treeff81498a3b032fb069f82d4baf1faf4f26f7e7a7 /mail
parentc7f23214440169bb881fb92d77878dc29aa4a83c (diff)
downloadfreebsd-ports-gnome-98535722bc0dee496184da1cf239e0e208c1a75d.tar.gz
freebsd-ports-gnome-98535722bc0dee496184da1cf239e0e208c1a75d.tar.zst
freebsd-ports-gnome-98535722bc0dee496184da1cf239e0e208c1a75d.zip
- Update to 4.89
Diffstat (limited to 'mail')
-rw-r--r--mail/exim/Makefile3
-rw-r--r--mail/exim/distinfo6
-rw-r--r--mail/exim/files/patch-pass-fd-to-tcpwrappers33
3 files changed, 18 insertions, 24 deletions
diff --git a/mail/exim/Makefile b/mail/exim/Makefile
index ffcf2db4f354..42ab08e61947 100644
--- a/mail/exim/Makefile
+++ b/mail/exim/Makefile
@@ -3,7 +3,6 @@
PORTNAME= exim
PORTVERSION?= ${EXIM_VERSION}
-PORTREVISION= 2
CATEGORIES= mail ipv6
MASTER_SITES= EXIM:exim
MASTER_SITE_SUBDIR= /exim4/:exim \
@@ -92,7 +91,7 @@ MASTER_SITES+= http://marc.merlins.org/linux/exim/files/:sa_exim \
DISTFILES+= sa-exim-${SA_EXIM_VERSION}.tar.gz:sa_exim
.endif
-EXIM_VERSION= 4.88
+EXIM_VERSION= 4.89
SA_EXIM_VERSION=4.2
EXIM_INSTALL_ARG+= "-no_chown" "-no_symlink"
diff --git a/mail/exim/distinfo b/mail/exim/distinfo
index 3c83a0d88194..3798e374b96f 100644
--- a/mail/exim/distinfo
+++ b/mail/exim/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1483356878
-SHA256 (exim/exim-4.88.tar.bz2) = 119d5fd7e31fc224e84dfa458fe182f200856bae7adf852a8287c242161f8a2d
-SIZE (exim/exim-4.88.tar.bz2) = 1824610
+TIMESTAMP = 1488990705
+SHA256 (exim/exim-4.89.tar.bz2) = 912f2ee03c8dba06a3a4c0ee40522d367e1b65dc59e38dfcc1f5d9eecff51ab0
+SIZE (exim/exim-4.89.tar.bz2) = 1844430
SHA256 (exim/sa-exim-4.2.tar.gz) = 72e0a735547f18b05785e6c58a71d24623858f0f5234a5dc0e24cb453999e99a
SIZE (exim/sa-exim-4.2.tar.gz) = 66575
diff --git a/mail/exim/files/patch-pass-fd-to-tcpwrappers b/mail/exim/files/patch-pass-fd-to-tcpwrappers
index 46156f260c98..91911dd12569 100644
--- a/mail/exim/files/patch-pass-fd-to-tcpwrappers
+++ b/mail/exim/files/patch-pass-fd-to-tcpwrappers
@@ -1,37 +1,32 @@
-This patch passes output filedescriptor argument (stdout in the
-case of SMTP sessions) to the tcp_wrappers code in order to allow
-statements like 'twist' (that output anything instead of the daemon)
-to work. Bare hosts_ctl() is too dumb to handle such usage of tcp
-wrappers.
-
---- src/smtp_in.c.orig 2012-06-28 19:52:46.000000000 +0400
-+++ src/smtp_in.c 2012-06-28 20:08:00.000000000 +0400
-@@ -1357,6 +1357,9 @@
- uschar *user_msg, *log_msg;
- uschar *code, *esc;
- uschar *p, *s, *ss;
+--- src/smtp_in.c.orig 2017-03-08 16:31:57.587957000 +0000
++++ src/smtp_in.c 2017-03-08 16:43:44.934346000 +0000
+@@ -2246,6 +2246,9 @@
+ #ifdef USE_TCP_WRAPPERS
+ struct request_info tcpwrap_ri;
+ #endif
+#ifdef USE_TCP_WRAPPERS
+struct request_info tcpwrap_ri;
+#endif
smtp_connection_start = time(NULL);
for (smtp_ch_index = 0; smtp_ch_index < SMTP_HBUFF_SIZE; smtp_ch_index++)
-@@ -1706,10 +1709,14 @@
+@@ -2602,11 +2605,14 @@
+ log_write(0, LOG_MAIN|LOG_PANIC_DIE, "Expansion of \"%s\" "
"(tcp_wrappers_name) failed: %s", string_printing(tcp_wrappers_name),
expand_string_message);
- }
+-
- if (!hosts_ctl(tcp_wrappers_name,
-- (sender_host_name == NULL)? STRING_UNKNOWN : CS sender_host_name,
-- (sender_host_address == NULL)? STRING_UNKNOWN : CS sender_host_address,
-- (sender_ident == NULL)? STRING_UNKNOWN : CS sender_ident))
-+ request_init(&tcpwrap_ri,
+- sender_host_name ? CS sender_host_name : STRING_UNKNOWN,
+- sender_host_address ? CS sender_host_address : STRING_UNKNOWN,
+- sender_ident ? CS sender_ident : STRING_UNKNOWN))
++ request_init(&tcpwrap_ri,
+ RQ_DAEMON, tcp_wrappers_name,
+ RQ_FILE, fileno(smtp_out),
+ RQ_CLIENT_NAME, (sender_host_name == NULL)? STRING_UNKNOWN : CS sender_host_name,
+ RQ_CLIENT_ADDR, (sender_host_address == NULL)? STRING_UNKNOWN : CS sender_host_address,
+ RQ_USER, (sender_ident == NULL)? STRING_UNKNOWN : CS sender_ident,
+ 0);
-+ if (!hosts_access(&tcpwrap_ri))
++ if (!hosts_access(&tcpwrap_ri))
{
if (errno == 0 || errno == ENOENT)
{