aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorultima <ultima@FreeBSD.org>2017-08-21 01:35:18 +0800
committerultima <ultima@FreeBSD.org>2017-08-21 01:35:18 +0800
commit9ace9b4bae9f3a22e9b400caa5e51f8e9f540c8e (patch)
tree9be35f20ad51b1c075b1df8ffc1841c99597c005 /mail
parent8600dc95dfd7bdeff4ac503c3471ec7b4b26d150 (diff)
downloadfreebsd-ports-gnome-9ace9b4bae9f3a22e9b400caa5e51f8e9f540c8e.tar.gz
freebsd-ports-gnome-9ace9b4bae9f3a22e9b400caa5e51f8e9f540c8e.tar.zst
freebsd-ports-gnome-9ace9b4bae9f3a22e9b400caa5e51f8e9f540c8e.zip
MailHog is an email testing tool for developers:
Configure your application to use MailHog for SMTP delivery View messages in the web UI, or retrieve them with the JSON API Optionally release messages to real SMTP servers for delivery WWW: https://github.com/mailhog/MailHog PR: 221015 Submitted by: punkt.de Hosting Team (maintainer) Reviewed by: matthew (mentor) Approved by: matthew (mentor) Differential Revision: https://reviews.freebsd.org/D12069
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/mailhog/Makefile50
-rw-r--r--mail/mailhog/distinfo43
-rw-r--r--mail/mailhog/files/mailhog.in43
-rw-r--r--mail/mailhog/files/pkg-message.in10
-rw-r--r--mail/mailhog/pkg-descr7
-rw-r--r--mail/mailhog/tags18
7 files changed, 172 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index 6e5ca1f59f13..0be59ddbd81f 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -213,6 +213,7 @@
SUBDIR += mailfromd
SUBDIR += mailfront
SUBDIR += mailgraph
+ SUBDIR += mailhog
SUBDIR += mailman
SUBDIR += mailmgr
SUBDIR += mailpile
diff --git a/mail/mailhog/Makefile b/mail/mailhog/Makefile
new file mode 100644
index 000000000000..c8c8d2f6ee70
--- /dev/null
+++ b/mail/mailhog/Makefile
@@ -0,0 +1,50 @@
+# Created by: punkt.de Hosting Team <mops@punkt.de>
+# $FreeBSD$
+
+PORTNAME= mailhog
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.0.0
+CATEGORIES= mail devel
+
+MAINTAINER= mops@punkt.de
+COMMENT= MailHog development mail server
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.md
+
+USES= go
+USE_RC_SUBR= mailhog
+USE_GITHUB= yes
+GH_ACCOUNT= mailhog
+GH_SUBDIR= src/github.com/mailhog/MailHog
+GH_TUPLE= gorilla:pat:cf955c3:pat/src/github.com/gorilla/pat \
+ gorilla:context:08b5f42:context/src/github.com/gorilla/context \
+ gorilla:mux:ac112f7:mux/src/github.com/gorilla/mux \
+ gorilla:websocket:a69d9f6:websocket/src/github.com/gorilla/websocket \
+ ian-kent:go-log:5731446:go_log/src/github.com/ian-kent/go-log \
+ ian-kent:goose:c3541ea:goose/src/github.com/ian-kent/goose \
+ ian-kent:envconf:c198099:envconf/src/github.com/ian-kent/envconf \
+ ian-kent:linkio:97566b8:linkio/src/github.com/ian-kent/linkio \
+ mailhog:data:v${DISTVERSION}:data/src/github.com/mailhog/data \
+ mailhog:http:v${DISTVERSION}:http/src/github.com/mailhog/http \
+ mailhog:mhsendmail:9e70164:mhsendmail/src/github.com/mailhog/mhsendmail \
+ mailhog:smtp:v${DISTVERSION}:smtp/src/github.com/mailhog/smtp \
+ mailhog:storage:v${DISTVERSION}:storage/src/github.com/mailhog/storage \
+ mailhog:MailHog-Server:v${DISTVERSION}:mailhog_server/src/github.com/mailhog/MailHog-Server \
+ mailhog:MailHog-UI:v${DISTVERSION}:mailhog_ui/src/github.com/mailhog/MailHog-UI \
+ t-k:fluent-logger-golang:0f8ec08:fluent_logger_golang/src/github.com/t-k/fluent-logger-golang \
+ tinylib:msgp:701aacd:msgp/src/github.com/tinylib/msgp \
+ philhofer:fwd:1612a29:fwd/src/github.com/philhofer/fwd \
+ golang:crypto:eb71ad9:crypto/src/golang.org/x/crypto \
+ go-mgo:mgo:3f83fa5:mgo/src/gopkg.in/mgo.v2
+
+WRKSRC= ${WRKDIR}/MailHog-${DISTVERSION}
+
+PLIST_FILES= bin/${PORTNAME}
+SUB_FILES= pkg-message
+
+post-extract:
+ @${LN} -sf ${WRKSRC}/src ${WRKDIR}
+ @${LN} -sf ${WRKSRC} ${GO_WRKSRC}
+
+.include <bsd.port.mk>
diff --git a/mail/mailhog/distinfo b/mail/mailhog/distinfo
new file mode 100644
index 000000000000..19e686b658cc
--- /dev/null
+++ b/mail/mailhog/distinfo
@@ -0,0 +1,43 @@
+TIMESTAMP = 1503216575
+SHA256 (mailhog-mailhog-v1.0.0_GH0.tar.gz) = 472bf0895f33d49ec8f9bf665fdbda317e57855e846e38e6a6b8dcecdacd7bc5
+SIZE (mailhog-mailhog-v1.0.0_GH0.tar.gz) = 140803
+SHA256 (gorilla-pat-cf955c3_GH0.tar.gz) = 7c6dacd45161d6446496c94459398e991f3e717a479bff87c88520c4b0920840
+SIZE (gorilla-pat-cf955c3_GH0.tar.gz) = 4499
+SHA256 (gorilla-context-08b5f42_GH0.tar.gz) = 27045aa6da0128aded8e81242630f59a90e0b1840000d31a3b7c5c4e57559df6
+SIZE (gorilla-context-08b5f42_GH0.tar.gz) = 4575
+SHA256 (gorilla-mux-ac112f7_GH0.tar.gz) = 263631f7ced2ea91b0c45062b03966b23b568926eebdbde4a929a30229e96867
+SIZE (gorilla-mux-ac112f7_GH0.tar.gz) = 29556
+SHA256 (gorilla-websocket-a69d9f6_GH0.tar.gz) = 4178ed0e39c9045486712d9b31ea9b74674c36984f3ecbf8dafa4b41c3af39dc
+SIZE (gorilla-websocket-a69d9f6_GH0.tar.gz) = 42999
+SHA256 (ian-kent-go-log-5731446_GH0.tar.gz) = 8b29bc4c714484ed62ad80a79f985ddf1b7dcc781390be7c710047d33e02ad7c
+SIZE (ian-kent-go-log-5731446_GH0.tar.gz) = 9564
+SHA256 (ian-kent-goose-c3541ea_GH0.tar.gz) = 75e1c19ef42bddf9439918ae410a8288e33feffe18329dd973db34ec776b4311
+SIZE (ian-kent-goose-c3541ea_GH0.tar.gz) = 2413
+SHA256 (ian-kent-envconf-c198099_GH0.tar.gz) = fae9cd5e0ba5df438a028d9acfbd71d300bcb6773b33dc8277cd06eed428daa2
+SIZE (ian-kent-envconf-c198099_GH0.tar.gz) = 2848
+SHA256 (ian-kent-linkio-97566b8_GH0.tar.gz) = c76c3dd380e53d902ab450455b244867a1b4843b0b8abbacb438518c74c2f033
+SIZE (ian-kent-linkio-97566b8_GH0.tar.gz) = 3149
+SHA256 (mailhog-data-v1.0.0_GH0.tar.gz) = e01e0ad224bdd58a39efa5295cebe82075d0e9db59ee2cda7aee15d0c54152aa
+SIZE (mailhog-data-v1.0.0_GH0.tar.gz) = 4024
+SHA256 (mailhog-http-v1.0.0_GH0.tar.gz) = 06a289553063462f31210087a7d139f4cbfa7843b4b753c68110ccda010caf06
+SIZE (mailhog-http-v1.0.0_GH0.tar.gz) = 2255
+SHA256 (mailhog-mhsendmail-9e70164_GH0.tar.gz) = d39e1a3926493d4459d63ef5523fd10f92e9723f96b8e1b324ead9c7ef80034c
+SIZE (mailhog-mhsendmail-9e70164_GH0.tar.gz) = 21341
+SHA256 (mailhog-smtp-v1.0.0_GH0.tar.gz) = 1ca3b61004fcff797c21bd49997f9b3612cc9734b0a92582a02f30f6d12843f8
+SIZE (mailhog-smtp-v1.0.0_GH0.tar.gz) = 10842
+SHA256 (mailhog-storage-v1.0.0_GH0.tar.gz) = 2fb5ac3c468748e7aadcae8e7384b5c0c030d36163605cdfa0bf7838d1a64a60
+SIZE (mailhog-storage-v1.0.0_GH0.tar.gz) = 4503
+SHA256 (mailhog-MailHog-Server-v1.0.0_GH0.tar.gz) = 1e036c2947715cea990c78735aa10bfd6d8777d85d6bb72d1c51e0368f178a41
+SIZE (mailhog-MailHog-Server-v1.0.0_GH0.tar.gz) = 11447
+SHA256 (mailhog-MailHog-UI-v1.0.0_GH0.tar.gz) = d9175b0876c4e2bc4920784d23dc7c995b876a563618ddd5a28f50a4a7dfcdd9
+SIZE (mailhog-MailHog-UI-v1.0.0_GH0.tar.gz) = 1392309
+SHA256 (t-k-fluent-logger-golang-0f8ec08_GH0.tar.gz) = f2b7083fc7b890428144184c6c1d617bbed7b09f356bb009beb520525dc138cb
+SIZE (t-k-fluent-logger-golang-0f8ec08_GH0.tar.gz) = 6227
+SHA256 (tinylib-msgp-701aacd_GH0.tar.gz) = 4b95dcd7dd0830053b6ff291e47256c978624ea6d956b0df34dca255bdef124e
+SIZE (tinylib-msgp-701aacd_GH0.tar.gz) = 69271
+SHA256 (philhofer-fwd-1612a29_GH0.tar.gz) = 0432a75da81b1635ace9afe2c58cce24b09fbe861688654700ab4681d009c0b2
+SIZE (philhofer-fwd-1612a29_GH0.tar.gz) = 9224
+SHA256 (golang-crypto-eb71ad9_GH0.tar.gz) = 989a8515e3a88f22887e77d7ff4c16fad76f802002903476f38f1ec857cc1490
+SIZE (golang-crypto-eb71ad9_GH0.tar.gz) = 1430965
+SHA256 (go-mgo-mgo-3f83fa5_GH0.tar.gz) = cae8560c00d9840fa78a24db6995e192cd66858f7912e42a559a56e3c44b0825
+SIZE (go-mgo-mgo-3f83fa5_GH0.tar.gz) = 376731
diff --git a/mail/mailhog/files/mailhog.in b/mail/mailhog/files/mailhog.in
new file mode 100644
index 000000000000..1187e79eb67a
--- /dev/null
+++ b/mail/mailhog/files/mailhog.in
@@ -0,0 +1,43 @@
+#!/bin/sh
+
+# PROVIDE: mailhog
+# REQUIRE: DAEMON
+# KEYWORD: shutdown
+#
+# Add these lines to /etc/rc.conf.local or /etc/rc.conf
+# to enable this service:
+#
+# mailhog_enable (bool): Set to NO by default.
+# Set it to YES to enable mailhog.
+# mailhog_bind_addr (ipaddr): Set to the address mailhog should listen on
+# for incoming connections. 127.0.0.1 by default.
+# mailhog_smtp_port (int): Port to listen on for SMTP. 1025 by default.
+# mailhog_api_port (int): Port to listen on for API. 8025 by default.
+# mailhog_ui_port (int): Port to listen on for UI. 8025 (same as API)
+# by default.
+# mailhog_runtimeuser (string): User mailhog should run as. 'nobody' by default.
+#
+# Please think twice before exposing this server to the Internet. This is an
+# insecure tool without any authentication specifically to aid development
+# and debugging. Use in controlled environments only is highly recommended.
+#
+
+. /etc/rc.subr
+
+name="mailhog"
+rcvar="mailhog_enable"
+pidfile="/var/run/${name}.pid"
+
+: ${mailhog_enable:="NO"}
+: ${mailhog_bind_addr:="127.0.0.1"}
+: ${mailhog_smtp_port:="1025"}
+: ${mailhog_api_port:="8025"}
+: ${mailhog_ui_port:="8025"}
+: ${mailhog_runtimeuser:="nobody"}
+
+load_rc_config "${name}"
+
+command="/usr/sbin/daemon"
+command_args="-c -r -f -P ${pidfile} -u ${mailhog_runtimeuser} %%PREFIX%%/bin/${name} -api-bind-addr ${mailhog_bind_addr}:${mailhog_api_port} -ui-bind-addr ${mailhog_bind_addr}:${mailhog_ui_port} -smtp-bind-addr ${mailhog_bind_addr}:${mailhog_smtp_port}"
+
+run_rc_command "$1"
diff --git a/mail/mailhog/files/pkg-message.in b/mail/mailhog/files/pkg-message.in
new file mode 100644
index 000000000000..474f608ff6af
--- /dev/null
+++ b/mail/mailhog/files/pkg-message.in
@@ -0,0 +1,10 @@
+
+----------------------------------------------------------------------------
+To run mailhog server on startup, add mailhog_enable="YES" to /etc/rc.conf.
+
+The SMTP server listens to 127.0.0.1:1025 by default while the web UI can
+be reached at http://127.0.0.1:8025/
+
+To change this look at the rc.conf variables in %%PREFIX%%/etc/rc.d/mailhog.
+----------------------------------------------------------------------------
+
diff --git a/mail/mailhog/pkg-descr b/mail/mailhog/pkg-descr
new file mode 100644
index 000000000000..b0775397b5b4
--- /dev/null
+++ b/mail/mailhog/pkg-descr
@@ -0,0 +1,7 @@
+MailHog is an email testing tool for developers:
+
+Configure your application to use MailHog for SMTP delivery
+View messages in the web UI, or retrieve them with the JSON API
+Optionally release messages to real SMTP servers for delivery
+
+WWW: https://github.com/mailhog/MailHog
diff --git a/mail/mailhog/tags b/mail/mailhog/tags
new file mode 100644
index 000000000000..6f46994fa5c2
--- /dev/null
+++ b/mail/mailhog/tags
@@ -0,0 +1,18 @@
+!_TAG_FILE_SORTED 2 /0=unsorted, 1=sorted, 2=foldcase/
+CATEGORIES /usr/home/ricky/FreeBSD/ports/mail/mailhog/Makefile /^CATEGORIES= mail devel$/;" m language:Make
+COMMENT /usr/home/ricky/FreeBSD/ports/mail/mailhog/Makefile /^COMMENT= MailHog development mail server$/;" m language:Make
+DISTVERSION /usr/home/ricky/FreeBSD/ports/mail/mailhog/Makefile /^DISTVERSION= 1.0.0$/;" m language:Make
+DISTVERSIONPREFIX /usr/home/ricky/FreeBSD/ports/mail/mailhog/Makefile /^DISTVERSIONPREFIX= v$/;" m language:Make
+GH_ACCOUNT /usr/home/ricky/FreeBSD/ports/mail/mailhog/Makefile /^GH_ACCOUNT= mailhog$/;" m language:Make
+GH_SUBDIR /usr/home/ricky/FreeBSD/ports/mail/mailhog/Makefile /^GH_SUBDIR= src\/github.com\/mailhog\/MailHog$/;" m language:Make
+GH_TUPLE /usr/home/ricky/FreeBSD/ports/mail/mailhog/Makefile /^GH_TUPLE= gorilla:pat:cf955c3:pat\/src\/github.com\/gorilla\/pat \\$/;" m language:Make
+LICENSE /usr/home/ricky/FreeBSD/ports/mail/mailhog/Makefile /^LICENSE= MIT$/;" m language:Make
+LICENSE_FILE /usr/home/ricky/FreeBSD/ports/mail/mailhog/Makefile /^LICENSE_FILE= ${WRKSRC}\/LICENSE.md$/;" m language:Make
+MAINTAINER /usr/home/ricky/FreeBSD/ports/mail/mailhog/Makefile /^MAINTAINER= mops@punkt.de$/;" m language:Make
+PLIST_FILES /usr/home/ricky/FreeBSD/ports/mail/mailhog/Makefile /^PLIST_FILES= bin\/${PORTNAME}$/;" m language:Make
+PORTNAME /usr/home/ricky/FreeBSD/ports/mail/mailhog/Makefile /^PORTNAME= mailhog$/;" m language:Make
+SUB_FILES /usr/home/ricky/FreeBSD/ports/mail/mailhog/Makefile /^SUB_FILES= pkg-message$/;" m language:Make
+USES /usr/home/ricky/FreeBSD/ports/mail/mailhog/Makefile /^USES= go$/;" m language:Make
+USE_GITHUB /usr/home/ricky/FreeBSD/ports/mail/mailhog/Makefile /^USE_GITHUB= yes$/;" m language:Make
+USE_RC_SUBR /usr/home/ricky/FreeBSD/ports/mail/mailhog/Makefile /^USE_RC_SUBR= mailhog$/;" m language:Make
+WRKSRC /usr/home/ricky/FreeBSD/ports/mail/mailhog/Makefile /^WRKSRC= ${WRKDIR}\/MailHog-${DISTVERSION}$/;" m language:Make