aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorsat <sat@FreeBSD.org>2007-02-22 20:41:44 +0800
committersat <sat@FreeBSD.org>2007-02-22 20:41:44 +0800
commit9c1f42b3421dafc0916a2e5538f1440a7d41bc30 (patch)
tree6a368a3bc7da4126649773aa60a0c9ef05d849ac /mail
parent8e0f1532f61f2b4ff1c576eab58326011940c5db (diff)
downloadfreebsd-ports-gnome-9c1f42b3421dafc0916a2e5538f1440a7d41bc30.tar.gz
freebsd-ports-gnome-9c1f42b3421dafc0916a2e5538f1440a7d41bc30.tar.zst
freebsd-ports-gnome-9c1f42b3421dafc0916a2e5538f1440a7d41bc30.zip
- Minor tweaks
Approved by: Beech Rintoul <beech@alaskaparadise.com> (maintainer)
Diffstat (limited to 'mail')
-rw-r--r--mail/horde-mimp/Makefile16
-rw-r--r--mail/horde-mimp/pkg-plist7
-rw-r--r--mail/mimp/Makefile16
-rw-r--r--mail/mimp/pkg-plist7
4 files changed, 16 insertions, 30 deletions
diff --git a/mail/horde-mimp/Makefile b/mail/horde-mimp/Makefile
index 66cdbdf612c7..944ee754eb55 100644
--- a/mail/horde-mimp/Makefile
+++ b/mail/horde-mimp/Makefile
@@ -1,6 +1,6 @@
# Ports collection makefile for: mimp3
# Date created: Mon Feb 05, 2007
-# Whom: Beech Rintoul (<beech@alaskaparadise.com>)
+# Whom: Beech Rintoul <beech@alaskaparadise.com>
#
# $FreeBSD$
#
@@ -67,8 +67,7 @@ USE_APACHE= 1.3+ # needed to test APACHE_VERSION
USE_GETTEXT= yes
REINPLACE_ARGS= -i.beforeMIMP
-DOCS= COPYING README docs/CHANGES docs/CREDITS docs/INSTALL \
- docs/RELEASE_NOTES
+PORTDOCS= README CHANGES CREDITS INSTALL RELEASE_NOTES
CONFFILE= filter.txt header.php menu.php mime_drivers.php motd.php \
prefs.php servers.php trailer.txt conf.xml .htaccess
SUB_DIRS= config lib locale po templates themes
@@ -115,6 +114,9 @@ HORDE_INC= ${LOCALBASE}/etc/apache${APACHE_VERSION:S/20/2/}/Includes/
HORDE_INC= ${LOCALBASE}/etc/horde/
.endif
+post-extract:
+ @${MV} ${WRKSRC}/README ${WRKSRC}/docs/
+
pre-configure:
@${REINPLACE_CMD} -e "s:/usr/local:${LOCALBASE}:" ${WRKSRC}/config/conf.xml
.if !defined(NOCRYPT)
@@ -157,7 +159,7 @@ pre-install:
.endfor
do-install:
- @${MKDIR} ${MIMPDIR}
+ @${INSTALL} -d ${MIMPDIR}/
.for REP in ${SUB_DIRS}
@${CP} -Rp ${WRKSRC}/${REP} ${MIMPDIR}/
.endfor
@@ -168,10 +170,8 @@ do-install:
@${CHMOD} -R o-rwx ${CONFDIR}/
.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
-.for FILE in ${DOCS}
- @${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}/
-.endfor
+ @${INSTALL} -d ${DOCSDIR}/
+ @${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/docs/|} ${DOCSDIR}/
@${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
.endif
diff --git a/mail/horde-mimp/pkg-plist b/mail/horde-mimp/pkg-plist
index cc4e1eb5114d..34a3e3fc320c 100644
--- a/mail/horde-mimp/pkg-plist
+++ b/mail/horde-mimp/pkg-plist
@@ -1,9 +1,3 @@
-%%PORTDOCS%%%%DOCSDIR%%/CHANGES
-%%PORTDOCS%%%%DOCSDIR%%/CREDITS
-%%PORTDOCS%%%%DOCSDIR%%/INSTALL
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%%%DOCSDIR%%/COPYING
-%%PORTDOCS%%%%DOCSDIR%%/RELEASE_NOTES
%%MIMPDIR%%/compose.php
%%MIMPDIR%%/config/.htaccess
%%MIMPDIR%%/config/conf.xml
@@ -77,7 +71,6 @@
%%MIMPDIR%%/themes/graphics/mimp.png
%%MIMPDIR%%/themes/graphics/horde-power2.png
%%MIMPDIR%%/themes/graphics/horde-power2.wbmp
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
%%HORDE_INC%%httpd-mimp.conf
@dirrm %%MIMPDIR%%/themes/graphics
@dirrm %%MIMPDIR%%/themes
diff --git a/mail/mimp/Makefile b/mail/mimp/Makefile
index 66cdbdf612c7..944ee754eb55 100644
--- a/mail/mimp/Makefile
+++ b/mail/mimp/Makefile
@@ -1,6 +1,6 @@
# Ports collection makefile for: mimp3
# Date created: Mon Feb 05, 2007
-# Whom: Beech Rintoul (<beech@alaskaparadise.com>)
+# Whom: Beech Rintoul <beech@alaskaparadise.com>
#
# $FreeBSD$
#
@@ -67,8 +67,7 @@ USE_APACHE= 1.3+ # needed to test APACHE_VERSION
USE_GETTEXT= yes
REINPLACE_ARGS= -i.beforeMIMP
-DOCS= COPYING README docs/CHANGES docs/CREDITS docs/INSTALL \
- docs/RELEASE_NOTES
+PORTDOCS= README CHANGES CREDITS INSTALL RELEASE_NOTES
CONFFILE= filter.txt header.php menu.php mime_drivers.php motd.php \
prefs.php servers.php trailer.txt conf.xml .htaccess
SUB_DIRS= config lib locale po templates themes
@@ -115,6 +114,9 @@ HORDE_INC= ${LOCALBASE}/etc/apache${APACHE_VERSION:S/20/2/}/Includes/
HORDE_INC= ${LOCALBASE}/etc/horde/
.endif
+post-extract:
+ @${MV} ${WRKSRC}/README ${WRKSRC}/docs/
+
pre-configure:
@${REINPLACE_CMD} -e "s:/usr/local:${LOCALBASE}:" ${WRKSRC}/config/conf.xml
.if !defined(NOCRYPT)
@@ -157,7 +159,7 @@ pre-install:
.endfor
do-install:
- @${MKDIR} ${MIMPDIR}
+ @${INSTALL} -d ${MIMPDIR}/
.for REP in ${SUB_DIRS}
@${CP} -Rp ${WRKSRC}/${REP} ${MIMPDIR}/
.endfor
@@ -168,10 +170,8 @@ do-install:
@${CHMOD} -R o-rwx ${CONFDIR}/
.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
-.for FILE in ${DOCS}
- @${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}/
-.endfor
+ @${INSTALL} -d ${DOCSDIR}/
+ @${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/docs/|} ${DOCSDIR}/
@${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
.endif
diff --git a/mail/mimp/pkg-plist b/mail/mimp/pkg-plist
index cc4e1eb5114d..34a3e3fc320c 100644
--- a/mail/mimp/pkg-plist
+++ b/mail/mimp/pkg-plist
@@ -1,9 +1,3 @@
-%%PORTDOCS%%%%DOCSDIR%%/CHANGES
-%%PORTDOCS%%%%DOCSDIR%%/CREDITS
-%%PORTDOCS%%%%DOCSDIR%%/INSTALL
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%%%DOCSDIR%%/COPYING
-%%PORTDOCS%%%%DOCSDIR%%/RELEASE_NOTES
%%MIMPDIR%%/compose.php
%%MIMPDIR%%/config/.htaccess
%%MIMPDIR%%/config/conf.xml
@@ -77,7 +71,6 @@
%%MIMPDIR%%/themes/graphics/mimp.png
%%MIMPDIR%%/themes/graphics/horde-power2.png
%%MIMPDIR%%/themes/graphics/horde-power2.wbmp
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
%%HORDE_INC%%httpd-mimp.conf
@dirrm %%MIMPDIR%%/themes/graphics
@dirrm %%MIMPDIR%%/themes