aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2016-12-14 23:39:16 +0800
committerjbeich <jbeich@FreeBSD.org>2016-12-14 23:39:16 +0800
commit9e9b69d16c7ce5731de32a95b9274408e2a75d86 (patch)
treee044d8874568429701a07d15cb3adb69c1d7e3ba /mail
parent03c917284f26a0ff45b40376d395e42c1127fbf3 (diff)
downloadfreebsd-ports-gnome-9e9b69d16c7ce5731de32a95b9274408e2a75d86.tar.gz
freebsd-ports-gnome-9e9b69d16c7ce5731de32a95b9274408e2a75d86.tar.zst
freebsd-ports-gnome-9e9b69d16c7ce5731de32a95b9274408e2a75d86.zip
gecko: improve NSS 3.28 compatibility
https://bugzilla.mozilla.org/show_bug.cgi?id=1323209 MFH: 2016Q4
Diffstat (limited to 'mail')
-rw-r--r--mail/thunderbird/Makefile2
-rw-r--r--mail/thunderbird/files/patch-bug129003729
2 files changed, 30 insertions, 1 deletions
diff --git a/mail/thunderbird/Makefile b/mail/thunderbird/Makefile
index 22d0e5682f41..176fccb66c3a 100644
--- a/mail/thunderbird/Makefile
+++ b/mail/thunderbird/Makefile
@@ -3,7 +3,7 @@
PORTNAME= thunderbird
DISTVERSION= 45.5.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= mail news net-im ipv6
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}/source \
MOZILLA/${PORTNAME}/candidates/${DISTVERSION}-candidates/build1/source
diff --git a/mail/thunderbird/files/patch-bug1290037 b/mail/thunderbird/files/patch-bug1290037
new file mode 100644
index 000000000000..94d9cd381bfb
--- /dev/null
+++ b/mail/thunderbird/files/patch-bug1290037
@@ -0,0 +1,29 @@
+commit 7943c27406fb
+Author: Franziskus Kiefer <franziskuskiefer@gmail.com>
+Date: Thu Jul 28 16:48:00 2016 +0200
+
+ Bug 1290037 - Update keybits in H2, r=mt
+
+ MozReview-Commit-ID: 35oWoDMqe1Y
+
+ --HG--
+ extra : rebase_source : 020fbd93c190131eb04eed2d583787d6e5954a5a
+---
+ netwerk/protocol/http/Http2Session.cpp | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git netwerk/protocol/http/Http2Session.cpp netwerk/protocol/http/Http2Session.cpp
+index dbcc1115cbd3..f3cd57304f73 100644
+--- mozilla/netwerk/protocol/http/Http2Session.cpp
++++ mozilla/netwerk/protocol/http/Http2Session.cpp
+@@ -3549,8 +3549,8 @@ Http2Session::ConfirmTLSProfile()
+ LOG3(("Http2Session::ConfirmTLSProfile %p FAILED due to DH %d < 2048\n",
+ this, keybits));
+ RETURN_SESSION_ERROR(this, INADEQUATE_SECURITY);
+- } else if (kea == ssl_kea_ecdh && keybits < 256) { // 256 bits is "security level" of 128
+- LOG3(("Http2Session::ConfirmTLSProfile %p FAILED due to ECDH %d < 256\n",
++ } else if (kea == ssl_kea_ecdh && keybits < 224) { // see rfc7540 9.2.1.
++ LOG3(("Http2Session::ConfirmTLSProfile %p FAILED due to ECDH %d < 224\n",
+ this, keybits));
+ RETURN_SESSION_ERROR(this, INADEQUATE_SECURITY);
+ }