aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2018-05-23 12:04:53 +0800
committerjbeich <jbeich@FreeBSD.org>2018-05-23 12:04:53 +0800
commita14fdbb1d47d837ca32a317339186bf6431ac764 (patch)
tree572a7cb00f34e1c0b690c1c2c98c5679ce2606a8 /mail
parent89ad1bb6e53926f5cab26b7975f6f1abf2a4857b (diff)
downloadfreebsd-ports-gnome-a14fdbb1d47d837ca32a317339186bf6431ac764.tar.gz
freebsd-ports-gnome-a14fdbb1d47d837ca32a317339186bf6431ac764.tar.zst
freebsd-ports-gnome-a14fdbb1d47d837ca32a317339186bf6431ac764.zip
gecko: adjust targetPlatform after r470668
PR: 226919 Reported by: Corpo (for Lightning)
Diffstat (limited to 'mail')
-rw-r--r--mail/thunderbird/Makefile2
-rw-r--r--mail/thunderbird/files/patch-addon-search13
2 files changed, 14 insertions, 1 deletions
diff --git a/mail/thunderbird/Makefile b/mail/thunderbird/Makefile
index 54dc2d11cd3d..5e1114ebc45c 100644
--- a/mail/thunderbird/Makefile
+++ b/mail/thunderbird/Makefile
@@ -3,7 +3,7 @@
PORTNAME= thunderbird
DISTVERSION= 52.8.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= mail news net-im ipv6
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}/source \
MOZILLA/${PORTNAME}/candidates/${DISTVERSION}-candidates/build1/source
diff --git a/mail/thunderbird/files/patch-addon-search b/mail/thunderbird/files/patch-addon-search
index c9d0e0aa109e..e92bf3c15652 100644
--- a/mail/thunderbird/files/patch-addon-search
+++ b/mail/thunderbird/files/patch-addon-search
@@ -58,3 +58,16 @@ index f70fd8d7e3bd8..81e8cd7764fdf 100644
break;
}
+diff --git toolkit/mozapps/extensions/internal/XPIProvider.jsm toolkit/mozapps/extensions/internal/XPIProvider.jsm
+index f70fd8d7e3bd8..81e8cd7764fdf 100644
+--- mozilla/toolkit/mozapps/extensions/internal/XPIProvider.jsm
++++ mozilla/toolkit/mozapps/extensions/internal/XPIProvider.jsm
+@@ -7186,7 +7186,7 @@ AddonInternal.prototype = {
+ // Something is causing errors in here
+ try {
+ for (let platform of this.targetPlatforms) {
+- if (platform.os == Services.appinfo.OS) {
++ if (platform.os == "Linux") {
+ if (platform.abi) {
+ needsABI = true;
+ if (platform.abi === abi)