aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-05-05 02:43:30 +0800
committerpav <pav@FreeBSD.org>2004-05-05 02:43:30 +0800
commita4cdc24a8c3487dad783f4fe4f15196e34ac56fb (patch)
treea0e159af3831acf8be082903695e44c1dbea8c70 /mail
parent6a2055a8237f4c3c37c262592fb576a2bcf7452a (diff)
downloadfreebsd-ports-gnome-a4cdc24a8c3487dad783f4fe4f15196e34ac56fb.tar.gz
freebsd-ports-gnome-a4cdc24a8c3487dad783f4fe4f15196e34ac56fb.tar.zst
freebsd-ports-gnome-a4cdc24a8c3487dad783f4fe4f15196e34ac56fb.zip
- Update to 2.10.6
- Add a lot of new OPTIONS - Fix plist for MySQL option - Make userdir configurable - Make signature life configurable - Add patch to fix delivering to LDA PR: ports/65384, ports/66199 Submitted by: Rob Evers <rob@debank.tv> (maintainer) Ion-Mihai Tetcu, Andreas Klemm
Diffstat (limited to 'mail')
-rw-r--r--mail/dspam-devel/Makefile81
-rw-r--r--mail/dspam-devel/distinfo4
-rw-r--r--mail/dspam-devel/files/patch-dspam.c17
-rw-r--r--mail/dspam-devel/pkg-plist3
-rw-r--r--mail/dspam/Makefile81
-rw-r--r--mail/dspam/distinfo4
-rw-r--r--mail/dspam/files/patch-dspam.c17
-rw-r--r--mail/dspam/pkg-plist3
8 files changed, 190 insertions, 20 deletions
diff --git a/mail/dspam-devel/Makefile b/mail/dspam-devel/Makefile
index 353130eff7bf..d3ca7a884136 100644
--- a/mail/dspam-devel/Makefile
+++ b/mail/dspam-devel/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= dspam
-PORTVERSION= 2.10.3
+PORTVERSION= 2.10.6
CATEGORIES= mail
MASTER_SITES= http://www.nuclearelephant.com/projects/dspam/sources/
@@ -14,25 +14,36 @@ MAINTAINER= rob@debank.tv
COMMENT= A server-side bayesian spam filter
OPTIONS= MYSQL "Use MySQL and not db4 as database" off \
+ MYSQL_COMPRESS "Compress dspam <--> MySQL" off \
MAILDROP "Use Maildrop as local delivery agent" off \
PROCMAIL "Use Procmail as local delivery agent" off \
+ SENDMAIL "Play nice with sendmail server" off \
QMAIL "Play nice with Qmail mail server" off \
ENABLE_SPAM_DELIVERY "Deliver messages marked as spam" off \
SIGNATURE_HEADERS "Put signatures in the header" off \
- WHITELIST "Automatic whitelisting of ham" off
+ WHITELIST "Automatic whitelisting of ham" off \
+ OPT_IN "Enable opt in" off \
+ TRUSTED_USERS "Disable trusted user security" off \
+ TUM "Enables TuM (Train until Mature)" off \
+ ALT_BAYESIAN "Enable alternative-bayesian" on \
+ NO_BIAS "Disable bias" off \
+ VIRT_USERS "Enable virtual users (needs MYSQL)" off \
+ SAT "Enable spam source address logging" off \
+ VERBOSE_DEBUG "Enable verbose debug" off
USE_LIBTOOL_VER=13
USE_REINPLACE= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib"
-CONFIGURE_ARGS= --with-userdir=${PREFIX}/etc/dspam
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
SED_SCRIPT= -e 's,%%DOCSDIR%%,${DOCSDIR},g' \
-e 's,%%EXAMPLESDIR%%,${EXAMPLESDIR},g' \
-e 's,%%LOCALBASE%%,${LOCALBASE},g'
+WITH_SIGNATURE_LIFE?= 28
+
.include <bsd.port.pre.mk>
.if defined(WITH_MYSQL)
@@ -44,23 +55,37 @@ PLIST_SUB+= DB4="@comment "
PLIST_SUB+= MYSQL=""
SED_SCRIPT+= -e 's,%%MYSQL%%,,g'
.else
-LIB_DEPENDS= db41.1:${PORTSDIR}/databases/db41
+LIB_DEPENDS+= db41.1:${PORTSDIR}/databases/db41
CONFIGURE_ARGS+= --with-db4-includes=${LOCALBASE}/include/db41
PLIST_SUB+= DB4=""
PLIST_SUB+= MYSQL="@comment "
SED_SCRIPT+= -e '/%%MYSQL%%/D'
.endif
+.if defined(WITH_MYSQL_COMPRESS)
+CONFIGURE_ARGS+= --enable-client-compression
+.endif
+
+.if defined(DSPAM_USERDIR)
+CONFIGURE_ARGS+=--with-userdir=${DSPAM_USERDIR}
+.else
+CONFIGURE_ARGS+=--with-userdir=${PREFIX}/etc/dspam
+.endif
+
.if defined(WITH_MAILDROP)
-RUN_DEPENDS= maildrop:${PORTSDIR}/mail/maildrop
+RUN_DEPENDS+= maildrop:${PORTSDIR}/mail/maildrop
CONFIGURE_ARGS+= --with-local-delivery-agent='${LOCALBASE}/bin/maildrop $u'
.endif
.if defined(WITH_PROCMAIL)
-RUN_DEPENDS= procmail:${PORTSDIR}/mail/procmail
+RUN_DEPENDS+= procmail:${PORTSDIR}/mail/procmail
CONFIGURE_ARGS+= --with-local-delivery-agent='${LOCALBASE}/bin/procmail $u'
.endif
+.if defined(WITH_SENDMAIL)
+CONFIGURE_ARGS+= --with-dspam-mode=4511
+.endif
+
.if defined(WITH_QMAIL)
CONFIGURE_ARGS+= --with-dspam-mode=4511
.endif
@@ -81,17 +106,59 @@ CONFIGURE_ARGS+= --enable-signature-headers
CONFIGURE_ARGS+= --enable-whitelist
.endif
+.if defined(WITH_OPT_IN)
+CONFIGURE_ARGS+= --enable-opt-in
+.endif
+
+.if defined(WITH_TRUSTED_USERS)
+CONFIGURE_ARGS+= --disable-trusted-user-security
+.endif
+
+.if defined(WITH_TUM)
+CONFIGURE_ARGS+= --enable-tum
+.endif
+
+.if defined(WITH_ALT_BAYESIAN)
+CONFIGURE_ARGS+= --enable-alternative-bayesian
+.endif
+
+.if defined(WITH_NO_BIAS)
+CONFIGURE_ARGS+= --disable-bias
+.endif
+
+.if defined(WITH_VIRT_USERS)
+CONFIGURE_ARGS+= --enable-virtual-users
+.endif
+
+.if defined(WITH_SAT)
+CONFIGURE_ARGS+= --enable-source-address-tracking
+.endif
+
+.if defined(WITH_VERBOSE_DEBUG)
+CONFIGURE_ARGS+= --enable-verbose-debug
+.endif
+
DOCS= CHANGE README
post-patch:
@${REINPLACE_CMD} -e 's|%%LIBTOOLFLAGS%%|${LIBTOOLFLAGS}|g ; \
s|-ldb-4.1|-ldb41|g' ${WRKSRC}/configure
+pre-configure:
+.if defined(WITH_MAILDROP) && defined(WITH_PROCMAIL)
+ @${ECHO_CMD} "You can only use one local delivery agent at once."
+ @${FALSE}
+.endif
+.if defined(WITH_VIRT_USERS) && !defined(WITH_MYSQL)
+ @${ECHO_CMD} "You need MySQL support to use this feature."
+ @${FALSE}
+.endif
+
post-install:
.if defined(WITH_MYSQL)
@${MKDIR} ${EXAMPLESDIR}
cd ${WRKSRC}/tools.mysql_drv && \
- ${INSTALL_DATA} README *.sql ${EXAMPLESDIR}
+ ${INSTALL_DATA} README *.sql.* ${EXAMPLESDIR}
${INSTALL_DATA} ${FILESDIR}/mysql.data ${EXAMPLESDIR}
.endif
.if !defined(NOPORTDOCS)
diff --git a/mail/dspam-devel/distinfo b/mail/dspam-devel/distinfo
index 0dd5c9f0ebf6..ebe59a898f95 100644
--- a/mail/dspam-devel/distinfo
+++ b/mail/dspam-devel/distinfo
@@ -1,2 +1,2 @@
-MD5 (dspam-2.10.3.tar.gz) = 9ae2d1b21bc54807454c76f0e444717d
-SIZE (dspam-2.10.3.tar.gz) = 485053
+MD5 (dspam-2.10.6.tar.gz) = ddb40d26cc923d7569d48b3072e61715
+SIZE (dspam-2.10.6.tar.gz) = 485466
diff --git a/mail/dspam-devel/files/patch-dspam.c b/mail/dspam-devel/files/patch-dspam.c
new file mode 100644
index 000000000000..8bfb29d8adc2
--- /dev/null
+++ b/mail/dspam-devel/files/patch-dspam.c
@@ -0,0 +1,17 @@
+--- dspam.c.orig Fri Apr 2 18:34:35 2004
++++ dspam.c Mon Apr 26 23:59:03 2004
+@@ -2422,12 +2422,12 @@
+ i++;
+ }
+ }
+- arg = strsep (&margs, " ");
+-
++
+ if (arg != NULL) {
+ strlcat (args, a, sizeof(args));
+ strlcat (args, " ", sizeof (args));
+ }
++ arg = strsep (&margs, " ");
+ }
+ free (mmargs);
+
diff --git a/mail/dspam-devel/pkg-plist b/mail/dspam-devel/pkg-plist
index 282309417cb7..aa3ae292a98f 100644
--- a/mail/dspam-devel/pkg-plist
+++ b/mail/dspam-devel/pkg-plist
@@ -20,7 +20,8 @@ lib/libdspam.a
%%PORTDOCS%%@dirrm %%DOCSDIR%%
%%MYSQL%%%%EXAMPLESDIR%%/README
%%MYSQL%%%%EXAMPLESDIR%%/mysql.data
-%%MYSQL%%%%EXAMPLESDIR%%/mysql_objects.sql
+%%MYSQL%%%%EXAMPLESDIR%%/mysql_objects.sql.space.optimized
+%%MYSQL%%%%EXAMPLESDIR%%/mysql_objects.sql.speed.optimized
%%MYSQL%%%%EXAMPLESDIR%%/purge.sql
%%MYSQL%%%%EXAMPLESDIR%%/virtual_users.sql
%%MYSQL%%@dirrm %%EXAMPLESDIR%%
diff --git a/mail/dspam/Makefile b/mail/dspam/Makefile
index 353130eff7bf..d3ca7a884136 100644
--- a/mail/dspam/Makefile
+++ b/mail/dspam/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= dspam
-PORTVERSION= 2.10.3
+PORTVERSION= 2.10.6
CATEGORIES= mail
MASTER_SITES= http://www.nuclearelephant.com/projects/dspam/sources/
@@ -14,25 +14,36 @@ MAINTAINER= rob@debank.tv
COMMENT= A server-side bayesian spam filter
OPTIONS= MYSQL "Use MySQL and not db4 as database" off \
+ MYSQL_COMPRESS "Compress dspam <--> MySQL" off \
MAILDROP "Use Maildrop as local delivery agent" off \
PROCMAIL "Use Procmail as local delivery agent" off \
+ SENDMAIL "Play nice with sendmail server" off \
QMAIL "Play nice with Qmail mail server" off \
ENABLE_SPAM_DELIVERY "Deliver messages marked as spam" off \
SIGNATURE_HEADERS "Put signatures in the header" off \
- WHITELIST "Automatic whitelisting of ham" off
+ WHITELIST "Automatic whitelisting of ham" off \
+ OPT_IN "Enable opt in" off \
+ TRUSTED_USERS "Disable trusted user security" off \
+ TUM "Enables TuM (Train until Mature)" off \
+ ALT_BAYESIAN "Enable alternative-bayesian" on \
+ NO_BIAS "Disable bias" off \
+ VIRT_USERS "Enable virtual users (needs MYSQL)" off \
+ SAT "Enable spam source address logging" off \
+ VERBOSE_DEBUG "Enable verbose debug" off
USE_LIBTOOL_VER=13
USE_REINPLACE= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib"
-CONFIGURE_ARGS= --with-userdir=${PREFIX}/etc/dspam
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
SED_SCRIPT= -e 's,%%DOCSDIR%%,${DOCSDIR},g' \
-e 's,%%EXAMPLESDIR%%,${EXAMPLESDIR},g' \
-e 's,%%LOCALBASE%%,${LOCALBASE},g'
+WITH_SIGNATURE_LIFE?= 28
+
.include <bsd.port.pre.mk>
.if defined(WITH_MYSQL)
@@ -44,23 +55,37 @@ PLIST_SUB+= DB4="@comment "
PLIST_SUB+= MYSQL=""
SED_SCRIPT+= -e 's,%%MYSQL%%,,g'
.else
-LIB_DEPENDS= db41.1:${PORTSDIR}/databases/db41
+LIB_DEPENDS+= db41.1:${PORTSDIR}/databases/db41
CONFIGURE_ARGS+= --with-db4-includes=${LOCALBASE}/include/db41
PLIST_SUB+= DB4=""
PLIST_SUB+= MYSQL="@comment "
SED_SCRIPT+= -e '/%%MYSQL%%/D'
.endif
+.if defined(WITH_MYSQL_COMPRESS)
+CONFIGURE_ARGS+= --enable-client-compression
+.endif
+
+.if defined(DSPAM_USERDIR)
+CONFIGURE_ARGS+=--with-userdir=${DSPAM_USERDIR}
+.else
+CONFIGURE_ARGS+=--with-userdir=${PREFIX}/etc/dspam
+.endif
+
.if defined(WITH_MAILDROP)
-RUN_DEPENDS= maildrop:${PORTSDIR}/mail/maildrop
+RUN_DEPENDS+= maildrop:${PORTSDIR}/mail/maildrop
CONFIGURE_ARGS+= --with-local-delivery-agent='${LOCALBASE}/bin/maildrop $u'
.endif
.if defined(WITH_PROCMAIL)
-RUN_DEPENDS= procmail:${PORTSDIR}/mail/procmail
+RUN_DEPENDS+= procmail:${PORTSDIR}/mail/procmail
CONFIGURE_ARGS+= --with-local-delivery-agent='${LOCALBASE}/bin/procmail $u'
.endif
+.if defined(WITH_SENDMAIL)
+CONFIGURE_ARGS+= --with-dspam-mode=4511
+.endif
+
.if defined(WITH_QMAIL)
CONFIGURE_ARGS+= --with-dspam-mode=4511
.endif
@@ -81,17 +106,59 @@ CONFIGURE_ARGS+= --enable-signature-headers
CONFIGURE_ARGS+= --enable-whitelist
.endif
+.if defined(WITH_OPT_IN)
+CONFIGURE_ARGS+= --enable-opt-in
+.endif
+
+.if defined(WITH_TRUSTED_USERS)
+CONFIGURE_ARGS+= --disable-trusted-user-security
+.endif
+
+.if defined(WITH_TUM)
+CONFIGURE_ARGS+= --enable-tum
+.endif
+
+.if defined(WITH_ALT_BAYESIAN)
+CONFIGURE_ARGS+= --enable-alternative-bayesian
+.endif
+
+.if defined(WITH_NO_BIAS)
+CONFIGURE_ARGS+= --disable-bias
+.endif
+
+.if defined(WITH_VIRT_USERS)
+CONFIGURE_ARGS+= --enable-virtual-users
+.endif
+
+.if defined(WITH_SAT)
+CONFIGURE_ARGS+= --enable-source-address-tracking
+.endif
+
+.if defined(WITH_VERBOSE_DEBUG)
+CONFIGURE_ARGS+= --enable-verbose-debug
+.endif
+
DOCS= CHANGE README
post-patch:
@${REINPLACE_CMD} -e 's|%%LIBTOOLFLAGS%%|${LIBTOOLFLAGS}|g ; \
s|-ldb-4.1|-ldb41|g' ${WRKSRC}/configure
+pre-configure:
+.if defined(WITH_MAILDROP) && defined(WITH_PROCMAIL)
+ @${ECHO_CMD} "You can only use one local delivery agent at once."
+ @${FALSE}
+.endif
+.if defined(WITH_VIRT_USERS) && !defined(WITH_MYSQL)
+ @${ECHO_CMD} "You need MySQL support to use this feature."
+ @${FALSE}
+.endif
+
post-install:
.if defined(WITH_MYSQL)
@${MKDIR} ${EXAMPLESDIR}
cd ${WRKSRC}/tools.mysql_drv && \
- ${INSTALL_DATA} README *.sql ${EXAMPLESDIR}
+ ${INSTALL_DATA} README *.sql.* ${EXAMPLESDIR}
${INSTALL_DATA} ${FILESDIR}/mysql.data ${EXAMPLESDIR}
.endif
.if !defined(NOPORTDOCS)
diff --git a/mail/dspam/distinfo b/mail/dspam/distinfo
index 0dd5c9f0ebf6..ebe59a898f95 100644
--- a/mail/dspam/distinfo
+++ b/mail/dspam/distinfo
@@ -1,2 +1,2 @@
-MD5 (dspam-2.10.3.tar.gz) = 9ae2d1b21bc54807454c76f0e444717d
-SIZE (dspam-2.10.3.tar.gz) = 485053
+MD5 (dspam-2.10.6.tar.gz) = ddb40d26cc923d7569d48b3072e61715
+SIZE (dspam-2.10.6.tar.gz) = 485466
diff --git a/mail/dspam/files/patch-dspam.c b/mail/dspam/files/patch-dspam.c
new file mode 100644
index 000000000000..8bfb29d8adc2
--- /dev/null
+++ b/mail/dspam/files/patch-dspam.c
@@ -0,0 +1,17 @@
+--- dspam.c.orig Fri Apr 2 18:34:35 2004
++++ dspam.c Mon Apr 26 23:59:03 2004
+@@ -2422,12 +2422,12 @@
+ i++;
+ }
+ }
+- arg = strsep (&margs, " ");
+-
++
+ if (arg != NULL) {
+ strlcat (args, a, sizeof(args));
+ strlcat (args, " ", sizeof (args));
+ }
++ arg = strsep (&margs, " ");
+ }
+ free (mmargs);
+
diff --git a/mail/dspam/pkg-plist b/mail/dspam/pkg-plist
index 282309417cb7..aa3ae292a98f 100644
--- a/mail/dspam/pkg-plist
+++ b/mail/dspam/pkg-plist
@@ -20,7 +20,8 @@ lib/libdspam.a
%%PORTDOCS%%@dirrm %%DOCSDIR%%
%%MYSQL%%%%EXAMPLESDIR%%/README
%%MYSQL%%%%EXAMPLESDIR%%/mysql.data
-%%MYSQL%%%%EXAMPLESDIR%%/mysql_objects.sql
+%%MYSQL%%%%EXAMPLESDIR%%/mysql_objects.sql.space.optimized
+%%MYSQL%%%%EXAMPLESDIR%%/mysql_objects.sql.speed.optimized
%%MYSQL%%%%EXAMPLESDIR%%/purge.sql
%%MYSQL%%%%EXAMPLESDIR%%/virtual_users.sql
%%MYSQL%%@dirrm %%EXAMPLESDIR%%