aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorbillf <billf@FreeBSD.org>1998-12-02 06:25:41 +0800
committerbillf <billf@FreeBSD.org>1998-12-02 06:25:41 +0800
commita7b965368ff68199ce9db0fcb6977f4d55fec7cd (patch)
treea5f98c7815311bae1f2d3c5452a47b5235087d83 /mail
parenta6de34fb07fceaf342d3f1434ab5e2dccfe1b486 (diff)
downloadfreebsd-ports-gnome-a7b965368ff68199ce9db0fcb6977f4d55fec7cd.tar.gz
freebsd-ports-gnome-a7b965368ff68199ce9db0fcb6977f4d55fec7cd.tar.zst
freebsd-ports-gnome-a7b965368ff68199ce9db0fcb6977f4d55fec7cd.zip
Initial Import of mbx2mbox, an excellent migration tool.
mbx2mbox converts Microsoft Outlook Express .mbx files into standard mail files (mbox) that programs like Pine, Mutt, and Netscape can parse. Usage: mbx2mbox file1.mbx file2.mbx ... http://www.cs.virginia.edu/~dwc3q/code/ PR: ports/8830 Submitted By: Josh Gilliam <josh@quick.net>
Diffstat (limited to 'mail')
-rw-r--r--mail/mbx2mbox/Makefile33
-rw-r--r--mail/mbx2mbox/distinfo1
-rw-r--r--mail/mbx2mbox/pkg-comment1
-rw-r--r--mail/mbx2mbox/pkg-descr10
-rw-r--r--mail/mbx2mbox/pkg-plist1
5 files changed, 46 insertions, 0 deletions
diff --git a/mail/mbx2mbox/Makefile b/mail/mbx2mbox/Makefile
new file mode 100644
index 000000000000..f6427cf1f888
--- /dev/null
+++ b/mail/mbx2mbox/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: mbx2mbox
+# Version required: 0.1
+# Date created: 23 November 1998
+# Whom: Josh Gilliam <josh@quick.net>
+#
+# $Id$
+#
+
+DISTNAME= mbx2mbox-0.1
+CATEGORIES= mail
+MASTER_SITES= http://www.cs.virginia.edu/~dwc3q/code/ \
+ ftp://maroon.webmaster.com/pub/mbx2mbox/
+EXTRACT_SUFX=
+
+MAINTAINER= josh@quick.net
+
+EXTRACT_CMD= ${CP}
+EXTRACT_BEFORE_ARGS=
+EXTRACT_AFTER_ARGS= .
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+USE_PERL5= yes
+
+post-patch:
+
+ @${MV} ${WRKSRC}/${DISTNAME} ${WRKSRC}/${DISTNAME}.pre_sed
+ @${SED} -e 's%/usr/bin/perl%${PERL}%' \
+ ${WRKSRC}/${DISTNAME}.pre_sed > ${WRKSRC}/${DISTNAME}
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKDIR}/mbx2mbox-0.1 ${PREFIX}/bin/mbx2mbox
+
+.include <bsd.port.mk>
diff --git a/mail/mbx2mbox/distinfo b/mail/mbx2mbox/distinfo
new file mode 100644
index 000000000000..b74d1a0b90ab
--- /dev/null
+++ b/mail/mbx2mbox/distinfo
@@ -0,0 +1 @@
+MD5 (mbx2mbox-0.1) = 33347825943db32a7aa9c1f1de425861
diff --git a/mail/mbx2mbox/pkg-comment b/mail/mbx2mbox/pkg-comment
new file mode 100644
index 000000000000..f3a22ca4d62c
--- /dev/null
+++ b/mail/mbx2mbox/pkg-comment
@@ -0,0 +1 @@
+MS Outlook Express .mbx to mbox file converter
diff --git a/mail/mbx2mbox/pkg-descr b/mail/mbx2mbox/pkg-descr
new file mode 100644
index 000000000000..37c2f0def491
--- /dev/null
+++ b/mail/mbx2mbox/pkg-descr
@@ -0,0 +1,10 @@
+mbx2mbox converts Microsoft Outlook Express .mbx files into
+standard mail files (mbox) that programs like Pine, Mutt, and
+Netscape can parse.
+
+Usage: mbx2mbox file1.mbx file2.mbx ...
+
+http://www.cs.virginia.edu/~dwc3q/code/
+
+--
+Josh Gilliam <josh@quick.net>
diff --git a/mail/mbx2mbox/pkg-plist b/mail/mbx2mbox/pkg-plist
new file mode 100644
index 000000000000..5c9da32c8f88
--- /dev/null
+++ b/mail/mbx2mbox/pkg-plist
@@ -0,0 +1 @@
+bin/mbx2mbox