aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2012-10-10 06:12:13 +0800
committerMark Linimon <linimon@FreeBSD.org>2012-10-10 06:12:13 +0800
commita8693b8dee82d3226a0bc0b337d3eb2085add552 (patch)
tree7d9d8595a250c7e5a9a646200945ef2094927620 /mail
parent39890db4500948ba8648094ec8b290262a74d880 (diff)
downloadfreebsd-ports-gnome-a8693b8dee82d3226a0bc0b337d3eb2085add552.tar.gz
freebsd-ports-gnome-a8693b8dee82d3226a0bc0b337d3eb2085add552.tar.zst
freebsd-ports-gnome-a8693b8dee82d3226a0bc0b337d3eb2085add552.zip
Force numerous ports that fail to build with clang over to instead always
rely on gcc. The patch uses the new USE_GCC=any code in Mk/bsd.gcc.mk to accomplish this. The ports chosen were ports that blocked 2 or more ports from building with clang. (There are several hundred other ports that still fail to build with clang, even with this patch. This is merely one step along the way.) Those interested in fixing these ports with clang, and have clang as their default compiler, can simply set FORCE_BASE_CC_FOR_TESTING=yes. For those who have gcc as their default compiler, this change is believed to cause no change. Hat: portmgr Tested with: multiple runs on amd64-8-exp-bcm and 9-exp-clang, with various combinations of patch/no-patch and flag settings.
Diffstat (limited to 'mail')
-rw-r--r--mail/courier/Makefile1
-rw-r--r--mail/ezmlm/Makefile1
-rw-r--r--mail/metamail/Makefile2
3 files changed, 4 insertions, 0 deletions
diff --git a/mail/courier/Makefile b/mail/courier/Makefile
index cc364da8e74e..509126ce05ea 100644
--- a/mail/courier/Makefile
+++ b/mail/courier/Makefile
@@ -62,6 +62,7 @@ WITH_TRANSPORT= local esmtp dsn
USE_AUTOTOOLS= libtool aclocal
USE_BZIP2= yes
+USE_GCC= any
USE_FAM= yes
USE_GETTEXT= yes
USE_GMAKE= yes
diff --git a/mail/ezmlm/Makefile b/mail/ezmlm/Makefile
index eb0965258029..48b634886c3d 100644
--- a/mail/ezmlm/Makefile
+++ b/mail/ezmlm/Makefile
@@ -20,6 +20,7 @@ MASTER_SITES= http://cr.yp.to/software/ \
MAINTAINER= ports@FreeBSD.org
COMMENT= An easy-to-use, high-speed mailing list manager for qmail
+USE_GCC= any
USE_QMAIL_RUN= yes
CONFLICTS= ezmlm-idx-*
diff --git a/mail/metamail/Makefile b/mail/metamail/Makefile
index 44e46b4bdc59..fe309c7ad53d 100644
--- a/mail/metamail/Makefile
+++ b/mail/metamail/Makefile
@@ -21,6 +21,8 @@ OPTIONS_DEFINE= X11
OPTIONS_DEFAULT= X11
X11_DESC= X11 hebrew font support
+USE_GCC= any
+
WRKSRC= ${WRKDIR}/${DISTNAME}/src
MAN1= audiocompose.1 audiosend.1 extcompose.1 \
getfilename.1 mailto-hebrew.1 mailto.1 metamail.1 \