aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2004-10-12 18:49:26 +0800
committermat <mat@FreeBSD.org>2004-10-12 18:49:26 +0800
commitb2eca98295e752060cb9c8878e80c7c3cb9d8ebd (patch)
tree7ca845c08502a1ebf469e68ec7d3997857c1b3c6 /mail
parentb255a19405792ec855fc562a4b7ccf88bfc0bca6 (diff)
downloadfreebsd-ports-gnome-b2eca98295e752060cb9c8878e80c7c3cb9d8ebd.tar.gz
freebsd-ports-gnome-b2eca98295e752060cb9c8878e80c7c3cb9d8ebd.tar.zst
freebsd-ports-gnome-b2eca98295e752060cb9c8878e80c7c3cb9d8ebd.zip
Add p5-MIME-Lite-HTML 1.21, provide routine to transform a HTML page
into a MIME mail. PR: ports/68249 Submitted by: Jean-Baptiste Quenot <jb.quenot@caraldi.com>
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/p5-MIME-Lite-HTML/Makefile26
-rw-r--r--mail/p5-MIME-Lite-HTML/distinfo2
-rw-r--r--mail/p5-MIME-Lite-HTML/pkg-descr19
-rw-r--r--mail/p5-MIME-Lite-HTML/pkg-plist7
5 files changed, 55 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index cbab02049ea7..6c3b736b85ce 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -244,6 +244,7 @@
SUBDIR += p5-IMAP-Sieve
SUBDIR += p5-Log-Procmail
SUBDIR += p5-MIME-Lite
+ SUBDIR += p5-MIME-Lite-HTML
SUBDIR += p5-MIME-Tools
SUBDIR += p5-MIME-Types
SUBDIR += p5-Mail-Address-MobileJp
diff --git a/mail/p5-MIME-Lite-HTML/Makefile b/mail/p5-MIME-Lite-HTML/Makefile
new file mode 100644
index 000000000000..c4b8029a0101
--- /dev/null
+++ b/mail/p5-MIME-Lite-HTML/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-MIME-Lite-HTML
+# Date created: 2004-06-23 18:16:13
+# Whom: Jean-Baptiste Quenot <jb.quenot@caraldi.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= MIME-Lite-HTML
+PORTVERSION= 1.21
+CATEGORIES= mail perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= MIME
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= jb.quenot@caraldi.com
+COMMENT= Provide routine to transform a HTML page into a MIME mail
+
+BUILD_DEPENDS= ${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/MIME/Lite.pm:${PORTSDIR}/mail/p5-MIME-Lite
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= YES
+
+MAN3= MIME::Lite::HTML.3
+
+.include <bsd.port.mk>
diff --git a/mail/p5-MIME-Lite-HTML/distinfo b/mail/p5-MIME-Lite-HTML/distinfo
new file mode 100644
index 000000000000..29c3a5516b30
--- /dev/null
+++ b/mail/p5-MIME-Lite-HTML/distinfo
@@ -0,0 +1,2 @@
+MD5 (MIME-Lite-HTML-1.21.tar.gz) = 3c0a7045ce8e1fffff24e301c4fc2321
+SIZE (MIME-Lite-HTML-1.21.tar.gz) = 63121
diff --git a/mail/p5-MIME-Lite-HTML/pkg-descr b/mail/p5-MIME-Lite-HTML/pkg-descr
new file mode 100644
index 000000000000..2f2f6b570bed
--- /dev/null
+++ b/mail/p5-MIME-Lite-HTML/pkg-descr
@@ -0,0 +1,19 @@
+This module is a Perl mail client interface for sending message that support
+HTML format and build them for you.. This module provide routine to transform a
+HTML page in MIME::Lite mail.
+
+The job done is:
+
+ * Get the file (LWP) if needed
+ * Parse page to find include images (gif, jpg, flash)
+ * Attach them to mail with adequat header if asked (default)
+ * Include external CSS,Javascript file
+ * Replace relative url with absolute one
+ * Build the final MIME-Lite object with each part found
+
+Did you already see link like "Send this page to a friend" ?. With this module,
+you can do script that to this in 3 lines. It can be used too in a HTML
+newsletter. You make a classic HTML page, and give just url to
+MIME::Lite::HTML.
+
+WWW: http://search.cpan.org/dist/MIME-Lite-HTML/
diff --git a/mail/p5-MIME-Lite-HTML/pkg-plist b/mail/p5-MIME-Lite-HTML/pkg-plist
new file mode 100644
index 000000000000..2a8a8d356a70
--- /dev/null
+++ b/mail/p5-MIME-Lite-HTML/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/MIME/Lite/HTML.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/MIME/Lite/HTML/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/MIME/Lite/HTML
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/MIME/Lite 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/MIME 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/MIME/Lite 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/MIME 2>/dev/null || true