aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-11-30 02:22:32 +0800
committertijl <tijl@FreeBSD.org>2014-11-30 02:22:32 +0800
commitb3a361d8eb7b71f0b468fd98e66a366d09af5fcf (patch)
treedd9cb6760a88c6c8e370786a93ecef5ba96f616c /mail
parent237bc033e6203c347316781328565cb5a7f8b2cf (diff)
downloadfreebsd-ports-gnome-b3a361d8eb7b71f0b468fd98e66a366d09af5fcf.tar.gz
freebsd-ports-gnome-b3a361d8eb7b71f0b468fd98e66a366d09af5fcf.tar.zst
freebsd-ports-gnome-b3a361d8eb7b71f0b468fd98e66a366d09af5fcf.zip
Split devel/gettext in devel/gettext-runtime and devel/gettext-tools. The
first contains runtime libraries such as libintl and the latter contains developer tools such as msgfmt. Ports that use gettext will usually need a LIB_DEPENDS on gettext-runtime and a BUILD_DEPENDS on gettext-tools. USES=gettext-runtime can be used to set a LIB/BUILD/RUN_DEPENDS on devel/gettext-runtime and USES=gettext-tools can be used to set a BUILD/RUN_DEPENDS on devel/gettext-tools. USES=gettext is now the same as "USES=gettext-runtime gettext-tools" meaning a LIB_DEPENDS on devel/gettext-runtime and a BUILD_DEPENDS on devel/gettext-tools. Update gettext to 0.19.3. Remove :oldver from converters/libiconv and devel/gettext-runtime. Leave symlinks with the old library versions to avoid the need to bump PORTREVISION on a large number of dependent ports. When most of the dependent ports have had normal version updates, PORTREVISION can be bumped on the remaining ones (low number) and the links can be removed. Fix some ports that installed files in lib/locale instead of share/locale. PR: 194038 Reviewed by: bapt Exp-run: antoine Approved by: portmgr (antoine)
Diffstat (limited to 'mail')
-rw-r--r--mail/faces/Makefile12
-rw-r--r--mail/milter-manager/Makefile16
2 files changed, 12 insertions, 16 deletions
diff --git a/mail/faces/Makefile b/mail/faces/Makefile
index f282aee4c374..068e6a524f81 100644
--- a/mail/faces/Makefile
+++ b/mail/faces/Makefile
@@ -16,12 +16,14 @@ X11_DESC= X11/GTK support
RPLAY_DESC= rplay audio support
SOX_DESC= Sox audio support
-WANT_GNOME= yes
+NLS_USES= gettext
+NLS_CONFIGURE_ENABLE= nls
+
USE_LDCONFIG= yes
PORTDOCS= README
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if ! ${PORT_OPTIONS:MX11}
PLIST_SUB+= X11="@comment "
@@ -37,10 +39,6 @@ CONFIGURE_ARGS= --enable-imap --enable-pop \
--with-facedir=${DATADIR}
.endif
-.if ! ${PORT_OPTIONS:MNLS}
-CONFIGURE_ARGS+=--disable-nls
-.endif
-
.ifdef WITH_NAS
CONFIGURE_ARGS+= --enable-audio --with-audio-cmd=${LOCALBASE}/bin/auplay
RUN_DEPENDS= auplay:${PORTSDIR}/audio/nas
@@ -98,4 +96,4 @@ do-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/mail/milter-manager/Makefile b/mail/milter-manager/Makefile
index f4e3f87d808e..6f17bfef557b 100644
--- a/mail/milter-manager/Makefile
+++ b/mail/milter-manager/Makefile
@@ -18,12 +18,11 @@ RUN_DEPENDS= rubygem-glib2>0:${PORTSDIR}/devel/rubygem-glib2
USE_RC_SUBR= milter-manager
GNU_CONFIGURE= yes
-MAKE_ARGS+= pkgconfigdir=${PREFIX}/libdata/pkgconfig
-CONFIGURE_ARGS= CPPFLAGS="-I${LOCALBASE}/include" \
- --with-libev \
- --with-package-platform=freebsd \
- LDFLAGS="-L${LOCALBASE}/lib -lintl"
-USES= gmake pkgconfig libtool
+CONFIGURE_ARGS= --with-libev \
+ --with-package-platform=freebsd
+CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib
+USES= gettext gmake libtool pathfix pkgconfig
USE_GNOME= glib20 intltool
USE_LDCONFIG= yes
USE_RUBY= yes
@@ -31,12 +30,11 @@ INSTALL_TARGET= install-strip
OPTIONS_DEFINE= DOCS EXAMPLES
-.include <bsd.port.options.mk>
-
-MANLANG= "" ja
PORTDOCS= *
PORTEXAMPLES= *
+.include <bsd.port.options.mk>
+
.if ${PORT_OPTIONS:MDOCS}
CONFIGURE_ARGS+=--with-html-dir=${DOCSDIR}
.else