aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-08-28 20:14:21 +0800
committeredwin <edwin@FreeBSD.org>2003-08-28 20:14:21 +0800
commitb5bd987d9b9ee2c2ac55a218690f4a05aa25aa7d (patch)
treedb535505a25785e63b3af6ae54fd3eb387203ac9 /mail
parent9245a3c3d4debdbc4dac3c3850bccbd3efde8ac1 (diff)
downloadfreebsd-ports-gnome-b5bd987d9b9ee2c2ac55a218690f4a05aa25aa7d.tar.gz
freebsd-ports-gnome-b5bd987d9b9ee2c2ac55a218690f4a05aa25aa7d.tar.zst
freebsd-ports-gnome-b5bd987d9b9ee2c2ac55a218690f4a05aa25aa7d.zip
[update ports]: Use USE_MYSQL and USE_OPENLDAP in my ports
www/mod_accounting [1] mail/perdition [2] security/prelude-manager [3] PR: ports/56026 Submitted by: Clement Laforet <sheepkiller@cultdeadsheep.org>
Diffstat (limited to 'mail')
-rw-r--r--mail/perdition/Makefile31
1 files changed, 3 insertions, 28 deletions
diff --git a/mail/perdition/Makefile b/mail/perdition/Makefile
index 3d559325cd3e..a63228117539 100644
--- a/mail/perdition/Makefile
+++ b/mail/perdition/Makefile
@@ -42,35 +42,10 @@ INSTALLS_SHLIB= yes
# WITH_NIS: Enable NIS database backend
# WITH_GDBM: Enable gdbm database backend
# WITH_MYSQL: Enable MySQL database backend
-# WITH_MYSQL_VER:
-# - 323 use MySQL 3.23.x
-# - 40 use MySQL 4.0.x
-# - 41 use MySQL 4.1.x
# WITH_PGSQL: Enable PostgreSQL database backend
# WITH_OPENLDAP: Enable OpenLDAP database backend
# WITH_ODBC: Enable ODBC database backend
-LDAP_VER?= 21
-
-# MySQL deps hack (revision 2)
-MYSQL323_LIBVER=10
-MYSQL40_LIBVER= 12
-MYSQL41_LIBVER= 14
-
-.include <bsd.port.pre.mk>
-
-.if defined(WITH_MYSQL_VER)
-MYSQL_VER= ${WITH_MYSQL_VER}
-.elif exists(${LOCALBASE}/lib/mysql/libmysqlclient.so.${MYSQL_323_LIBVER})
-MYSQL_VER= 323
-.elif exists(${LOCALBASE}/lib/mysql/libmysqlclient.so.${MYSQL40_LIBVER})
-MYSQL_VER= 40
-.elif exists(${LOCALBASE}/lib/mysql/libmysqlclient.so.${MYSQL41_LIBVER})
-MYSQL_VER= 41
-.else
-MYSQL_VER= 40
-.endif
-
.if !defined(WITHOUT_SSL)
CONFIGURE_ARGS+= --enable-ssl
USE_OPENSSL= yes
@@ -115,8 +90,8 @@ PLIST_SUB+= GDBM="@comment "
.endif
.if defined(WITH_MYSQL)
+USE_MYSQL= YES
CONFIGURE_ARGS+= --enable-mysql
-LIB_DEPENDS+= mysqlclient.${MYSQL${MYSQL_VER}_LIBVER}:${PORTSDIR}/databases/mysql${MYSQL_VER}-client
PLIST_SUB+= MYSQL=""
MAN8+= perditiondb_mysql_makedb.8
.else
@@ -135,8 +110,8 @@ PLIST_SUB+= PGSQL="@comment "
.endif
.if defined(WITH_OPENLDAP)
+USE_OPENLDAP= YES
CONFIGURE_ARGS+= --enable-ldap --with-ldap-schema-directory=${LOCALBASE}/etc/openldap/schema/
-LIB_DEPENDS+= ldap.2:${PORTSDIR}/net/openldap${LDAP_VER}-client
PLIST_SUB+= OPENLDAP=""
MAN8+= perditiondb_ldap_makedb.8
.else
@@ -164,4 +139,4 @@ post-install:
@${ECHO_MSG} "/********************************************************/"
@${ECHO_MSG} ""
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>