aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2010-04-03 00:53:24 +0800
committermiwi <miwi@FreeBSD.org>2010-04-03 00:53:24 +0800
commitbb4e70957afff1dddc3a377738f62f34fc81417d (patch)
tree5562ccd663d2ebc43374b35d58d1fa0e12fc34e9 /mail
parentc2a63ccf1e72f713e3034d5980cefeb3703d8930 (diff)
downloadfreebsd-ports-gnome-bb4e70957afff1dddc3a377738f62f34fc81417d.tar.gz
freebsd-ports-gnome-bb4e70957afff1dddc3a377738f62f34fc81417d.tar.zst
freebsd-ports-gnome-bb4e70957afff1dddc3a377738f62f34fc81417d.zip
This perl script generates top spam/ham rules fired for SpamAssassin
installations: TOP SPAM RULES FIRED ---------------------------------------------------------------------- RANK RULE NAME COUNT %OFMAIL %OFSPAM %OFHAM ---------------------------------------------------------------------- 1 CMAE_1 30455 26.68 70.34 0.03 2 BAYES_99 24478 21.98 56.54 0.89 3 RAZOR2_CHECK 11910 10.61 27.52 0.29 ---------------------------------------------------------------------- TOP HAM RULES FIRED ---------------------------------------------------------------------- RANK RULE NAME COUNT %OFMAIL %OFSPAM %OFHAM ---------------------------------------------------------------------- 1 BAYES_00 44253 46.60 20.71 62.40 2 ALL_TRUSTED 34534 49.42 50.61 48.70 3 SPF_PASS 10880 17.43 20.82 15.35 ---------------------------------------------------------------------- WWW: http://www.rulesemporium.com/programs/ PR: ports/144802 Submitted by: Alexey V. Degtyarev <alexey at renatasystems.org>
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/sa-stats/Makefile35
-rw-r--r--mail/sa-stats/distinfo3
-rw-r--r--mail/sa-stats/pkg-descr22
4 files changed, 61 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index b8550a1ae46a..8b645c6dede5 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -598,6 +598,7 @@
SUBDIR += rubygem-actionmailer
SUBDIR += rubygem-mailfactory
SUBDIR += rubygem-tmail
+ SUBDIR += sa-stats
SUBDIR += sa-utils
SUBDIR += sastatd
SUBDIR += sccmilter
diff --git a/mail/sa-stats/Makefile b/mail/sa-stats/Makefile
new file mode 100644
index 000000000000..b92d9e3d16d0
--- /dev/null
+++ b/mail/sa-stats/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: sa-stats
+# Date created: Tue 16 Mar 2010
+# Whom: Alexey V. Degtyarev <alexey@renatasystems.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sa-stats
+PORTVERSION= 1.0
+CATEGORIES= mail
+MASTER_SITES= http://www.rulesemporium.com/programs/ \
+ ftp://renatasystems.org/pub/FreeBSD/ports/distfiles/
+DISTNAME= ${PORTNAME}-${PORTVERSION}.txt
+EXTRACT_SUFX=
+EXTRACT_ONLY=
+
+MAINTAINER= alexey@renatasystems.org
+COMMENT= Generates top spam/ham rules fired for SpamAssassin installations
+
+RUN_DEPENDS= p5-Getopt-Long>=0:${PORTSDIR}/devel/p5-Getopt-Long
+
+USE_PERL5= yes
+
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+
+PLIST_FILES= bin/sa-stats
+
+post-extract:
+ ${CP} ${DISTDIR}/${DISTNAME} ${WRKSRC}
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/${DISTNAME} ${PREFIX}/bin/sa-stats
+
+.include <bsd.port.mk>
diff --git a/mail/sa-stats/distinfo b/mail/sa-stats/distinfo
new file mode 100644
index 000000000000..5b4966674e81
--- /dev/null
+++ b/mail/sa-stats/distinfo
@@ -0,0 +1,3 @@
+MD5 (sa-stats-1.0.txt) = 681d592694740331254a7b41b7f04aaf
+SHA256 (sa-stats-1.0.txt) = dc66ada115a61f4dfe727305a02c518a419c6cad51278e506153a6798094d42e
+SIZE (sa-stats-1.0.txt) = 8411
diff --git a/mail/sa-stats/pkg-descr b/mail/sa-stats/pkg-descr
new file mode 100644
index 000000000000..3eea8265faf9
--- /dev/null
+++ b/mail/sa-stats/pkg-descr
@@ -0,0 +1,22 @@
+This perl script generates top spam/ham rules fired for SpamAssassin
+installations:
+
+TOP SPAM RULES FIRED
+----------------------------------------------------------------------
+RANK RULE NAME COUNT %OFMAIL %OFSPAM %OFHAM
+----------------------------------------------------------------------
+ 1 CMAE_1 30455 26.68 70.34 0.03
+ 2 BAYES_99 24478 21.98 56.54 0.89
+ 3 RAZOR2_CHECK 11910 10.61 27.52 0.29
+----------------------------------------------------------------------
+
+TOP HAM RULES FIRED
+----------------------------------------------------------------------
+RANK RULE NAME COUNT %OFMAIL %OFSPAM %OFHAM
+----------------------------------------------------------------------
+ 1 BAYES_00 44253 46.60 20.71 62.40
+ 2 ALL_TRUSTED 34534 49.42 50.61 48.70
+ 3 SPF_PASS 10880 17.43 20.82 15.35
+----------------------------------------------------------------------
+
+WWW: http://www.rulesemporium.com/programs/