aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authormezz <mezz@FreeBSD.org>2008-02-28 12:40:05 +0800
committermezz <mezz@FreeBSD.org>2008-02-28 12:40:05 +0800
commitc32acdbae3e8c024f7270b1a4fbe4c6680ded31a (patch)
tree91ad14228654f5bf24c0088e221bddfc5fb049e9 /mail
parent5360b3a571f798a57fbdfc4ab2da8aa870537e58 (diff)
downloadfreebsd-ports-gnome-c32acdbae3e8c024f7270b1a4fbe4c6680ded31a.tar.gz
freebsd-ports-gnome-c32acdbae3e8c024f7270b1a4fbe4c6680ded31a.tar.zst
freebsd-ports-gnome-c32acdbae3e8c024f7270b1a4fbe4c6680ded31a.zip
- Add "--with-default-mozilla-five-home=${PREFIX}/lib/${MOZILLA}" to fix other
applications in the runtime. Some applications required to have set MOZILLA_FIVE_HOME or/and LD_LIBRARY_PATH to make it works in the runtime. Now, it's no longer need to set these variables, which this flag takes care of it. The MOZILLA_FIVE_HOME still works with this flag if someone need to use different one. I have learned about this flag from RPM, Debian, Gentoo ebuild and other packages. - Add two extensions, auth[1] and transformiix[2]. Have been tested in MC CVS since Dec. PR: ports/117734 [1] Submitted by: Nathan Whitehorn <nathanw@uchicago.edu> [1] Reported by: Juan Pablo Roig <juan.roig@globant.com> [2]
Diffstat (limited to 'mail')
-rw-r--r--mail/thunderbird-esr/Makefile9
-rw-r--r--mail/thunderbird/Makefile9
-rw-r--r--mail/thunderbird3/Makefile9
3 files changed, 15 insertions, 12 deletions
diff --git a/mail/thunderbird-esr/Makefile b/mail/thunderbird-esr/Makefile
index e7a4e6672505..bdcf9ebdcc52 100644
--- a/mail/thunderbird-esr/Makefile
+++ b/mail/thunderbird-esr/Makefile
@@ -3,12 +3,12 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/mail/thunderbird/Makefile,v 1.25 2007/04/20 14:29:23 ahze Exp $
+# $MCom: ports/mail/thunderbird/Makefile,v 1.28 2008/01/10 17:58:39 mezz Exp $
#
PORTNAME= thunderbird
DISTVERSION= 2.0.0.9
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= mail ipv6
MASTER_SITES= ${MASTER_SITE_MOZILLA_EXTENDED}
MASTER_SITE_SUBDIR= thunderbird/releases/${DISTVERSION}/source
@@ -27,10 +27,11 @@ USE_GMAKE= yes
USE_GCC= 3.4+
WANT_PERL= yes
-MOZ_EXTENSIONS= wallet,spellcheck,xmlextras,webservices
+MOZ_EXTENSIONS= wallet,spellcheck,xmlextras,webservices,auth,transformiix
MOZ_PROTOCOLS= http,file,jar,viewsource,res,data
MOZ_GRAPHICS= default,-xbm
-MOZ_OPTIONS= --enable-single-profile --disable-profilesharing \
+MOZ_OPTIONS= --with-default-mozilla-five-home=${PREFIX}/lib/${MOZILLA} \
+ --enable-single-profile --disable-profilesharing \
--enable-application=mail --enable-official-branding
MOZ_MK_OPTIONS= MOZ_MOZ_THUNDERBIRD=1
MOZ_EXPORT= MOZ_THUNDERBIRD=1
diff --git a/mail/thunderbird/Makefile b/mail/thunderbird/Makefile
index e7a4e6672505..bdcf9ebdcc52 100644
--- a/mail/thunderbird/Makefile
+++ b/mail/thunderbird/Makefile
@@ -3,12 +3,12 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/mail/thunderbird/Makefile,v 1.25 2007/04/20 14:29:23 ahze Exp $
+# $MCom: ports/mail/thunderbird/Makefile,v 1.28 2008/01/10 17:58:39 mezz Exp $
#
PORTNAME= thunderbird
DISTVERSION= 2.0.0.9
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= mail ipv6
MASTER_SITES= ${MASTER_SITE_MOZILLA_EXTENDED}
MASTER_SITE_SUBDIR= thunderbird/releases/${DISTVERSION}/source
@@ -27,10 +27,11 @@ USE_GMAKE= yes
USE_GCC= 3.4+
WANT_PERL= yes
-MOZ_EXTENSIONS= wallet,spellcheck,xmlextras,webservices
+MOZ_EXTENSIONS= wallet,spellcheck,xmlextras,webservices,auth,transformiix
MOZ_PROTOCOLS= http,file,jar,viewsource,res,data
MOZ_GRAPHICS= default,-xbm
-MOZ_OPTIONS= --enable-single-profile --disable-profilesharing \
+MOZ_OPTIONS= --with-default-mozilla-five-home=${PREFIX}/lib/${MOZILLA} \
+ --enable-single-profile --disable-profilesharing \
--enable-application=mail --enable-official-branding
MOZ_MK_OPTIONS= MOZ_MOZ_THUNDERBIRD=1
MOZ_EXPORT= MOZ_THUNDERBIRD=1
diff --git a/mail/thunderbird3/Makefile b/mail/thunderbird3/Makefile
index e7a4e6672505..bdcf9ebdcc52 100644
--- a/mail/thunderbird3/Makefile
+++ b/mail/thunderbird3/Makefile
@@ -3,12 +3,12 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/mail/thunderbird/Makefile,v 1.25 2007/04/20 14:29:23 ahze Exp $
+# $MCom: ports/mail/thunderbird/Makefile,v 1.28 2008/01/10 17:58:39 mezz Exp $
#
PORTNAME= thunderbird
DISTVERSION= 2.0.0.9
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= mail ipv6
MASTER_SITES= ${MASTER_SITE_MOZILLA_EXTENDED}
MASTER_SITE_SUBDIR= thunderbird/releases/${DISTVERSION}/source
@@ -27,10 +27,11 @@ USE_GMAKE= yes
USE_GCC= 3.4+
WANT_PERL= yes
-MOZ_EXTENSIONS= wallet,spellcheck,xmlextras,webservices
+MOZ_EXTENSIONS= wallet,spellcheck,xmlextras,webservices,auth,transformiix
MOZ_PROTOCOLS= http,file,jar,viewsource,res,data
MOZ_GRAPHICS= default,-xbm
-MOZ_OPTIONS= --enable-single-profile --disable-profilesharing \
+MOZ_OPTIONS= --with-default-mozilla-five-home=${PREFIX}/lib/${MOZILLA} \
+ --enable-single-profile --disable-profilesharing \
--enable-application=mail --enable-official-branding
MOZ_MK_OPTIONS= MOZ_MOZ_THUNDERBIRD=1
MOZ_EXPORT= MOZ_THUNDERBIRD=1