aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authornaddy <naddy@FreeBSD.org>2003-03-25 09:26:45 +0800
committernaddy <naddy@FreeBSD.org>2003-03-25 09:26:45 +0800
commitc76ae11925537501c9127fd4134621e91e6be5bb (patch)
tree8a6345d82c887c17c6159ea882c854feddfebde5 /mail
parentf74c9f2d39a5bb15b29a8f70060d209acda2b8f3 (diff)
downloadfreebsd-ports-gnome-c76ae11925537501c9127fd4134621e91e6be5bb.tar.gz
freebsd-ports-gnome-c76ae11925537501c9127fd4134621e91e6be5bb.tar.zst
freebsd-ports-gnome-c76ae11925537501c9127fd4134621e91e6be5bb.zip
- Don't strip the mutt binary again, it's done by install -s.
- Fix the pkg-plist if NOPORTDOCS and some of the other knobs are defined. PR: 50235, 50227 Submitted by: Udo Schweigert <udo.schweigert@siemens.com>
Diffstat (limited to 'mail')
-rw-r--r--mail/mutt-devel/Makefile1
-rw-r--r--mail/mutt-devel/scripts/generate-plist79
2 files changed, 38 insertions, 42 deletions
diff --git a/mail/mutt-devel/Makefile b/mail/mutt-devel/Makefile
index 459b03b72589..706a7746fb67 100644
--- a/mail/mutt-devel/Makefile
+++ b/mail/mutt-devel/Makefile
@@ -314,7 +314,6 @@ pre-install:
@${SETENV} ${SCRIPTS_ENV} ${SH} ${SCRIPTDIR}/generate-plist > ${PLIST}
post-install:
- @strip ${PREFIX}/bin/mutt
.if !defined(NOPORTDOCS)
@${ECHO} "===> Installing Mutt documentation"
@${MKDIR} ${PREFIX}/share/doc/mutt && \
diff --git a/mail/mutt-devel/scripts/generate-plist b/mail/mutt-devel/scripts/generate-plist
index 6ad92ecdc73d..d14aac2fd153 100644
--- a/mail/mutt-devel/scripts/generate-plist
+++ b/mail/mutt-devel/scripts/generate-plist
@@ -59,7 +59,7 @@ share/locale/zh_TW/LC_MESSAGES/mutt.mo
EOF
if [ "$MUTT_PORTDOCS" = "yes" ]; then
-cat >> $tmp_first <<EOF
+ cat >> $tmp_first <<EOF
share/doc/mutt/ABOUT-NLS
share/doc/mutt/COPYRIGHT
share/doc/mutt/ChangeLog
@@ -111,51 +111,48 @@ share/doc/mutt/samples/iconv/iconv.solaris-2.6-cjk.rc
share/doc/mutt/samples/iconv/iconv.solaris-2.6.rc
share/doc/mutt/samples/iconv/iconv.solaris-2.7.rc
EOF
-fi
-
-if [ "$MUTT_NNTP" = "yes" ]; then
-echo "share/doc/mutt/ChangeLog.nntp" >> $tmp_first
-fi
-if [ "$MUTT_SGML" = "yes" ]; then
-echo "share/doc/mutt/manual.latin1" >> $tmp_first
-echo "share/doc/mutt/manual.ps" >> $tmp_first
-fi
-if [ "$MUTT_HTML" = "yes" ]; then
- html=366
- if [ "$MUTT_COMPRESSED_FOLDERS" = "yes" ]; then
- html=$(($html + 5))
- fi
if [ "$MUTT_NNTP" = "yes" ]; then
- html=$(($html + 22))
- fi
- if [ "$MUTT_QUOTE_PATCH" = "yes" ]; then
- html=$(($html + 2))
+ echo "share/doc/mutt/ChangeLog.nntp" >> $tmp_first
fi
- if [ "$MUTT_EDIT_THREADS" = "yes" ]; then
- html=$(($html + 3))
+ if [ "$MUTT_SGML" = "yes" ]; then
+ echo "share/doc/mutt/manual.latin1" >> $tmp_first
+ echo "share/doc/mutt/manual.ps" >> $tmp_first
fi
- if [ "$MUTT_SIGNATURE_MENU" = "yes" ]; then
- html=$(($html + 1))
- fi
- if [ "$MUTT_IFDEF_PATCH" = "yes" ]; then
- html=$(($html + 1))
- fi
- if [ "$MUTT_PGP_PATCH" = "yes" ]; then
- html=$(($html + 2))
- fi
- echo "share/doc/mutt/html/manual.html" >> $tmp_first
- echo "share/doc/mutt/html/manual_toc.html" >> $tmp_first
- i=1
- while [ $i -le $html ]; do
- echo "share/doc/mutt/html/manual$i.html" >> $tmp_first
- i=$(($i + 1))
- done
- echo "@dirrm share/doc/mutt/html" >> $tmp_last
-fi
-if [ "$MUTT_PORTDOCS" = "yes" ]; then
-cat >> $tmp_last <<EOF
+ if [ "$MUTT_HTML" = "yes" ]; then
+ html=366
+ if [ "$MUTT_COMPRESSED_FOLDERS" = "yes" ]; then
+ html=$(($html + 5))
+ fi
+ if [ "$MUTT_NNTP" = "yes" ]; then
+ html=$(($html + 22))
+ fi
+ if [ "$MUTT_QUOTE_PATCH" = "yes" ]; then
+ html=$(($html + 2))
+ fi
+ if [ "$MUTT_EDIT_THREADS" = "yes" ]; then
+ html=$(($html + 3))
+ fi
+ if [ "$MUTT_SIGNATURE_MENU" = "yes" ]; then
+ html=$(($html + 1))
+ fi
+ if [ "$MUTT_IFDEF_PATCH" = "yes" ]; then
+ html=$(($html + 1))
+ fi
+ if [ "$MUTT_PGP_PATCH" = "yes" ]; then
+ html=$(($html + 2))
+ fi
+ echo "share/doc/mutt/html/manual.html" >> $tmp_first
+ echo "share/doc/mutt/html/manual_toc.html" >> $tmp_first
+ i=1
+ while [ $i -le $html ]; do
+ echo "share/doc/mutt/html/manual$i.html" >> $tmp_first
+ i=$(($i + 1))
+ done
+ echo "@dirrm share/doc/mutt/html" >> $tmp_last
+ fi
+ cat >> $tmp_last <<EOF
@dirrm share/doc/mutt/samples/iconv
@dirrm share/doc/mutt/samples
@dirrm share/doc/mutt