aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-02-27 06:18:08 +0800
committermiwi <miwi@FreeBSD.org>2007-02-27 06:18:08 +0800
commitd1a03c364e673701882f61e7c450a9f5956f96e4 (patch)
treea87503abd57ce2dc9bc40a6bf645290f648bb876 /mail
parent8911728fa9827e22d465c6d39565674324d3393e (diff)
downloadfreebsd-ports-gnome-d1a03c364e673701882f61e7c450a9f5956f96e4.tar.gz
freebsd-ports-gnome-d1a03c364e673701882f61e7c450a9f5956f96e4.tar.zst
freebsd-ports-gnome-d1a03c364e673701882f61e7c450a9f5956f96e4.zip
- Depend on compatibility-plugin1, doesn't work with version 2
- Rework Makefile to make more consistent with 5.2 of the Porters Handbook - Fix plugin activation - Bump PORTREVISION PR: 109435 Submitted by: Thomas Abthorpe <thomas@goodking.ca> (maintainer)
Diffstat (limited to 'mail')
-rw-r--r--mail/squirrelmail-newuser_wiz-plugin/Makefile21
1 files changed, 15 insertions, 6 deletions
diff --git a/mail/squirrelmail-newuser_wiz-plugin/Makefile b/mail/squirrelmail-newuser_wiz-plugin/Makefile
index 483c1302902b..639571c441d0 100644
--- a/mail/squirrelmail-newuser_wiz-plugin/Makefile
+++ b/mail/squirrelmail-newuser_wiz-plugin/Makefile
@@ -5,21 +5,23 @@
# $FreeBSD$
#
-PORTNAME= squirrelmail-${SQUIRREL_PLUGIN_NAME}-plugin
+PORTNAME= newuser_wiz
PORTVERSION= 1.3.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= mail www
MASTER_SITES= http://www.squirrelmail.org/plugins/
-DISTNAME= ${SQUIRREL_PLUGIN_NAME}-${PORTVERSION}
+PKGNAMEPREFIX= squirrelmail-
+PKGNAMESUFFIX= -plugin
+DISTNAME= ${PORTNAME}-${PORTVERSION}
DIST_SUBDIR= squirrelmail
MAINTAINER= thomas@goodking.ca
COMMENT= Force user to enter Full name and Email address at initial logon
RUN_DEPENDS= ${SQUIRRELDIR}/index.php:${PORTSDIR}/mail/squirrelmail \
- ${SQUIRRELDIR}/plugins/compatibility:${PORTSDIR}/mail/squirrelmail-compatibility-plugin
+ ${SQUIRRELDIR}/plugins/compatibility:${PORTSDIR}/mail/squirrelmail-compatibility-plugin1
-SQUIRREL_PLUGIN_NAME= newuser_wiz
+SQUIRREL_PLUGIN_NAME= ${PORTNAME}
.ifdef SQUIRRELDIR
PLIST_SUB+= SQUIRRELDIR=${SQUIRRELDIR}
@@ -35,6 +37,7 @@ PLIST_SUB+= SQUIRRELDIR=squirrelmail
SUB_LIST+= "SQUIRRELDIR=squirrelmail"
.endif
.endif
+PLIST_SUB+= SQUIRREL_PLUGIN_NAME=${SQUIRREL_PLUGIN_NAME}
NO_BUILD= yes
NO_WRKSUBDIR= yes
@@ -42,6 +45,12 @@ USE_PERL5_BUILD= yes
USE_PHP= yes
WANT_PHP_WEB= yes
+.include <bsd.port.pre.mk>
+
+.if exists(${SQUIRRELDIR}/plugins/compatibility/getpot)
+IGNORE='compatibility2 plugin is incompatible with this plugin, install mail/squirrelmail-compatibility-plugin1. WARNING compatibility-plugin1 could break other squirrelmail plugins'
+.endif
+
pre-everything::
@${ECHO} ""
.ifndef WITHOUT_ACTIVATE
@@ -70,4 +79,4 @@ post-install:
@${ECHO} "${SQUIRRELDIR}/config/conf.pl --install-plugin ${SQUIRREL_PLUGIN_NAME}"
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>