aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2010-12-17 17:24:56 +0800
committermiwi <miwi@FreeBSD.org>2010-12-17 17:24:56 +0800
commitd234826da20388824fadb2860de7d2c9859aac1f (patch)
tree1a99716269b415257e12eec98b01c5571a1fa641 /mail
parente11713dab3c2666348376bbe06d7b504b73cfcf8 (diff)
downloadfreebsd-ports-gnome-d234826da20388824fadb2860de7d2c9859aac1f.tar.gz
freebsd-ports-gnome-d234826da20388824fadb2860de7d2c9859aac1f.tar.zst
freebsd-ports-gnome-d234826da20388824fadb2860de7d2c9859aac1f.zip
This plugin uses Clam AntiVirus to scan all messages that are
received from an IMAP, LOCAL or POP account. When a message attachment is found to contain a virus it can be deleted or saved in a specially designated folder. Options can be found in /Configuration/Preferences/Plugins/Clam AntiVirus. WWW: http://www.claws-mail.org/plugins.php PR: ports/152758 Submitted by: Pawel Pekala <c0rn at o2.pl>
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/claws-mail-clamd/Makefile46
-rw-r--r--mail/claws-mail-clamd/distinfo2
-rw-r--r--mail/claws-mail-clamd/pkg-descr9
-rw-r--r--mail/claws-mail-clamd/pkg-message4
-rw-r--r--mail/claws-mail-clamd/pkg-plist14
6 files changed, 76 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index 9ff3635d9e4e..33086928132b 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -51,6 +51,7 @@
SUBDIR += claws-mail-attach_warner
SUBDIR += claws-mail-bsfilter
SUBDIR += claws-mail-cachesaver
+ SUBDIR += claws-mail-clamd
SUBDIR += claws-mail-fancy
SUBDIR += claws-mail-fetchinfo
SUBDIR += claws-mail-gtkhtml2_viewer
diff --git a/mail/claws-mail-clamd/Makefile b/mail/claws-mail-clamd/Makefile
new file mode 100644
index 000000000000..11d1ba267bf6
--- /dev/null
+++ b/mail/claws-mail-clamd/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: claws-mail-clamd
+# Date created: 2010-12-01
+# Whom: Pawel Pekala <c0rn@o2.pl>
+#
+# $FreeBSD$
+#
+
+PORTNAME= clamd
+PORTVERSION= 3.5
+CATEGORIES= mail
+MASTER_SITES= http://www.claws-mail.org/downloads/plugins/
+PKGNAMEPREFIX= claws-mail-
+
+MAINTAINER= c0rn@o2.pl
+COMMENT= This plugin scans messages using clamd (Clam AV)
+
+BUILD_DEPENDS= claws-mail>=3.7.8:${PORTSDIR}/mail/claws-mail
+RUN_DEPENDS= claws-mail>=3.7.8:${PORTSDIR}/mail/claws-mail \
+ clamd:${PORTSDIR}/security/clamav
+
+LICENSE= GPLv3
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_ICONV= yes
+MAKE_JOBS_SAFE= yes
+
+.if defined(WITHOUT_NLS)
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
+.else
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.endif
+
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+post-install:
+ @${ECHO}
+ @${ECHO_CMD} "********************************************************************************"
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO_CMD} "********************************************************************************"
+ @${ECHO}
+
+.include <bsd.port.mk>
diff --git a/mail/claws-mail-clamd/distinfo b/mail/claws-mail-clamd/distinfo
new file mode 100644
index 000000000000..c4b87350cc6c
--- /dev/null
+++ b/mail/claws-mail-clamd/distinfo
@@ -0,0 +1,2 @@
+SHA256 (clamd-3.5.tar.gz) = 5c15ab75d6decd3cb6428c31d76479238a90df1e6b31be259b6f761420e017db
+SIZE (clamd-3.5.tar.gz) = 376200
diff --git a/mail/claws-mail-clamd/pkg-descr b/mail/claws-mail-clamd/pkg-descr
new file mode 100644
index 000000000000..edfd88445442
--- /dev/null
+++ b/mail/claws-mail-clamd/pkg-descr
@@ -0,0 +1,9 @@
+his plugin uses Clam AntiVirus to scan all messages that are
+received from an IMAP, LOCAL or POP account.
+
+When a message attachment is found to contain a virus it can be
+deleted or saved in a specially designated folder.
+
+Options can be found in /Configuration/Preferences/Plugins/Clam AntiVirus.
+
+WWW: http://www.claws-mail.org/plugins.php
diff --git a/mail/claws-mail-clamd/pkg-message b/mail/claws-mail-clamd/pkg-message
new file mode 100644
index 000000000000..d8c705bb285b
--- /dev/null
+++ b/mail/claws-mail-clamd/pkg-message
@@ -0,0 +1,4 @@
+Due to licensing issues this plugin does not link against any libraries
+from clamav. The plugin therefore requires a running clamav daemon running
+on either localhost or somewhere else which allows the plugin access via
+a unix or a TCP socket.
diff --git a/mail/claws-mail-clamd/pkg-plist b/mail/claws-mail-clamd/pkg-plist
new file mode 100644
index 000000000000..629dbada2e8a
--- /dev/null
+++ b/mail/claws-mail-clamd/pkg-plist
@@ -0,0 +1,14 @@
+lib/claws-mail/plugins/clamd.so
+lib/claws-mail/plugins/clamd.la
+lib/claws-mail/plugins/clamd.a
+%%NLS%%share/locale/cs/LC_MESSAGES/clamd.mo
+%%NLS%%share/locale/en_GB/LC_MESSAGES/clamd.mo
+%%NLS%%share/locale/es/LC_MESSAGES/clamd.mo
+%%NLS%%share/locale/fi/LC_MESSAGES/clamd.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/clamd.mo
+%%NLS%%share/locale/hu/LC_MESSAGES/clamd.mo
+%%NLS%%share/locale/id/LC_MESSAGES/clamd.mo
+%%NLS%%share/locale/it/LC_MESSAGES/clamd.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/clamd.mo
+%%NLS%%share/locale/sk/LC_MESSAGES/clamd.mo
+%%NLS%%share/locale/uk/LC_MESSAGES/clamd.mo