aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2015-10-28 20:57:22 +0800
committermat <mat@FreeBSD.org>2015-10-28 20:57:22 +0800
commitd340bf3573c870aaea7c5f33b8427b5ad3a0a73f (patch)
tree362719446dc117b2bf865046ac8eea1487101e8c /mail
parent318383eba553522938d5382822ec9d94ae3f433f (diff)
downloadfreebsd-ports-gnome-d340bf3573c870aaea7c5f33b8427b5ad3a0a73f.tar.gz
freebsd-ports-gnome-d340bf3573c870aaea7c5f33b8427b5ad3a0a73f.tar.zst
freebsd-ports-gnome-d340bf3573c870aaea7c5f33b8427b5ad3a0a73f.zip
add IPv6 support in connect_callback
maintainer timeout PR: 202248 Submitted by: fbsd opal com MFH: 2015Q4 Sponsored by: Absolight
Diffstat (limited to 'mail')
-rw-r--r--mail/p5-Sendmail-Milter/Makefile2
-rw-r--r--mail/p5-Sendmail-Milter/files/patch-Milter.pm17
-rw-r--r--mail/p5-Sendmail-Milter/files/patch-callbacks.c14
3 files changed, 32 insertions, 1 deletions
diff --git a/mail/p5-Sendmail-Milter/Makefile b/mail/p5-Sendmail-Milter/Makefile
index c212a52f87b6..12700e42596d 100644
--- a/mail/p5-Sendmail-Milter/Makefile
+++ b/mail/p5-Sendmail-Milter/Makefile
@@ -3,7 +3,7 @@
PORTNAME= Sendmail-Milter
PORTVERSION= 0.18
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= mail perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
diff --git a/mail/p5-Sendmail-Milter/files/patch-Milter.pm b/mail/p5-Sendmail-Milter/files/patch-Milter.pm
new file mode 100644
index 000000000000..a345ef359a58
--- /dev/null
+++ b/mail/p5-Sendmail-Milter/files/patch-Milter.pm
@@ -0,0 +1,17 @@
+--- Milter.pm.orig 2001-10-10 04:21:22 UTC
++++ Milter.pm
+@@ -423,10 +423,10 @@ calls. See B<Milter Context Functions> f
+ =item B<connect_callback> CTX, HOSTNAME, SOCKADDR_IN
+
+ Invoked on each connection. HOSTNAME is the host domain name, as determined by
+-a reverse lookup on the host address. SOCKADDR_IN is the AF_INET portion of the
+-host address, as determined by a B<getpeername(2)> syscall on the SMTP
+-socket. You can use B<Socket::unpack_sockaddr_in()> to unpack it into a port
+-and IP address.
++a reverse lookup on the host address. SOCKADDR_IN is the AF_INET or AF_INET6
++portion of the host address, as determined by a B<getpeername(2)> syscall on
++the SMTP socket. You can use B<Socket::unpack_sockaddr_in()> or
++B<Socket6::unpack_sockaddr_in6()> to unpack it into a port and IP address.
+
+ This callback should return one of the B<SMFIS_*> result codes.
+
diff --git a/mail/p5-Sendmail-Milter/files/patch-callbacks.c b/mail/p5-Sendmail-Milter/files/patch-callbacks.c
new file mode 100644
index 000000000000..c42f07bac09e
--- /dev/null
+++ b/mail/p5-Sendmail-Milter/files/patch-callbacks.c
@@ -0,0 +1,14 @@
+--- callbacks.c.orig 2000-07-19 06:20:36 UTC
++++ callbacks.c
+@@ -490,6 +490,11 @@ callback_ssockaddr(pTHX_ SV *callback, S
+ XPUSHs(sv_2mortal(newSVpvn((char *)arg_sa,
+ sizeof(_SOCK_ADDR))));
+ }
++ else if (arg_sa->sa_family == AF_INET6)
++ {
++ XPUSHs(sv_2mortal(newSVpvn((char *)arg_sa,
++ sizeof(struct sockaddr_in6))));
++ }
+ else
+ {
+ XPUSHs(sv_2mortal(newSVsv(&PL_sv_undef)));
44/cgit/cgit.cgi/freebsd-ports-gnome/commit/lang?id=63373f0f49896d5c0e7a4aa1851b4943ff9f10af'>Convert tab after WWW: in pkg-descrs to single space as per PHBamdmi32016-05-247-7/+7 * Update to v5.25.1-46-g5f602b3.mat2016-05-235-7/+75 * lang/seed7: update to 05_20160430gahr2016-05-202-3/+4 * ang/cython: 0.23.5 -> 0.24pi2016-05-202-3/+4 * - Fix trailing whitespace in pkg-messagesamdmi32016-05-194-4/+4 * - Fix trailing whitespace in Makefilesamdmi32016-05-191-1/+1 * - Fix trailing whitespace in pkg-descrs, categories [g-n]*amdmi32016-05-19