aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorbeat <beat@FreeBSD.org>2012-10-05 23:02:43 +0800
committerbeat <beat@FreeBSD.org>2012-10-05 23:02:43 +0800
commitd45c3861eec13475d36a0dcd077d2c123c52f024 (patch)
treee763ddf9056af761224bb746fa64db2fcf10f9a7 /mail
parent5a1bc3924bc6cf324f9e739a1ed978182c97ae8f (diff)
downloadfreebsd-ports-gnome-d45c3861eec13475d36a0dcd077d2c123c52f024.tar.gz
freebsd-ports-gnome-d45c3861eec13475d36a0dcd077d2c123c52f024.tar.zst
freebsd-ports-gnome-d45c3861eec13475d36a0dcd077d2c123c52f024.zip
- Convert to optionsng
- Trim Makefile header
Diffstat (limited to 'mail')
-rw-r--r--mail/swaks/Makefile19
1 files changed, 8 insertions, 11 deletions
diff --git a/mail/swaks/Makefile b/mail/swaks/Makefile
index 8008a9665b1f..ae9dc2323661 100644
--- a/mail/swaks/Makefile
+++ b/mail/swaks/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: swaks
-# Date created: 29 Sep 2004
-# Whom: Oliver Eikemeier
-#
+# Created by: Oliver Eikemeier
# $FreeBSD$
-#
PORTNAME= swaks
PORTVERSION= 20120320.0
@@ -15,23 +11,24 @@ COMMENT= Swiss Army Knife SMTP transaction tester
PLIST_FILES= bin/${PORTNAME}
-OPTIONS= PERL_NET_DNS "Add MX lookup support" off \
- PERL_NET_SSLEAY "Add TLS support" off \
- PERL_AUTHEN_NTLM "Add support for AUTH NTLM" off
+OPTIONS_DEFINE= PERL_NET_DNS PERL_NET_SSLEAY PERL_AUTHEN_NTLM
+PERL_NET_DNS_DESC= Add MX lookup support
+PERL_NET_SSLEAY_DESC= Add TLS support
+PERL_AUTHEN_NTLM_DESC= Add support for AUTH NTLM
USE_PERL5_RUN= yes
.include <bsd.port.pre.mk>
-.if defined(WITH_PERL_NET_DNS)
+.if ${PORT_OPTIONS:MPERL_NET_DNS}
RUN_DEPENDS+= p5-Net-DNS>=0:${PORTSDIR}/dns/p5-Net-DNS
.endif
-.if defined(WITH_PERL_NET_SSLEAY)
+.if ${PORT_OPTIONS:MPERL_NET_SSLEAY}
RUN_DEPENDS+= p5-Net-SSLeay>=0:${PORTSDIR}/security/p5-Net-SSLeay
.endif
-.if defined(WITH_PERL_AUTHEN_NTLM)
+.if ${PORT_OPTIONS:MPERL_AUTHEN_NTLM}
RUN_DEPENDS+= p5-Authen-NTLM>=0:${PORTSDIR}/security/p5-Authen-NTLM
.endif