aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorsem <sem@FreeBSD.org>2004-12-06 21:59:54 +0800
committersem <sem@FreeBSD.org>2004-12-06 21:59:54 +0800
commitd5d86e556f5d4f411eaa2e1c79ec6dcd65b9c358 (patch)
tree111b2cff1f74c25d1fe2f5ad64c36787a15b8632 /mail
parent9c6b02d9dc05b37add081c5ddf1cacb1c15130aa (diff)
downloadfreebsd-ports-gnome-d5d86e556f5d4f411eaa2e1c79ec6dcd65b9c358.tar.gz
freebsd-ports-gnome-d5d86e556f5d4f411eaa2e1c79ec6dcd65b9c358.tar.zst
freebsd-ports-gnome-d5d86e556f5d4f411eaa2e1c79ec6dcd65b9c358.zip
- Update to 2.20
PR: ports/74540 Submitted by: maintainer
Diffstat (limited to 'mail')
-rw-r--r--mail/spampd/Makefile3
-rw-r--r--mail/spampd/distinfo4
-rw-r--r--mail/spampd/files/patch-2to363
-rw-r--r--mail/spampd/files/patch-setsid30
4 files changed, 14 insertions, 86 deletions
diff --git a/mail/spampd/Makefile b/mail/spampd/Makefile
index 8f52af358d71..b70b26e48288 100644
--- a/mail/spampd/Makefile
+++ b/mail/spampd/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= spampd
-PORTVERSION= 2.12
-PORTREVISION= 1
+PORTVERSION= 2.20
CATEGORIES= mail perl5
MASTER_SITES= http://www.worlddesign.com/Content/rd/mta/spampd/
diff --git a/mail/spampd/distinfo b/mail/spampd/distinfo
index 2eb13ba436ae..f3a651f62922 100644
--- a/mail/spampd/distinfo
+++ b/mail/spampd/distinfo
@@ -1,2 +1,2 @@
-MD5 (spampd-2.12.tar.gz) = cf4d5959500053c83ac230cd27fd8dd1
-SIZE (spampd-2.12.tar.gz) = 21862
+MD5 (spampd-2.20.tar.gz) = 4efdb66e424bc24f8a7ce3bf6264ce31
+SIZE (spampd-2.20.tar.gz) = 22713
diff --git a/mail/spampd/files/patch-2to3 b/mail/spampd/files/patch-2to3
deleted file mode 100644
index 4af4ef172283..000000000000
--- a/mail/spampd/files/patch-2to3
+++ /dev/null
@@ -1,63 +0,0 @@
---- spampd.orig Tue May 11 09:52:42 2004
-+++ spampd Mon Oct 4 15:06:57 2004
-@@ -395,7 +395,6 @@
- use IO::File;
- use Getopt::Long;
- use Mail::SpamAssassin;
--use Mail::SpamAssassin::NoMailAudit;
-
- BEGIN {
- # Load Time::HiRes if it's available
-@@ -464,8 +463,7 @@
- my $previous_alarm = alarm($self->{spampd}->{satimeout});
-
- # Audit the message
-- my $mail = Mail::SpamAssassin::NoMailAudit->new (
-- data => \@msglines );
-+ my $mail = $assassin->parse( \@msglines );
-
- # Check spamminess
- my $status = $assassin->check($mail);
-@@ -475,11 +473,12 @@
-
- my $addingHeader = 0;
- if ( $self->{spampd}->{addheader} && length($self->{spampd}->{myhostname}) ) {
-- $mail->put_header("X-Spam-Checked-By", $self->{spampd}->{myhostname});
-+ $mail->put_metadata("X-Spam-Checked-By", $self->{spampd}->{myhostname});
- $addingHeader = 1;
- }
-
- # Rewrite mail if high spam factor or options --tagall or --add-sc-header
-+ my $msg_resp = '';
- if ( $status->is_spam || $self->{spampd}->{tagall} || $addingHeader ) {
-
- # if spam or --tagall, have SA put in its report/headers.
-@@ -487,12 +486,14 @@
- if ( $self->{spampd}->{debug} ) {
- $self->log(2, "Rewriting mail using SpamAssassin"); }
-
-- $status->rewrite_mail;
-+ $msg_resp = $status->rewrite_mail;
-
-- }
-+ } else {
-
-- my $msg_resp = join '', $mail->header, "\r\n", @{$mail->body};
-+ $msg_resp = join '', $mail->get_pristine_header(), "\r\n", @{$mail->get_body()};
-+ }
- my @resplines = split(/\r?\n/, $msg_resp);
-+
-
- # Build the new message to relay
- # pause the timeout alarm while we do this (no point in timing
-@@ -513,8 +514,8 @@
- # Log what we did
- my $was_it_spam = 'clean message';
- if ($status->is_spam) { $was_it_spam = 'identified spam'; }
-- my $msg_score = sprintf("%.2f",$status->get_hits);
-- my $msg_threshold = sprintf("%.2f",$status->get_required_hits);
-+ my $msg_score = sprintf("%.2f",$status->get_score);
-+ my $msg_threshold = sprintf("%.2f",$status->get_required_score);
- my $proc_time = sprintf("%.2f", time - $start);
-
- $self->log(2, "$was_it_spam $msgid ($msg_score/$msg_threshold) for ". \ No newline at end of file
diff --git a/mail/spampd/files/patch-setsid b/mail/spampd/files/patch-setsid
index 2fafac1852a7..67e2de8188a8 100644
--- a/mail/spampd/files/patch-setsid
+++ b/mail/spampd/files/patch-setsid
@@ -1,19 +1,11 @@
-*** spampd.orig Wed Apr 7 14:32:09 2004
---- spampd Wed Apr 7 14:32:17 2004
-*************** my $server = bless {
-*** 831,837 ****
- syslog_ident => 'spampd',
- syslog_facility => 'mail',
- background => 1,
-! # setsid => 1,
- pid_file => $pidfile,
- user => $user,
- group => $group,
---- 831,837 ----
- syslog_ident => 'spampd',
- syslog_facility => 'mail',
- background => 1,
-! setsid => 1,
- pid_file => $pidfile,
- user => $user,
- group => $group,
+--- spampd.orig Mon Nov 29 16:34:40 2004
++++ spampd Mon Nov 29 16:34:50 2004
+@@ -825,7 +825,7 @@
+ syslog_ident => 'spampd',
+ syslog_facility => 'mail',
+ background => $background,
+- # setsid => 1,
++ setsid => 1,
+ pid_file => $pidfile,
+ user => $user,
+ group => $group,