aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2017-01-18 21:20:31 +0800
committertijl <tijl@FreeBSD.org>2017-01-18 21:20:31 +0800
commitd7b51d6e3b9874fae397ddfa8717c3be71d84edb (patch)
tree62d2805fd9c9c4285034b54a2ccb3f498f302811 /mail
parent2739bac9ff93a8cdeb834d5da5f0c2720bad7903 (diff)
downloadfreebsd-ports-gnome-d7b51d6e3b9874fae397ddfa8717c3be71d84edb.tar.gz
freebsd-ports-gnome-d7b51d6e3b9874fae397ddfa8717c3be71d84edb.tar.zst
freebsd-ports-gnome-d7b51d6e3b9874fae397ddfa8717c3be71d84edb.zip
The output of tools like awk, date, sort, tr,... depends on the current
locale set by the user. Add LANG=C and LC_ALL=C at the beginning of bsd.port.mk and export them so all commands are executed with the C locale. LC_ALL=C overrides all other LC_* variables. LANG is used by setlocale(3) as default value for LC_* variables, so normally it isn't used when LC_ALL is set, but there's code out there that looks at LANG directly so it's safer to set it as well. The only commands not captured by this are != assignments before any inclusion of bsd.port.*mk. Introduce USE_LOCALE=<locale> that adds LANG=<locale> and LC_ALL=<locale> to CONFIGURE_ENV and MAKE_ENV so upstream build systems can be executed with a different locale (e.g. USE_LOCALE=en_US.UTF-8). PR: 215882 Exp-run by: antoine Approved by: portmgr (antoine)
Diffstat (limited to 'mail')
-rw-r--r--mail/mew/files/patch-info__Makefile3
-rw-r--r--mail/wanderlust-devel/files/patch-Makefile2
-rw-r--r--mail/wanderlust/files/patch-Makefile2
3 files changed, 3 insertions, 4 deletions
diff --git a/mail/mew/files/patch-info__Makefile b/mail/mew/files/patch-info__Makefile
index ba9dae34e941..d0f6a4fc5136 100644
--- a/mail/mew/files/patch-info__Makefile
+++ b/mail/mew/files/patch-info__Makefile
@@ -28,9 +28,8 @@
+ -e 's/@set en/@set ja/' mew.texi > tmp.ja.texi
$(RM) mew.ja.info*
$(TOUCH) mew.ja.info
-- $(EMACS) -batch -q -no-site-file -l texinfmt \
+ $(EMACS) -batch -q -no-site-file -l texinfmt \
- -f batch-texinfo-format mew.texi
-+ LC_ALL=C $(EMACS) -batch -q -no-site-file -l texinfmt \
+ -f batch-texinfo-format tmp.ja.texi
+ $(RM) tmp.ja.texi
diff --git a/mail/wanderlust-devel/files/patch-Makefile b/mail/wanderlust-devel/files/patch-Makefile
index 1b6534760592..2320a7e85703 100644
--- a/mail/wanderlust-devel/files/patch-Makefile
+++ b/mail/wanderlust-devel/files/patch-Makefile
@@ -5,7 +5,7 @@
info:
- $(EMACS) $(FLAGS) -l WL-MK -f wl-texinfo-format $(INFODIR)
-+ LANG=ja $(EMACS) $(FLAGS) -l WL-MK -f wl-texinfo-format $(INFODIR)
++ LANG=ja LC_ALL=ja $(EMACS) $(FLAGS) -l WL-MK -f wl-texinfo-format $(INFODIR)
install-info:
$(EMACS) $(FLAGS) -l WL-MK -f install-wl-info $(INFODIR)
diff --git a/mail/wanderlust/files/patch-Makefile b/mail/wanderlust/files/patch-Makefile
index cdf17c95d230..9716ac1b2b66 100644
--- a/mail/wanderlust/files/patch-Makefile
+++ b/mail/wanderlust/files/patch-Makefile
@@ -5,7 +5,7 @@
info:
- $(EMACS) $(FLAGS) -l WL-MK -f wl-texinfo-format $(INFODIR)
-+ LANG=ja $(EMACS) $(FLAGS) -l WL-MK -f wl-texinfo-format $(INFODIR)
++ LANG=ja LC_ALL=ja $(EMACS) $(FLAGS) -l WL-MK -f wl-texinfo-format $(INFODIR)
install-info:
$(EMACS) $(FLAGS) -l WL-MK -f install-wl-info $(INFODIR)