aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2006-06-27 00:40:45 +0800
committerpav <pav@FreeBSD.org>2006-06-27 00:40:45 +0800
commitdf059eddd7f50b0df9c3ebbf93c0464d8c1c4bda (patch)
tree01e2d8226a6e240a4d90b135523e644197c5881e /mail
parent0e4f5afaf41c88522f557edcb57623170b3d4bfa (diff)
downloadfreebsd-ports-gnome-df059eddd7f50b0df9c3ebbf93c0464d8c1c4bda.tar.gz
freebsd-ports-gnome-df059eddd7f50b0df9c3ebbf93c0464d8c1c4bda.tar.zst
freebsd-ports-gnome-df059eddd7f50b0df9c3ebbf93c0464d8c1c4bda.zip
This is a simple plugin to automatically turn on SSL security during
login if it hasn't already been requested by the referring hyperlink or bookmark. Primarily this utility is intended to prevent plain text passwords and email contents being transmitted over the internet after people manually enter their server URL without including https://... WWW: http://www.squirrelmail.org/plugin_view.php?id=61 PR: ports/99234 Submitted by: Thomas Abthorpe <thomas@goodking.ca>
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/squirrelmail-secure_login-plugin/Makefile76
-rw-r--r--mail/squirrelmail-secure_login-plugin/distinfo3
-rw-r--r--mail/squirrelmail-secure_login-plugin/files/pkg-message.in5
-rw-r--r--mail/squirrelmail-secure_login-plugin/pkg-descr9
-rw-r--r--mail/squirrelmail-secure_login-plugin/pkg-plist10
6 files changed, 104 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index 647fb0cd9e19..93664b75189d 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -519,6 +519,7 @@
SUBDIR += squirrelmail-notes-plugin
SUBDIR += squirrelmail-notify-plugin
SUBDIR += squirrelmail-quota_usage-plugin
+ SUBDIR += squirrelmail-secure_login-plugin
SUBDIR += squirrelmail-vlogin-plugin
SUBDIR += squirrelmail-wetteronline-plugin
SUBDIR += sqwebmail
diff --git a/mail/squirrelmail-secure_login-plugin/Makefile b/mail/squirrelmail-secure_login-plugin/Makefile
new file mode 100644
index 000000000000..aa8c5d6ea0eb
--- /dev/null
+++ b/mail/squirrelmail-secure_login-plugin/Makefile
@@ -0,0 +1,76 @@
+# New ports collection makefile for: squirrelmail-secure_login-plugin
+# Date created: 2006-06-20
+# Whom: Thomas Abthorpe <thomas@goodking.ca>
+#
+# $FreeBSD$
+#
+
+PORTNAME= squirrelmail-${SQUIRREL_PLUGIN_NAME}-plugin
+PORTVERSION= 1.2.8
+CATEGORIES= mail www
+MASTER_SITES= http://www.squirrelmail.org/plugins/
+DISTNAME= ${SQUIRREL_PLUGIN_NAME}-1.2-${PORTVERSION}
+DIST_SUBDIR= squirrelmail
+
+MAINTAINER= thomas@goodking.ca
+COMMENT= This plugin will automatically turn on SSL security during login
+
+RUN_DEPENDS= ${SQUIRRELDIR}/index.php:${PORTSDIR}/mail/squirrelmail \
+ ${SQUIRRELDIR}/plugins/compatibility:${PORTSDIR}/mail/squirrelmail-compatibility-plugin
+
+SQUIRREL_PLUGIN_NAME= secure_login
+
+.ifdef SQUIRRELDIR
+PLIST_SUB+= SQUIRRELDIR=${SQUIRRELDIR}
+SUB_LIST+= "SQUIRRELDIR=${SQUIRRELDIR}"
+.else
+.ifndef WITHOUT_WWWDIR
+SQUIRRELDIR= ${PREFIX}/www/squirrelmail
+PLIST_SUB+= SQUIRRELDIR=www/squirrelmail
+SUB_LIST+= "SQUIRRELDIR=www/squirrelmail"
+.else
+SQUIRRELDIR= ${PREFIX}/squirrelmail
+PLIST_SUB+= SQUIRRELDIR=squirrelmail
+SUB_LIST+= "SQUIRRELDIR=squirrelmail"
+.endif
+.endif
+
+SUB_FILES= pkg-message
+
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+USE_PERL5_BUILD= yes
+USE_PHP= yes
+WANT_PHP_WEB= yes
+
+pre-everything::
+ @${ECHO} ""
+.ifndef WITHOUT_ACTIVATE
+ @${ECHO} "Activating plug-in in SquirrelMail after installation."
+ @${ECHO} "If you don't want to automatically activate the plug-in set"
+ @${ECHO} "WITHOUT_ACTIVATE=yes"
+.else
+ @${ECHO} "NOT Activating plug-in in SquirrelMail after installation."
+ @${ECHO} "If you want to automatically activate the plug-in unset"
+ @${ECHO} "WITHOUT_ACTIVATE"
+.endif
+ @${ECHO} ""
+
+do-install:
+ ${CP} -rp ${WRKSRC}/${SQUIRREL_PLUGIN_NAME} ${SQUIRRELDIR}/plugins
+ ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${SQUIRRELDIR}/plugins/${SQUIRREL_PLUGIN_NAME}
+
+post-install:
+.ifndef WITHOUT_ACTIVATE
+.if exists( ${SQUIRRELDIR}/config/config.php )
+ @${ECHO} "Activating plug-in in SquirrelMail"
+ ${SQUIRRELDIR}/config/conf.pl --install-plugin ${SQUIRREL_PLUGIN_NAME}
+.endif
+.else
+ @${ECHO} "To activate the plug-in in SquirrelMail use"
+ @${ECHO} "${SQUIRRELDIR}/config/conf.pl --install-plugin ${SQUIRREL_PLUGIN_NAME}"
+.endif
+ @${ECHO} ""
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/mail/squirrelmail-secure_login-plugin/distinfo b/mail/squirrelmail-secure_login-plugin/distinfo
new file mode 100644
index 000000000000..2176b660005c
--- /dev/null
+++ b/mail/squirrelmail-secure_login-plugin/distinfo
@@ -0,0 +1,3 @@
+MD5 (squirrelmail/secure_login-1.2-1.2.8.tar.gz) = 73d2c111579e2fad17c289f62e0be855
+SHA256 (squirrelmail/secure_login-1.2-1.2.8.tar.gz) = b3cf5fbf15206ca9f0e00b573408fc78b287fbb2e0d5fcbba93fe6e75ceb4a0b
+SIZE (squirrelmail/secure_login-1.2-1.2.8.tar.gz) = 6361
diff --git a/mail/squirrelmail-secure_login-plugin/files/pkg-message.in b/mail/squirrelmail-secure_login-plugin/files/pkg-message.in
new file mode 100644
index 000000000000..b220c847cde8
--- /dev/null
+++ b/mail/squirrelmail-secure_login-plugin/files/pkg-message.in
@@ -0,0 +1,5 @@
+For the port to work properly you must copy the file
+%%PREFIX%%/%%SQUIRRELDIR%%/plugins/secure_login/config.php.sample
+to
+%%PREFIX%%/%%SQUIRRELDIR%%/plugins/secure_login/config.php
+and edit the configuration to meet your needs.
diff --git a/mail/squirrelmail-secure_login-plugin/pkg-descr b/mail/squirrelmail-secure_login-plugin/pkg-descr
new file mode 100644
index 000000000000..1c572d633ef8
--- /dev/null
+++ b/mail/squirrelmail-secure_login-plugin/pkg-descr
@@ -0,0 +1,9 @@
+This is a simple plugin to automatically turn on SSL security during
+login if it hasn't already been requested by the referring hyperlink
+or bookmark.
+
+Primarily this utility is intended to prevent plain text passwords
+and email contents being transmitted over the internet after people
+manually enter their server URL without including https://...
+
+WWW: http://www.squirrelmail.org/plugin_view.php?id=61
diff --git a/mail/squirrelmail-secure_login-plugin/pkg-plist b/mail/squirrelmail-secure_login-plugin/pkg-plist
new file mode 100644
index 000000000000..9eb677aaca9c
--- /dev/null
+++ b/mail/squirrelmail-secure_login-plugin/pkg-plist
@@ -0,0 +1,10 @@
+@unexec if [ -f %D/%%SQUIRRELDIR%%/config/config.php ]; then %D/%%SQUIRRELDIR%%/config/conf.pl --remove-plugin newuser_wiz; fi
+%%SQUIRRELDIR%%/plugins/secure_login/functions.php
+%%SQUIRRELDIR%%/plugins/secure_login/README
+%%SQUIRRELDIR%%/plugins/secure_login/setup.php
+%%SQUIRRELDIR%%/plugins/secure_login/index.php
+%%SQUIRRELDIR%%/plugins/secure_login/version
+%%SQUIRRELDIR%%/plugins/secure_login/INSTALL
+%%SQUIRRELDIR%%/plugins/secure_login/config.php.sample
+@dirrm %%SQUIRRELDIR%%/plugins/secure_login
+@exec if [ -f %D/%%SQUIRRELDIR%%/config/config.php ]; then %D/%%SQUIRRELDIR%%/config/conf.pl --install-plugin newuser_wiz; fi