aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authordelphij <delphij@FreeBSD.org>2013-09-06 08:17:45 +0800
committerdelphij <delphij@FreeBSD.org>2013-09-06 08:17:45 +0800
commite2512535f3f9e3763965982f7f4001c13b8d4b5c (patch)
tree0a3a8f7f985d5a013df87579dc75504385a4aea9 /mail
parentb27798514bcda17a4f6307e157848efc6a192c51 (diff)
downloadfreebsd-ports-gnome-e2512535f3f9e3763965982f7f4001c13b8d4b5c.tar.gz
freebsd-ports-gnome-e2512535f3f9e3763965982f7f4001c13b8d4b5c.tar.zst
freebsd-ports-gnome-e2512535f3f9e3763965982f7f4001c13b8d4b5c.zip
Fix build.
Per ISO C++03 14.2/4: When the name of a member template specialization appears after . or -> in a postfix-expression, or after nested-name-specifier in a qualified-id, and the postfix-expression or qualified-id explicitly depends on a template-parameter (14.6.2), the member template name must be prefixed by the keyword template. Otherwise the name is assumed to name a non-template.
Diffstat (limited to 'mail')
-rw-r--r--mail/libvmime/Makefile2
-rw-r--r--mail/libvmime/files/patch-vmime__base.hpp11
2 files changed, 12 insertions, 1 deletions
diff --git a/mail/libvmime/Makefile b/mail/libvmime/Makefile
index 037aa8ab751e..5e69818fc199 100644
--- a/mail/libvmime/Makefile
+++ b/mail/libvmime/Makefile
@@ -3,7 +3,7 @@
PORTNAME= libvmime
PORTVERSION= 0.9.1
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= mail
MASTER_SITES= SF/vmime/vmime/0.9
diff --git a/mail/libvmime/files/patch-vmime__base.hpp b/mail/libvmime/files/patch-vmime__base.hpp
new file mode 100644
index 000000000000..eae3e285d0d3
--- /dev/null
+++ b/mail/libvmime/files/patch-vmime__base.hpp
@@ -0,0 +1,11 @@
+--- ./vmime/base.hpp.orig 2010-02-06 10:12:57.000000000 -0800
++++ ./vmime/base.hpp 2013-09-05 17:05:39.233608129 -0700
+@@ -252,7 +252,7 @@
+ template <class X, class Y>
+ ref <X> dynamicCast(ref <Y> y)
+ {
+- return y.dynamicCast <X>();
++ return y. template dynamicCast <X>();
+ }
+
+ } // vmime