aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2002-11-11 22:29:03 +0800
committerlioux <lioux@FreeBSD.org>2002-11-11 22:29:03 +0800
commite2d9cbd04b7460ccf38cdf4c1974807d9f11e8b2 (patch)
treee11c36db06d8d8c5deed6139b34197d954828995 /mail
parent006aa3e4891b5ebd169b3dc2d11a614e8c7c2a2c (diff)
downloadfreebsd-ports-gnome-e2d9cbd04b7460ccf38cdf4c1974807d9f11e8b2.tar.gz
freebsd-ports-gnome-e2d9cbd04b7460ccf38cdf4c1974807d9f11e8b2.tar.zst
freebsd-ports-gnome-e2d9cbd04b7460ccf38cdf4c1974807d9f11e8b2.zip
o Fix build to match recent updates in GNU auto* support in bsd.port.mk
o Deploy USE_REINPLACE instead of PERL o Fix warning messages in -CURRENT PR: 45212 Submitted by: maintainer
Diffstat (limited to 'mail')
-rw-r--r--mail/mutt/Makefile9
-rw-r--r--mail/mutt/files/patch-configure.in20
-rw-r--r--mail/mutt14/Makefile9
-rw-r--r--mail/mutt14/files/patch-configure.in20
4 files changed, 30 insertions, 28 deletions
diff --git a/mail/mutt/Makefile b/mail/mutt/Makefile
index b92de8b9820b..948ecd20c95a 100644
--- a/mail/mutt/Makefile
+++ b/mail/mutt/Makefile
@@ -60,7 +60,7 @@ WRKSRC= ${WRKDIR}/${DISTNAME:S/i$//}
USE_OPENSSL= yes
GNU_CONFIGURE= yes
USE_AUTOMAKE= yes # configure.in is patched by <PATCHFILES>
-AUTOMAKE_ARGS= --include-deps
+USE_REINPLACE= yes
CONFIGURE_TARGET=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CC="${CC} -I${LOCALBASE}/include" LDFLAGS=-L${LOCALBASE}/lib
CONFIGURE_ARGS= --enable-pop --enable-imap --enable-flock --disable-fcntl \
@@ -88,10 +88,11 @@ MAN5= mbox.5 muttrc.5
# this should be done automagically by aclocal but ....
# for now, this will have to do
pre-build:
- @${PERL} -pi -e "s/^(ACLOCAL = ).+/\1${ACLOCAL}/; s/^(AUTOCONF = ).+/\1${AUTOCONF}/; \
- s/^(AUTOMAKE = ).+/\1${AUTOMAKE}/; s/^(AUTOHEADER = ).+/\1${AUTOHEADER}/" \
+ ${REINPLACE_CMD} -E -e "s|^(ACLOCAL = ).+|\1${ACLOCAL}|" \
+ -e "s|^(AUTOCONF = ).+|\1${AUTOCONF}|" \
+ -e "s|^(AUTOMAKE = ).+|\1${AUTOMAKE}|" \
+ -e "s|^(AUTOHEADER = ).+|\1${AUTOHEADER}|" \
${BUILD_WRKSRC}/Makefile
- cd ${WRKSRC} && ${MAKE} keymap_defs.h
.if !defined(NOPORTDOCS)
post-build:
diff --git a/mail/mutt/files/patch-configure.in b/mail/mutt/files/patch-configure.in
index 20909e07a9a0..0b37933c1c62 100644
--- a/mail/mutt/files/patch-configure.in
+++ b/mail/mutt/files/patch-configure.in
@@ -1,5 +1,5 @@
---- configure.in.orig Fri Jun 21 14:52:03 2002
-+++ configure.in Fri Jun 21 14:54:07 2002
+--- configure.in.orig Mon Nov 11 14:11:26 2002
++++ configure.in Mon Nov 11 14:12:09 2002
@@ -515,7 +515,7 @@
AC_MSG_ERROR([SSL support is only useful with POP or IMAP support])
fi
@@ -18,12 +18,12 @@
LDFLAGS="$LDFLAGS -L$with_sasl/lib"
fi
-@@ -609,6 +609,8 @@
- [if test $enableval = yes; then
- AC_DEFINE(USE_FLOCK,1, [ Define to use flock() to lock mailboxes. ])
- fi])
-+
-+MUTTLIBS="$MUTTLIBS -lxpg4"
+@@ -625,7 +625,7 @@
+ fi])
- mutt_cv_fcntl=yes
- AC_ARG_ENABLE(fcntl, [ --disable-fcntl Do NOT use fcntl() to lock files ],
+ if test x$GCC = xyes -a $mutt_cv_warnings = yes; then
+- CFLAGS="-Wall -pedantic $CFLAGS"
++ CFLAGS="-Wall $CFLAGS"
+ fi
+
+ AC_ARG_ENABLE(nfs-fix, [ --enable-nfs-fix Work around an NFS with broken attributes caching ],
diff --git a/mail/mutt14/Makefile b/mail/mutt14/Makefile
index b92de8b9820b..948ecd20c95a 100644
--- a/mail/mutt14/Makefile
+++ b/mail/mutt14/Makefile
@@ -60,7 +60,7 @@ WRKSRC= ${WRKDIR}/${DISTNAME:S/i$//}
USE_OPENSSL= yes
GNU_CONFIGURE= yes
USE_AUTOMAKE= yes # configure.in is patched by <PATCHFILES>
-AUTOMAKE_ARGS= --include-deps
+USE_REINPLACE= yes
CONFIGURE_TARGET=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CC="${CC} -I${LOCALBASE}/include" LDFLAGS=-L${LOCALBASE}/lib
CONFIGURE_ARGS= --enable-pop --enable-imap --enable-flock --disable-fcntl \
@@ -88,10 +88,11 @@ MAN5= mbox.5 muttrc.5
# this should be done automagically by aclocal but ....
# for now, this will have to do
pre-build:
- @${PERL} -pi -e "s/^(ACLOCAL = ).+/\1${ACLOCAL}/; s/^(AUTOCONF = ).+/\1${AUTOCONF}/; \
- s/^(AUTOMAKE = ).+/\1${AUTOMAKE}/; s/^(AUTOHEADER = ).+/\1${AUTOHEADER}/" \
+ ${REINPLACE_CMD} -E -e "s|^(ACLOCAL = ).+|\1${ACLOCAL}|" \
+ -e "s|^(AUTOCONF = ).+|\1${AUTOCONF}|" \
+ -e "s|^(AUTOMAKE = ).+|\1${AUTOMAKE}|" \
+ -e "s|^(AUTOHEADER = ).+|\1${AUTOHEADER}|" \
${BUILD_WRKSRC}/Makefile
- cd ${WRKSRC} && ${MAKE} keymap_defs.h
.if !defined(NOPORTDOCS)
post-build:
diff --git a/mail/mutt14/files/patch-configure.in b/mail/mutt14/files/patch-configure.in
index 20909e07a9a0..0b37933c1c62 100644
--- a/mail/mutt14/files/patch-configure.in
+++ b/mail/mutt14/files/patch-configure.in
@@ -1,5 +1,5 @@
---- configure.in.orig Fri Jun 21 14:52:03 2002
-+++ configure.in Fri Jun 21 14:54:07 2002
+--- configure.in.orig Mon Nov 11 14:11:26 2002
++++ configure.in Mon Nov 11 14:12:09 2002
@@ -515,7 +515,7 @@
AC_MSG_ERROR([SSL support is only useful with POP or IMAP support])
fi
@@ -18,12 +18,12 @@
LDFLAGS="$LDFLAGS -L$with_sasl/lib"
fi
-@@ -609,6 +609,8 @@
- [if test $enableval = yes; then
- AC_DEFINE(USE_FLOCK,1, [ Define to use flock() to lock mailboxes. ])
- fi])
-+
-+MUTTLIBS="$MUTTLIBS -lxpg4"
+@@ -625,7 +625,7 @@
+ fi])
- mutt_cv_fcntl=yes
- AC_ARG_ENABLE(fcntl, [ --disable-fcntl Do NOT use fcntl() to lock files ],
+ if test x$GCC = xyes -a $mutt_cv_warnings = yes; then
+- CFLAGS="-Wall -pedantic $CFLAGS"
++ CFLAGS="-Wall $CFLAGS"
+ fi
+
+ AC_ARG_ENABLE(nfs-fix, [ --enable-nfs-fix Work around an NFS with broken attributes caching ],
freebsd-ports-gnome/commit/misc/Makefile?id=8d4441ba1606e0c5e9135f7815d7ba91c0d8d0f0'>Add p5-Asterisk-FastAGI - a perl module for FastAGI handling.sobomax2013-05-031-0/+1 * KDE/FreeBSD team presents KDE SC 4.10.1 ports!makc2013-03-271-0/+1 * 2013-03-13 misc/gopod: does not work with modern iPods anymorebapt2013-03-131-2/+0 * Remove expired, unmaintained ports:rene2013-03-061-3/+0 * - removal of non-essential meta portjgh2013-03-051-1/+0 * Connect qmetro and saaghar to the buildmakc2013-02-211-0/+2 * Text-mode less-like fb2 books reader, written on python.miwi2013-02-181-0/+1 * 2012-05-10 databases/hypertable: BROKEN for more than 6 monthbapt2013-01-061-1/+0 * 2012-10-20 misc/voltcraft304: No more public distfilesbapt2012-10-261-3/+0 * KDE thumbnail generator for the CHM file format.makc2012-10-031-0/+1 * Add compat9x after some people ask to itgarga2012-09-111-0/+1 * DAHDI 2.6.1 development version:fjoe2012-08-291-0/+1 * Remove expired ports:ak2012-08-201-2/+0 * Business::EDI is a class for generating U.N. EDI interchange objectsculot2012-08-191-0/+1 * 2012-07-13 misc/alevt: No more upstreambapt2012-07-161-1/+0 * New port: openr2fjoe2012-06-281-0/+1 * New port: libsupertonefjoe2012-06-261-0/+1 * Port for Various Freeswitch scripts.crees2012-05-271-0/+1 * KDE/FreeBSD team presents long awaited KDE SC 4.8.3!makc2012-05-251-0/+1 * Add pizzademo port for net/freeswitch-develcrees2012-05-211-0/+1 * Remove misc/freshmeat-submit as it was renamed to misc/freecode-submitcs2012-05-211-1/+0 * Add freecode-submit to Makefilecs2012-05-211-0/+1 * Remove expired unmaintained ports:rene2012-05-181-3/+0 * XDG-Menu is a ROX panel applet that displays applications menu button.miwi2012-05-181-0/+1 * readd php 5.3.13 and all its modules as php53*flo2012-05-161-0/+1 * - Upgrade to 3.3.1 after preserving 3.2.x askuriyama2012-05-151-0/+2 * 2012-05-10 archivers/php4-bz2: php4 is EOLedbapt2012-05-121-2/+0 * Remove expired port:rene2012-05-081-1/+0 * Re-import tkcron, a tk frontend to cron.cy2012-04-081-0/+1 * xmonad-log-applet is for Xmonad users who find the GNOME panel useful. Thepawel2012-03-061-0/+1 * Remove expired, unmaintained ports:rene2011-12-291-1/+0 * - Add p5-Geo-Coder-Geocoder-US 0.002sunpoet2011-12-061-0/+1 * Remove ports@ ports that have been DEPRECATED for at least 1 monthdougb2011-11-021-1/+0 * audio/mp3butler Depends on audio/p5-MusicBrainz-Client which is DEPRECATEDdougb2011-11-011-2/+0 * - Add p5-Geo-Coder-Many 0.28sunpoet2011-10-201-0/+1 * - Add p5-Geo-Coder-TomTom 0.03sunpoet2011-10-201-0/+1 * - Add p5-Geo-Coder-PlaceFinder 0.05sunpoet2011-10-201-0/+1 * - Add p5-Geo-Coder-Ovi 0.02sunpoet2011-10-201-0/+1 * - Add p5-Geo-Coder-OSM 0.02sunpoet2011-10-201-0/+1 * - Add p5-Geo-Coder-Navteq 0.03sunpoet2011-10-201-0/+1 * - Add p5-Geo-Coder-Multimap 0.01sunpoet2011-10-201-0/+1 * - Add p5-Geo-Coder-Mapquest 0.05sunpoet2011-10-201-0/+1 * - Add p5-Geo-Coder-Googlev3 0.10sunpoet2011-10-201-0/+1 * - Add p5-Geo-Coder-Bing 0.11sunpoet2011-10-201-0/+1 * The KDE/FreeBSD team is pleased to announce KDE Software Compilationavilla2011-10-171-2/+8 * Remove ports maintainted by ports@ which have passed their EXPIRATION_DATEdougb2011-10-091-1/+0 * 2011-09-01 korean/hlatexfonts-ocf: No more public distfilesbapt2011-09-071-1/+0 * Add compat8x, for i386 and amd64, repocopied from compat7xgarga2011-08-311-0/+1 * Bot::Training::StarCraft provides starcraft.trn training data for Bot::Training.culot2011-08-091-0/+1 * Bye bye abandonwares (part 4)bapt2011-08-011-3/+0 * Remove this DEPRECATED port as it was replaced by misc/logsurfer+zi2011-07-291-1/+0 * New port: misc/logsurfer+zi2011-07-291-0/+1 * Provides megahal.trn training data for Bot::Trainingcrees2011-07-281-0/+1 * Markov bots like Hailo and AI::MegaHAL are fun. But to get them working youaz2011-07-241-0/+1 * DigiTemp is a simple to use console application for reading values frommiwi2011-06-261-0/+1 * remove unmaintained expired ports from miscbapt2011-05-021-17/+0 * Remove most expired ports:rene2011-04-191-1/+0 * Split dahdi port into two parts:fjoe2011-04-191-0/+1