aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authoreik <eik@FreeBSD.org>2004-07-22 23:39:30 +0800
committereik <eik@FreeBSD.org>2004-07-22 23:39:30 +0800
commite31c3f934cb87a75f9a6ba4e3e427ee5e988de76 (patch)
treeb5dc863f1ff8b109fe93643cc0c30a41008ce391 /mail
parentb9ebd28aec53b33070b8de5eebdbc5c3d68aa3c2 (diff)
downloadfreebsd-ports-gnome-e31c3f934cb87a75f9a6ba4e3e427ee5e988de76.tar.gz
freebsd-ports-gnome-e31c3f934cb87a75f9a6ba4e3e427ee5e988de76.tar.zst
freebsd-ports-gnome-e31c3f934cb87a75f9a6ba4e3e427ee5e988de76.zip
Update to Exim 4.41 + exiscan-acl 24
Note that this port uses libsrs2, not libsrs_alt as documented in exiscan-acl-spec
Diffstat (limited to 'mail')
-rw-r--r--mail/exim/Makefile4
-rw-r--r--mail/exim/distinfo8
-rw-r--r--mail/exim/files/xpatch-exiscan246
3 files changed, 11 insertions, 47 deletions
diff --git a/mail/exim/Makefile b/mail/exim/Makefile
index 4687393ced69..9243e86d7f06 100644
--- a/mail/exim/Makefile
+++ b/mail/exim/Makefile
@@ -27,8 +27,8 @@ PATCH_DIST_STRIP= -p1
EXTRA_PATCHES+= ${PATCHDIR}/xpatch-exiscan2
.endif
-EXIM_VERSION= 4.40
-EXISCAN_VERSION=23
+EXIM_VERSION= 4.41
+EXISCAN_VERSION=24
.if !defined(EXIMON_ONLY)
.if defined(PKGNAMESUFFIX)
diff --git a/mail/exim/distinfo b/mail/exim/distinfo
index d462acb0635c..0fe08737374f 100644
--- a/mail/exim/distinfo
+++ b/mail/exim/distinfo
@@ -1,4 +1,4 @@
-MD5 (exim/exim-4.40.tar.bz2) = af6db81a995046e1e30bcfda6ed0b357
-SIZE (exim/exim-4.40.tar.bz2) = 1340622
-MD5 (exim/exiscan-acl-4.40-23.patch.bz2) = c068c157b7e885bd4ce79d29d4f38469
-SIZE (exim/exiscan-acl-4.40-23.patch.bz2) = 79849
+MD5 (exim/exim-4.41.tar.bz2) = 769c8b03cdefcc98c9707dde965c96f1
+SIZE (exim/exim-4.41.tar.bz2) = 1340206
+MD5 (exim/exiscan-acl-4.41-24.patch.bz2) = 13eaeb6c5def7cdf4c9cea6d82f85bd8
+SIZE (exim/exiscan-acl-4.41-24.patch.bz2) = 80544
diff --git a/mail/exim/files/xpatch-exiscan2 b/mail/exim/files/xpatch-exiscan2
index 42ef6c047293..0bb651fe385d 100644
--- a/mail/exim/files/xpatch-exiscan2
+++ b/mail/exim/files/xpatch-exiscan2
@@ -1,39 +1,3 @@
-diff -u doc/exiscan-acl-spec.txt doc/exiscan-acl-spec.txt
---- doc/exiscan-acl-spec.txt Sat Jul 17 11:12:00 2004
-+++ doc/exiscan-acl-spec.txt Sat Jul 17 12:15:36 2004
-@@ -12,7 +12,7 @@
- - Antivirus using 3rd party scanners.
- - Anti-spam using SpamAssassin.
- - Anti-spam using Brightmail Antispam.
-- - SPF support via the libspf_alt library
-+ - SPF support via the libspf2 library
- - Regular expression match against headers, bodies, raw
- MIME parts and decoded MIME parts.
-
-@@ -1087,9 +1087,9 @@
- need to care. If you don't know what that means, visit the
- above mentioned website.
-
--SPF support is added via the libspf_alt library. Visit
-+SPF support is added via the libspf2 library. Visit
-
-- http://www.midwestcs.com/spf/libspf-alt/
-+ http://libspf2.org/
-
- to obtain a copy, then compile and install it. By default,
- this will put headers in /usr/local/include and the static
-@@ -1099,9 +1099,9 @@
- Local/Makefile:
-
- CFLAGS=-DSPF -I/usr/local/include
--EXTRALIBS_EXIM=-L/usr/local/lib -lspf_alt
-+EXTRALIBS_EXIM=-L/usr/local/lib -lspf2
-
--This assumes that the libspf_alt files are installed in
-+This assumes that the libspf2 files are installed in
- their default locations.
-
- You can now run SPF checks in incoming SMTP by using the "spf"
diff -u scripts/MakeLinks scripts/MakeLinks
--- scripts/MakeLinks Sat Jul 17 11:12:00 2004
+++ scripts/MakeLinks Sat Jul 17 11:34:48 2004
@@ -164,7 +128,7 @@ diff -u src/routers/redirect.c src/routers/redirect.c
- usesrs = expand_check_condition(ob->srs_condition, "srs_condition expansion failed", NULL);
-
- if(usesrs)
-- if(Ustrcmp(ob->srs, "reverse") == 0)
+- if(Ustrcmp(ob->srs, "reverse") == 0 || Ustrcmp(ob->srs, "reverseandforward") == 0)
- {
- uschar *res;
- int n_srs;
@@ -180,7 +144,7 @@ diff -u src/routers/redirect.c src/routers/redirect.c
- DEBUG(D_any)
- debug_printf("SRS: Recipient '%s' rewriteen to '%s'\n", srs_orig_recipient, srs_recipient);
- }
-+ if (Ustrcmp(ob->srs, "reverse") == 0)
++ if (Ustrcmp(ob->srs, "reverse") == 0 || Ustrcmp(ob->srs, "reverseandforward") == 0)
+ {
+ uschar *res;
+ int ret;
@@ -218,7 +182,7 @@ diff -u src/routers/redirect.c src/routers/redirect.c
- usesrs = expand_check_condition(ob->srs_condition, "srs_condition expansion failed", NULL);
-
- if(usesrs)
-- if(Ustrcmp(ob->srs, "forward") == 0 )// && !verify)
+- if((Ustrcmp(ob->srs, "forward") == 0 || Ustrcmp(ob->srs, "reverseandforward") == 0) && !verify)
- {
- uschar *res;
- int n_srs;
@@ -232,7 +196,7 @@ diff -u src/routers/redirect.c src/routers/redirect.c
- sender_address = res;
- DEBUG(D_any)
- debug_printf("SRS: Sender '%s' rewritten to '%s'\n", srs_orig_sender, sender_address);
-+ if ((Ustrcmp(ob->srs, "forward") == 0) && !verify )
++ if ((Ustrcmp(ob->srs, "forward") == 0 || Ustrcmp(ob->srs, "reverseandforward") == 0) && !verify )
+ {
+ uschar *res;
+ int ret;
@@ -285,7 +249,7 @@ diff -u src/srs.c src/srs.c
/* This file is an extension to Exim and is not part of the standard
Exim distribution */
--/* ©2004 Miles Wilton <miles@mirtol.com> */
+-/* (C)2004 Miles Wilton <miles@mirtol.com> */
+/* (c) 2004 Shevek
+ * Based on work by Miles Wilton <miles@mirtol.com>
+ * Updated by Shevek to use libsrs2