aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorsf <sf@FreeBSD.org>2003-07-14 10:41:33 +0800
committersf <sf@FreeBSD.org>2003-07-14 10:41:33 +0800
commite8da58d6a01de0af819cb8c26f60a466104ba4a2 (patch)
treef591efe2b42bee79db3d435fa27e0dd12c169843 /mail
parent5a66051231c94244f89e4fb03c39494d2b0ed1be (diff)
downloadfreebsd-ports-gnome-e8da58d6a01de0af819cb8c26f60a466104ba4a2.tar.gz
freebsd-ports-gnome-e8da58d6a01de0af819cb8c26f60a466104ba4a2.tar.zst
freebsd-ports-gnome-e8da58d6a01de0af819cb8c26f60a466104ba4a2.zip
get rid of libgnugetopt dependency for -CURRENT,
use USE_GETOPT_LONG instead. use getopt_long() instead of getopt_long_only(). Obtained from: NetBSD
Diffstat (limited to 'mail')
-rw-r--r--mail/ifile/Makefile8
-rw-r--r--mail/ifile/files/patch-Makefile.in11
-rw-r--r--mail/ifile/files/patch-argp_argp.h11
3 files changed, 24 insertions, 6 deletions
diff --git a/mail/ifile/Makefile b/mail/ifile/Makefile
index e3425f009e76..cbba689e1a6c 100644
--- a/mail/ifile/Makefile
+++ b/mail/ifile/Makefile
@@ -7,21 +7,17 @@
PORTNAME= ifile
PORTVERSION= 1.3.2
+PORTREVISION= 1
CATEGORIES= mail textproc
MASTER_SITES= http://savannah.nongnu.org/download/ifile/default.pkg/${PORTVERSION}/
MAINTAINER= david+ports@bushong.net
COMMENT= An application of machine learning to e-mail filtering
-LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
-
+USE_GETOPT_LONG=yes
USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
MAN1= ifile.1
-post-patch:
- @${REINPLACE_CMD} -e 's,-lm,-lm -L${LOCALBASE}/lib -lgnugetopt,' \
- ${WRKSRC}/Makefile.in
-
.include <bsd.port.mk>
diff --git a/mail/ifile/files/patch-Makefile.in b/mail/ifile/files/patch-Makefile.in
new file mode 100644
index 000000000000..eaf6dcf7bcff
--- /dev/null
+++ b/mail/ifile/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig Tue Jun 10 23:09:27 2003
++++ Makefile.in Mon Jul 7 06:50:51 2003
+@@ -46,7 +46,7 @@
+ CFLAGS = @CFLAGS@
+ CPPFLAGS = @CPPFLAGS@
+ INCLUDEFLAGS =
+-LDFLAGS =
++LDFLAGS = @LDFLAGS@
+
+ prefix = @prefix@
+ exec_prefix = @exec_prefix@
diff --git a/mail/ifile/files/patch-argp_argp.h b/mail/ifile/files/patch-argp_argp.h
new file mode 100644
index 000000000000..d9493d2995b2
--- /dev/null
+++ b/mail/ifile/files/patch-argp_argp.h
@@ -0,0 +1,11 @@
+--- argp/argp.h.orig Tue Jun 10 23:09:27 2003
++++ argp/argp.h Mon Jul 7 04:31:41 2003
+@@ -352,7 +352,7 @@
+ #define ARGP_NO_EXIT 0x20
+
+ /* Use the gnu getopt `long-only' rules for parsing arguments. */
+-#define ARGP_LONG_ONLY 0x40
++#define ARGP_LONG_ONLY 0x00
+
+ /* Turns off any message-printing/exiting options. */
+ #define ARGP_SILENT (ARGP_NO_EXIT | ARGP_NO_ERRS | ARGP_NO_HELP)