aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authoritetcu <itetcu@FreeBSD.org>2006-11-12 23:56:58 +0800
committeritetcu <itetcu@FreeBSD.org>2006-11-12 23:56:58 +0800
commiteb9813c4014eb9661eb90daabae9aee701aca306 (patch)
treeaf873493f0c8f6a54126f57d3c296353325f4ac8 /mail
parent9b381aac1ec87ad4d8c7882227b15932f12e6f81 (diff)
downloadfreebsd-ports-gnome-eb9813c4014eb9661eb90daabae9aee701aca306.tar.gz
freebsd-ports-gnome-eb9813c4014eb9661eb90daabae9aee701aca306.tar.zst
freebsd-ports-gnome-eb9813c4014eb9661eb90daabae9aee701aca306.zip
- added safecat as LDA [1]
- give user the possibility to configure where dspam.conf is [1] - bump PORTVERSION for OPTIONS chage for [1] - display UPDATING entry smarter [2] Submitted by: Emil Isberg <emil@pyttemjuk.se> [1] Phil Pennock <pdp@spodhuis.demon.nl> [2] (suggestion by vd@)
Diffstat (limited to 'mail')
-rw-r--r--mail/dspam/Makefile26
-rw-r--r--mail/dspam/files/UPDATING11
2 files changed, 28 insertions, 9 deletions
diff --git a/mail/dspam/Makefile b/mail/dspam/Makefile
index 4d591e294274..e0665ca9e6cb 100644
--- a/mail/dspam/Makefile
+++ b/mail/dspam/Makefile
@@ -7,13 +7,12 @@
#
# Note to commiters: If don't commit a maintainer patch and as a result PKGNAME
-# or user variables (WITH*) changes please add an entry in ${FILESDIR}/UPDATING and
-# modify _UPD_LINE_NO=(no_of_added_lines-1) in this Makefile.
-# Else the port will be broken. Thanks.
+# or user variables (WITH*) changes please add an entry in ${FILESDIR}/UPDATING
+# Thanks.
PORTNAME= dspam
PORTVERSION= ${PORTVER_MAJ}${SNAP_DATE}
-#PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= # set later
@@ -22,9 +21,8 @@ COMMENT= Bayesian spam filter - stable maintenance version
PORTVER_MAJ= 3.6.8
#SNAP_DATE= .20060421.2101
-_UPD_LINE_NO= 13
-MIN_OPTIONS_VER= ${PORTNAME}-3.6.6
+MIN_OPTIONS_VER= ${PORTNAME}-3.6.8_1
.ifdef(SNAP_DATE)
MASTER_SITES= http://sce-tindy.tecnik93.com/FreeBSD/ports/${PORTNAME}/sources/ \
@@ -120,6 +118,7 @@ DSPAM_MODE?= 4510
DSPAM_OWNER?= root
DSPAM_GROUP?= mail
+DSPAM_ETC?= ${LOCALBASE}/etc
DSPAM_HOME?= ${_VAR_DIR}/db/dspam
DSPAM_HOME_OWNER?= ${DSPAM_OWNER}
DSPAM_HOME_GROUP?= ${DSPAM_GROUP}
@@ -127,6 +126,7 @@ DSPAM_HOME_MODE?= 0770
.include <bsd.port.pre.mk>
+CONFIGURE_ARGS+= --sysconfdir=${DSPAM_ETC}
CONFIGURE_ARGS+= --with-logdir=${LOG_DIR}
PLIST_SUB+= LOG_DIR=${LOG_DIR}
@@ -339,7 +339,7 @@ CONFIGURE_ARGS+= --enable-domain-scale
.endif
# add one 'o' here for each new LDA
-LDA_TOTAL_COUNT= oooooooo # 8
+LDA_TOTAL_COUNT= ooooooooo # 9
LDA_COUNT= ${LDA_TOTAL_COUNT}
.if defined(WITH_CYRUS21_LDA)
@@ -383,6 +383,12 @@ CONFIGURE_ARGS+= --with-delivery-agent='${LOCALBASE}/bin/procmail'
LDA_COUNT:= ${LDA_COUNT:S/o//}
.endif
+.ifdef(WITH_SAFECAT_LDA)
+RUN_DEPENDS+= safecat:${PORTSDIR}/sysutils/safecat
+CONFIGURE_ARGS+= --with-delivery-agent='${LOCALBASE}/safecat tmp new'
+LDA_COUNT:= ${LDA_COUNT:S/o//}
+.endif
+
.ifdef(WITH_SENDMAIL_LDA) && exists(/usr/sbin/sendmail)
CONFIGURE_ARGS+= --with-delivery-agent=/usr/sbin/sendmail
LDA_COUNT:= ${LDA_COUNT:S/o//}
@@ -455,7 +461,8 @@ pre-everything::
.ifndef(MAINT)
@${ECHO_CMD} ""
@${ECHO_CMD} "Last ${FILESDIR}/UPDATING entry:"
- @${GREP} -B 1 -A ${_UPD_LINE_NO} ${PKGNAME} ${FILESDIR}/UPDATING
+ @${ECHO_CMD} "###########################################################################"
+ @${SED} -n < ${FILESDIR}/UPDATING "/^# ${PKGNAME}/,/^#####/p"
@${ECHO_CMD} ""
@sleep 5
.endif
@@ -469,6 +476,7 @@ pre-extract: check-options-version
@${ECHO_CMD} "DSPAM_OWNER=${DSPAM_OWNER} (default: root)"
@${ECHO_CMD} "DSPAM_GROUP=${DSPAM_GROUP} (default: mail)"
@${ECHO_CMD} "DSPAM_MODE=${DSPAM_MODE}"
+ @${ECHO_CMD} "DSPAM_ETC=${DSPAM_ETC} (default: ${LOCALBASE}/etc"
@${ECHO_CMD} "DSPAM_HOME=${DSPAM_HOME} (default: ${_VAR_DIR}/db/dspam)"
@${ECHO_CMD} "DSPAM_HOME_OWNER=${DSPAM_HOME_OWNER}"
@${ECHO_CMD} "DSPAM_HOME_GROUP=${DSPAM_HOME_GROUP}"
@@ -505,7 +513,7 @@ pre-configure:
@${ECHO_CMD}
.if !( ${LDA_TOTAL_COUNT:S/o//}==${LDA_COUNT} || ${LDA_TOTAL_COUNT}==${LDA_COUNT} )
@${ECHO_CMD} "You can only use one local delivery agent at once."
- @${ECHO_CMD} "See ${LOCALBASE}/etc/dspam.conf for how to chage it at run time."
+ @${ECHO_CMD} "See ${DSPAM_ETC}/dspam.conf for how to chage it at run time."
@${FALSE}
.endif
.if ${_DBDRV}==""
diff --git a/mail/dspam/files/UPDATING b/mail/dspam/files/UPDATING
index 3a0e7a3cfcf8..de903f8f59cf 100644
--- a/mail/dspam/files/UPDATING
+++ b/mail/dspam/files/UPDATING
@@ -17,6 +17,17 @@ in the port directory:
make extract; more `find . -type f -maxdepth 2 -name UPGRADING`
###########################################################################
+# dspam-3.6.8_1
+#
+
+Port changes:
+- added safecat as LDA [1]
+- give user the possibility to configure where dspam.conf is [1]
+
+[1] patch from Emil Isberg <emil@pyttemjuk.se> [1]
+
+
+###########################################################################
# dspam-3.6.8
#