aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorjohans <johans@FreeBSD.org>2006-06-26 03:58:41 +0800
committerjohans <johans@FreeBSD.org>2006-06-26 03:58:41 +0800
commitf33661da5771c7552915225892ade333a5ae07f8 (patch)
treeb4571c584b74499d460c7a949fa1db65b8733c23 /mail
parentd78dab3e464f2ae5a0c5224a214ed82fdb627a05 (diff)
downloadfreebsd-ports-gnome-f33661da5771c7552915225892ade333a5ae07f8.tar.gz
freebsd-ports-gnome-f33661da5771c7552915225892ade333a5ae07f8.tar.zst
freebsd-ports-gnome-f33661da5771c7552915225892ade333a5ae07f8.zip
- Update to 4.0.9
- Assign submitter of PR as maintainer - Remove IPv6 patch PR: 97641 Submitted by: Doug Hardie Approved by: flz (mentor)
Diffstat (limited to 'mail')
-rw-r--r--mail/qpopper/Makefile16
-rw-r--r--mail/qpopper/distinfo12
-rw-r--r--mail/qpopper/files/patch-popper_genpath.c26
-rw-r--r--mail/qpopper/pkg-descr4
4 files changed, 43 insertions, 15 deletions
diff --git a/mail/qpopper/Makefile b/mail/qpopper/Makefile
index 6f4333dfb656..9d73b4bcb5d4 100644
--- a/mail/qpopper/Makefile
+++ b/mail/qpopper/Makefile
@@ -6,16 +6,17 @@
#
PORTNAME= qpopper
-PORTVERSION= 4.0.8
+PORTVERSION= 4.0.9
CATEGORIES= mail ipv6
MASTER_SITES= ftp://ftp.qualcomm.com/eudora/servers/unix/popper/ \
http://core.ring.gr.jp/archives/net/mail/qpopper/
DISTNAME= ${PORTNAME}${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= bc979@lafn.org
COMMENT= Berkeley POP 3 server (now maintained by Qualcomm)
USE_AUTOTOOLS= autoconf:259
+USE_REINPLACE= yes
USE_OPENSSL= yes
CONFIGURE_ENV= LIBS="-lcrypt -lmd -lutil -L${LOCALBASE}/lib" \
OS_DEFS="-DSETPROCTITLE ${OS_DEFS}"
@@ -46,7 +47,6 @@ OPTIONS= APOP_ONLY "build with APOP authentication only" off \
APOP "build with APOP" on \
DOCUMENTATION "install pdf documentation" off \
DRAC "build with Dynamic Relay Authorization" off \
- IPV6 "build with IPv6 support" on \
FULL_POPD_DEBUG "build with more verbose debugging" off \
PAM "build with PAM authentication" off \
POPPASSD "build the poppassd daemon" off \
@@ -63,11 +63,11 @@ OPTIONS= APOP_ONLY "build with APOP authentication only" off \
WITHOUT_IPV6= yes
.endif
-.if !defined(WITHOUT_IPV6)
-PATCH_SITES= http://www.imasy.or.jp/~ume/ipv6/
-PATCHFILES= qpopper4.0.8-ipv6-20050515.diff.gz
-PATCH_DIST_STRIP= -p1
-.endif
+# .if !defined(WITHOUT_IPV6)
+# PATCH_SITES= http://www.imasy.or.jp/~ume/ipv6/
+# PATCHFILES= qpopper4.0.8-ipv6-20050515.diff.gz
+# PATCH_DIST_STRIP= -p1
+# .endif
.if defined(WITHOUT_APOP)
QPOPAUTH= "@comment "
diff --git a/mail/qpopper/distinfo b/mail/qpopper/distinfo
index 29788ee17829..21077c8196d1 100644
--- a/mail/qpopper/distinfo
+++ b/mail/qpopper/distinfo
@@ -1,6 +1,6 @@
-MD5 (qpopper4.0.8.tar.gz) = 8dd2d0c72bd3821eac8c52b9edb3f422
-SHA256 (qpopper4.0.8.tar.gz) = 2a166d70ab42bbe5a605707f0bf0416052df15a3c88e090fcb9ad7ffe07714f9
-SIZE (qpopper4.0.8.tar.gz) = 2766902
-MD5 (qpopper4.0.8-ipv6-20050515.diff.gz) = ece052733db5b780fa76ce6e5bc57719
-SHA256 (qpopper4.0.8-ipv6-20050515.diff.gz) = b45b671fb1e11d9285d5195ca6e5b2358c171176970287045da50b0632ab9c94
-SIZE (qpopper4.0.8-ipv6-20050515.diff.gz) = 11479
+MD5 (qpopper4.0.9.tar.gz) = de2cd15f95cfd00d0d080fd16287acad
+SHA256 (qpopper4.0.9.tar.gz) = c98830ba61c20c38d64c2c2e84fe7f21642b25cfc15f6257f4cad474d01d4c5d
+SIZE (qpopper4.0.9.tar.gz) = 2767261
+# MD5 (qpopper4.0.8-ipv6-20050515.diff.gz) = ece052733db5b780fa76ce6e5bc57719
+# SHA256 (qpopper4.0.8-ipv6-20050515.diff.gz) = b45b671fb1e11d9285d5195ca6e5b2358c171176970287045da50b0632ab9c94
+# SIZE (qpopper4.0.8-ipv6-20050515.diff.gz) = 11479
diff --git a/mail/qpopper/files/patch-popper_genpath.c b/mail/qpopper/files/patch-popper_genpath.c
new file mode 100644
index 000000000000..61ac40556fb9
--- /dev/null
+++ b/mail/qpopper/files/patch-popper_genpath.c
@@ -0,0 +1,26 @@
+--- popper/genpath.c.orig Thu Mar 9 14:32:37 2006
++++ popper/genpath.c Sat May 13 17:40:25 2006
+@@ -133,7 +133,10 @@
+ break;
+
+ case GNPH_POP: /* .pop file */
+- len1 = strlcpy ( pszDrop, p->pCfg_temp_dir, iDropLen );
++ if (p->bHome_dir_misc == TRUE)
++ len1 = strlcpy (pszDrop, pw->pw_dir, iDropLen );
++ else
++ len1 = strlcpy (pszDrop, p->pCfg_temp_dir, iDropLen );
+ len2 = strlcat ( pszDrop, "/", iDropLen );
+ break;
+
+@@ -143,7 +146,10 @@
+ break;
+
+ case GNPH_CACHE: /* .cache file */
+- len1 = strlcpy ( pszDrop, p->pCfg_cache_dir, iDropLen );
++ if (p->bHome_dir_misc == TRUE)
++ len1 = strlcpy (pszDrop, pw->pw_dir, iDropLen );
++ else
++ len1 = strlcpy (pszDrop, p->pCfg_cache_dir, iDropLen );
+ len2 = strlcat ( pszDrop, "/", iDropLen );
+ break;
+
diff --git a/mail/qpopper/pkg-descr b/mail/qpopper/pkg-descr
index 690c374d3561..969e00044bf7 100644
--- a/mail/qpopper/pkg-descr
+++ b/mail/qpopper/pkg-descr
@@ -1,5 +1,7 @@
This is a POP 3 server useful for dealing with remote mail reader clients
-such as Eudora.
+such as Eudora. One of the 4.1a2 patches has been included so that
+home-dir-misc actually works. The option and patch for IPv6 have been removed
+as it they are not up to date for 4.0.9.
Don't forget to edit /etc/inetd.conf to enable the server after installation.