aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2013-10-20 04:03:52 +0800
committersunpoet <sunpoet@FreeBSD.org>2013-10-20 04:03:52 +0800
commitf3fcd4ddd051b430faf3df24ca8bf6ba4679b77d (patch)
tree463b97df127514be9c63581645d1013f80496b5e /mail
parentb0b770a44d59cea2ec44cc4395ac10fe42d6a9f8 (diff)
downloadfreebsd-ports-gnome-f3fcd4ddd051b430faf3df24ca8bf6ba4679b77d.tar.gz
freebsd-ports-gnome-f3fcd4ddd051b430faf3df24ca8bf6ba4679b77d.tar.zst
freebsd-ports-gnome-f3fcd4ddd051b430faf3df24ca8bf6ba4679b77d.zip
- Make postgrey work with Perl 5.18
- Bump PORTREVISION for package change PR: ports/181291 Reference: https://github.com/schweikert/postgrey/commit/569dd044840a075127ddcf9d92c7791677d118e2 Submitted by: Yasuhiro KIMURA <yasu@utahime.org> Approved by: Darren Pilgrim <ports.maintainer@evilphi.com> (maintainer)
Diffstat (limited to 'mail')
-rw-r--r--mail/postgrey/Makefile2
-rw-r--r--mail/postgrey/files/patch-postgrey19
2 files changed, 20 insertions, 1 deletions
diff --git a/mail/postgrey/Makefile b/mail/postgrey/Makefile
index f248ac004a0d..a322a885fa14 100644
--- a/mail/postgrey/Makefile
+++ b/mail/postgrey/Makefile
@@ -3,7 +3,7 @@
PORTNAME= postgrey
PORTVERSION= 1.34
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= mail
MASTER_SITES= http://postgrey.schweikert.ch/pub/ \
http://postgrey.schweikert.ch/pub/old/
diff --git a/mail/postgrey/files/patch-postgrey b/mail/postgrey/files/patch-postgrey
new file mode 100644
index 000000000000..98260f1e4cbe
--- /dev/null
+++ b/mail/postgrey/files/patch-postgrey
@@ -0,0 +1,19 @@
+--- postgrey.orig 2011-05-05 04:54:15.000000000 +0800
++++ postgrey 2013-10-20 01:07:50.744835568 +0800
+@@ -557,6 +557,16 @@
+ if($opt{dbdir}) {
+ $opt{dbdir} =~ /^(.*)$/; $opt{dbdir} = $1;
+ }
++ # untaint what is given on --pidfile. It is not security sensitive since
++ # it is provided by the admin
++ if($opt{pidfile}) {
++ $opt{pidfile} =~ /^(.*)$/; $opt{pidfile} = $1;
++ }
++ # untaint what is given on --inet. It is not security sensitive since
++ # it is provided by the admin
++ if($opt{inet}) {
++ $opt{inet} =~ /^(.*)$/; $opt{inet} = $1;
++ }
+
+ # determine proper "logsock" for Sys::Syslog
+ my $syslog_logsock;