aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authortz <tz@FreeBSD.org>2018-12-07 15:53:14 +0800
committertz <tz@FreeBSD.org>2018-12-07 15:53:14 +0800
commitf7b7b59198cf1a2d0013f2b55c9cdb801c0e0fb6 (patch)
tree1f9be04b3912a634a7f486db2f939b0b98e3f835 /mail
parentc2230226b8843eb0cb8a3ed80d9f12eb1d40592a (diff)
downloadfreebsd-ports-gnome-f7b7b59198cf1a2d0013f2b55c9cdb801c0e0fb6.tar.gz
freebsd-ports-gnome-f7b7b59198cf1a2d0013f2b55c9cdb801c0e0fb6.tar.zst
freebsd-ports-gnome-f7b7b59198cf1a2d0013f2b55c9cdb801c0e0fb6.zip
lang/php71: Upgrade from 7.1.24 to 7.1.25
Changelog: http://www.php.net/ChangeLog-7.php#7.1.25 MFH: 2018Q4
Diffstat (limited to 'mail')
-rw-r--r--mail/php71-imap/Makefile1
-rw-r--r--mail/php71-imap/files/patch-php__imap.c40
-rw-r--r--mail/php71-imap/files/patch-php__imap.h10
3 files changed, 0 insertions, 51 deletions
diff --git a/mail/php71-imap/Makefile b/mail/php71-imap/Makefile
index 076bb217f5af..7c56e35e9865 100644
--- a/mail/php71-imap/Makefile
+++ b/mail/php71-imap/Makefile
@@ -1,7 +1,6 @@
# $FreeBSD$
CATEGORIES= mail
-PORTREVISION= 1
MASTERDIR= ${.CURDIR}/../../lang/php71
diff --git a/mail/php71-imap/files/patch-php__imap.c b/mail/php71-imap/files/patch-php__imap.c
deleted file mode 100644
index faa12adafa16..000000000000
--- a/mail/php71-imap/files/patch-php__imap.c
+++ /dev/null
@@ -1,40 +0,0 @@
---- php_imap.c.orig 2018-09-11 22:12:36 UTC
-+++ php_imap.c
-@@ -562,6 +562,15 @@ static const zend_module_dep imap_deps[]
- };
- /* }}} */
-
-+
-+/* {{{ PHP_INI
-+ */
-+PHP_INI_BEGIN()
-+STD_PHP_INI_BOOLEAN("imap.enable_insecure_rsh", "0", PHP_INI_SYSTEM, OnUpdateBool, enable_rsh, zend_imap_globals, imap_globals)
-+PHP_INI_END()
-+/* }}} */
-+
-+
- /* {{{ imap_module_entry
- */
- zend_module_entry imap_module_entry = {
-@@ -835,6 +844,8 @@ PHP_MINIT_FUNCTION(imap)
- {
- unsigned long sa_all = SA_MESSAGES | SA_RECENT | SA_UNSEEN | SA_UIDNEXT | SA_UIDVALIDITY;
-
-+ REGISTER_INI_ENTRIES();
-+
- #ifndef PHP_WIN32
- mail_link(&unixdriver); /* link in the unix driver */
- mail_link(&mhdriver); /* link in the mh driver */
-@@ -1052,6 +1063,12 @@ PHP_MINIT_FUNCTION(imap)
- GC_TEXTS texts
- */
-
-+ if (!IMAPG(enable_rsh)) {
-+ /* disable SSH and RSH, see https://bugs.php.net/bug.php?id=77153 */
-+ mail_parameters (NIL, SET_RSHTIMEOUT, 0);
-+ mail_parameters (NIL, SET_SSHTIMEOUT, 0);
-+ }
-+
- le_imap = zend_register_list_destructors_ex(mail_close_it, NULL, "imap", module_number);
- return SUCCESS;
- }
diff --git a/mail/php71-imap/files/patch-php__imap.h b/mail/php71-imap/files/patch-php__imap.h
deleted file mode 100644
index f27f888f2ee7..000000000000
--- a/mail/php71-imap/files/patch-php__imap.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- php_imap.h.orig 2018-09-11 22:12:36 UTC
-+++ php_imap.h
-@@ -214,6 +214,7 @@ ZEND_BEGIN_MODULE_GLOBALS(imap)
- #endif
- /* php_stream for php_mail_gets() */
- php_stream *gets_stream;
-+ zend_bool enable_rsh;
- ZEND_END_MODULE_GLOBALS(imap)
-
- #ifdef ZTS