aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2011-10-06 00:18:03 +0800
committerpawel <pawel@FreeBSD.org>2011-10-06 00:18:03 +0800
commitfe177a70a5f38d46d2ead1b3a9f133d3ec07677b (patch)
tree209be96cb698bc19d76c05a1162777698a61ced3 /mail
parent3a4244701486b0f35e133abd93e2245311dbbfef (diff)
downloadfreebsd-ports-gnome-fe177a70a5f38d46d2ead1b3a9f133d3ec07677b.tar.gz
freebsd-ports-gnome-fe177a70a5f38d46d2ead1b3a9f133d3ec07677b.tar.zst
freebsd-ports-gnome-fe177a70a5f38d46d2ead1b3a9f133d3ec07677b.zip
Mailtray is a Python program that displays a tray icon which informs you when
you have new email. It's simple, easy, fairly environment-independent, and "just works" without tons of (Gnome|KDE|..) dependencies. WWW: http://code.google.com/p/mailtray/ PR: ports/161114 Submitted by: Martin Tournoij <martin@arp242.net> Approved by: miwi, wen (mentors implicit)
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/mailtray/Makefile22
-rw-r--r--mail/mailtray/distinfo2
-rw-r--r--mail/mailtray/pkg-descr7
-rw-r--r--mail/mailtray/pkg-plist8
5 files changed, 40 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index 769e21cf83e9..8dcd18b45841 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -259,6 +259,7 @@
SUBDIR += mailscanner
SUBDIR += mailscanner-mrtg
SUBDIR += mailsync
+ SUBDIR += mailtray
SUBDIR += mailx
SUBDIR += mairix
SUBDIR += majordomo
diff --git a/mail/mailtray/Makefile b/mail/mailtray/Makefile
new file mode 100644
index 000000000000..c0dc275d5f0b
--- /dev/null
+++ b/mail/mailtray/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: sysutils/mailtray
+# Date created: 2011-09-28
+# Whom: Martin Tournoij <martin@arp242.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mailtray
+PORTVERSION= 1.4
+CATEGORIES= mail python
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+
+MAINTAINER= martin@arp242.net
+COMMENT= Display email status in tray
+
+USE_GNOME= pygtk2
+USE_PYTHON= yes
+USE_PYDISTUTILS=yes
+
+MAN1= mailtray.1
+
+.include <bsd.port.mk>
diff --git a/mail/mailtray/distinfo b/mail/mailtray/distinfo
new file mode 100644
index 000000000000..6ddb514840cb
--- /dev/null
+++ b/mail/mailtray/distinfo
@@ -0,0 +1,2 @@
+SHA256 (mailtray-1.4.tar.gz) = 3447de80bd6b24c626ea563dd61c682892a6cf00db317ed4de060b78a4686077
+SIZE (mailtray-1.4.tar.gz) = 153933
diff --git a/mail/mailtray/pkg-descr b/mail/mailtray/pkg-descr
new file mode 100644
index 000000000000..af2fa8f61203
--- /dev/null
+++ b/mail/mailtray/pkg-descr
@@ -0,0 +1,7 @@
+Mailtray is a Python program that displays a tray icon which informs you when
+you have new email.
+
+It's simple, easy, fairly environment-independent, and "just works" without
+tons of (Gnome|KDE|..) dependencies.
+
+WWW: http://code.google.com/p/mailtray/
diff --git a/mail/mailtray/pkg-plist b/mail/mailtray/pkg-plist
new file mode 100644
index 000000000000..3945567a758a
--- /dev/null
+++ b/mail/mailtray/pkg-plist
@@ -0,0 +1,8 @@
+bin/mailtray
+%%DATADIR%%/alert.wav
+%%DATADIR%%/mailtrayrc_default.py
+%%DATADIR%%/icons/disconnect.png
+%%DATADIR%%/icons/newmail.png
+%%DATADIR%%/icons/nomail.png
+@dirrm %%DATADIR%%/icons
+@dirrm %%DATADIR%%