aboutsummaryrefslogtreecommitdiffstats
path: root/math/GiNaC/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-11-26 21:18:55 +0800
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-11-26 21:18:55 +0800
commit8408ed8657475f978f43d085fd220f2a4e29e271 (patch)
tree3c49a8277901ced46332cf890229e0fdb2a4a787 /math/GiNaC/Makefile
parentd4634bbee230a3c17214b517917c3255d28265e7 (diff)
downloadfreebsd-ports-gnome-8408ed8657475f978f43d085fd220f2a4e29e271.tar.gz
freebsd-ports-gnome-8408ed8657475f978f43d085fd220f2a4e29e271.tar.zst
freebsd-ports-gnome-8408ed8657475f978f43d085fd220f2a4e29e271.zip
upgrade to 1.0.1
Diffstat (limited to 'math/GiNaC/Makefile')
-rw-r--r--math/GiNaC/Makefile14
1 files changed, 12 insertions, 2 deletions
diff --git a/math/GiNaC/Makefile b/math/GiNaC/Makefile
index 9b2179172c73..b207b3657ac9 100644
--- a/math/GiNaC/Makefile
+++ b/math/GiNaC/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= GiNaC
-PORTVERSION= 0.9.0
+PORTVERSION= 1.0.1
CATEGORIES= math
MASTER_SITES= ftp://ftpthep.physik.uni-mainz.de/pub/GiNaC/ \
http://www.ginac.de/
@@ -18,7 +18,6 @@ USE_BZIP2= yes
LIB_DEPENDS= cln:${PORTSDIR}/math/cln
USE_LIBTOOL= yes
-
USE_GMAKE= yes
USE_NEWGCC= yes
@@ -26,4 +25,15 @@ INSTALLS_SHLIB= yes
MAN1= ginsh.1 viewgar.1 ginac-config.1
+post-patch:
+ @${PERL} -pi -e "s,sstream,strstream,g" ${WRKSRC}/configure
+.for file in numeric.cpp tostring.h
+ @${PERL} -pi -e "s,sstream,strstream,g ; \
+ s,stringstream,strstream,g" ${WRKSRC}/ginac/${file}
+.endfor
+
+pre-build:
+ @(cd ${WRKSRC} ; \
+ ${LN} -sf ${PREFIX}/bin/libtool)
+
.include <bsd.port.mk>