aboutsummaryrefslogtreecommitdiffstats
path: root/math/Makefile
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-10-19 21:50:08 +0800
committermiwi <miwi@FreeBSD.org>2008-10-19 21:50:08 +0800
commit661e421253c1f4e4ecd9f372f2f4d4043fa3e294 (patch)
tree874891bfad00c7d9beee241a918808553de842b6 /math/Makefile
parent1b0dbf22f9bc30fedd9092dd76a69695fc18664b (diff)
downloadfreebsd-ports-gnome-661e421253c1f4e4ecd9f372f2f4d4043fa3e294.tar.gz
freebsd-ports-gnome-661e421253c1f4e4ecd9f372f2f4d4043fa3e294.tar.zst
freebsd-ports-gnome-661e421253c1f4e4ecd9f372f2f4d4043fa3e294.zip
Mpmath is a pure-Python library for multiprecision floating-point
arithmetic. It provides an extensive set of transcendental functions, unlimited exponent sizes, complex numbers, interval arithmetic, numerical integration and differentiation, root-finding, linear algebra, and much more. Almost any calculation can be performed just as well at 10-digit or 1000-digit precision, and in many cases mpmath implements asymptotically fast algorithms that scale well for extremely high precision work. If available, mpmath will (optionally) use gmpy to speed up high precision operations. WWW: http://code.google.com/p/mpmath/ PR: ports/128133 Submitted by: Wen Heping <wenheping at gmail.com>
Diffstat (limited to 'math/Makefile')
-rw-r--r--math/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 7c6b8b8fad30..0aaa8816a708 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -393,6 +393,7 @@
SUBDIR += py-igraph
SUBDIR += py-mathdom
SUBDIR += py-matplotlib
+ SUBDIR += py-mpmath
SUBDIR += py-mpz
SUBDIR += py-networkx
SUBDIR += py-numarray